summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorrandomdan <randomdan@localhost>2010-06-05 17:39:40 +0000
committerrandomdan <randomdan@localhost>2010-06-05 17:39:40 +0000
commit297daab2fe4da8bdc30db8c59672241d1299653f (patch)
tree175b8f1f521443331e69ea28cf8abe30bafdc459 /dev-db
parentbeta of pgadmin for pg9 (diff)
downloadportage-297daab2fe4da8bdc30db8c59672241d1299653f.tar.bz2
portage-297daab2fe4da8bdc30db8c59672241d1299653f.tar.xz
portage-297daab2fe4da8bdc30db8c59672241d1299653f.zip
dbmaint v0.2
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/dbmaint/Manifest1
-rw-r--r--dev-db/dbmaint/dbmaint-0.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-db/dbmaint/Manifest b/dev-db/dbmaint/Manifest
new file mode 100644
index 0000000..da78a8d
--- /dev/null
+++ b/dev-db/dbmaint/Manifest
@@ -0,0 +1 @@
+EBUILD dbmaint-0.2.ebuild 533 RMD160 7351fff894ae025229084c0a56f73e476d1fea0e SHA1 8473024cebd5a4d3d509e7148177d62510300a4e SHA256 e7f3c00234fd74e354bbbd814c1a462bc79e70435e5018ff669d9246c9399100
diff --git a/dev-db/dbmaint/dbmaint-0.2.ebuild b/dev-db/dbmaint/dbmaint-0.2.ebuild
new file mode 100644
index 0000000..5769322
--- /dev/null
+++ b/dev-db/dbmaint/dbmaint-0.2.ebuild
@@ -0,0 +1,31 @@
+inherit subversion
+
+DESCRIPTION="Programable database data mangler"
+HOMEPAGE="http://dbmaint.randomdan.homeip.net"
+
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-db/unixODBC
+ dev-libs/libxml2"
+RDEPEND="${DEPEND}"
+ESVN_REPO_URI="svn+ssh://svn.random.lan/var/svn/src/tags/${PF}"
+
+src_compile() {
+ cd ${S}/libmisc || die
+ econf || die
+ emake || die
+ cd ${S}/libodbcpp || die
+ econf || die
+ emake || die
+ cd ${S}/dbmaint || die
+ econf || die
+ emake || die
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe ${S}/dbmaint/dbmaint
+}