summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorrandomdan <randomdan@localhost>2010-06-04 19:23:33 +0000
committerrandomdan <randomdan@localhost>2010-06-04 19:23:33 +0000
commit96b6fbc3be3740cf2b25f8e53ed2ac0ed36d89bb (patch)
tree0847aa5a8544faa4653ab44a854aee9915912ed6 /dev-db
parentInclude FastCGI support (diff)
downloadportage-96b6fbc3be3740cf2b25f8e53ed2ac0ed36d89bb.tar.bz2
portage-96b6fbc3be3740cf2b25f8e53ed2ac0ed36d89bb.tar.xz
portage-96b6fbc3be3740cf2b25f8e53ed2ac0ed36d89bb.zip
beta of pgadmin for pg9
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pgadmin3/Manifest3
-rw-r--r--dev-db/pgadmin3/files/1.12.0-as_needed_ssl_detect_broken.patch10
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.12.0_beta2.ebuild58
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-db/pgadmin3/Manifest b/dev-db/pgadmin3/Manifest
new file mode 100644
index 0000000..7b6228d
--- /dev/null
+++ b/dev-db/pgadmin3/Manifest
@@ -0,0 +1,3 @@
+AUX 1.12.0-as_needed_ssl_detect_broken.patch 255 RMD160 dc0f2e426c3701771d52ab359e40996a068ba260 SHA1 3475c48ec1270503b4edd9fb473a65eb09e9e56a SHA256 35440743518dc3eb1bda462a65b946b13da94e152d1bb4b9263b6eb909d5e963
+DIST pgadmin3-1.12.0-beta2.tar.gz 12968769 RMD160 3ba2b96f77febe8cb83eb2b8f040444f0a743c1c SHA1 5ee33aa8b371a31462de23a780ccddaa47b55f7e SHA256 07f234a4f1bab66c65c07c318062f2386659a1de33169445047b47323b710f6a
+EBUILD pgadmin3-1.12.0_beta2.ebuild 1406 RMD160 75b8949a729b39c172213c45f66695a753509bd0 SHA1 81d48513fb11a70d65bdcf4ba473533224636791 SHA256 4c1c2dfa0624c1bd063821eb2a9f0e1abf1e45124f0d98d27c65f588a96f534c
diff --git a/dev-db/pgadmin3/files/1.12.0-as_needed_ssl_detect_broken.patch b/dev-db/pgadmin3/files/1.12.0-as_needed_ssl_detect_broken.patch
new file mode 100644
index 0000000..a727a13
--- /dev/null
+++ b/dev-db/pgadmin3/files/1.12.0-as_needed_ssl_detect_broken.patch
@@ -0,0 +1,10 @@
+--- acinclude.m4 2010-02-25 22:14:24.000000000 +0000
++++ acdan 2010-06-04 19:07:25.711862588 +0100
+@@ -506,6 +506,7 @@
+ PG_SSL="no"
+ fi
+ else
++ LIBS="${LIBS} -lssl"
+ AC_CHECK_LIB(pq, SSL_connect, [PG_SSL=yes], [PG_SSL=no])
+ fi
+ fi
diff --git a/dev-db/pgadmin3/pgadmin3-1.12.0_beta2.ebuild b/dev-db/pgadmin3/pgadmin3-1.12.0_beta2.ebuild
new file mode 100644
index 0000000..0c441a0
--- /dev/null
+++ b/dev-db/pgadmin3/pgadmin3-1.12.0_beta2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/pgadmin3-1.10.2.ebuild,v 1.1 2010/03/17 20:53:22 patrick Exp $
+
+EAPI="1"
+
+WX_GTK_VER="2.8"
+
+inherit wxwidgets eutils autotools
+
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+
+DESCRIPTION="wxWidgets GUI for PostgreSQL."
+HOMEPAGE="http://www.pgadmin.org/"
+Pnv="pgadmin3-1.12.0-beta2"
+SRC_URI="http://wwwmaster.postgresql.org/redir/170/h/pgadmin3/release/v1.12.0-beta2/src/${Pnv}.tar.gz"
+LICENSE="Artistic"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="x11-libs/wxGTK:2.8
+ virtual/postgresql-base
+ >=dev-libs/libxml2-2.5
+ >=dev-libs/libxslt-1.1"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}/${Pnv}"
+ epatch "${FILESDIR}/1.12.0-as_needed_ssl_detect_broken.patch"
+ eautoreconf
+}
+
+src_compile() {
+ einfo "${WORKDIR}/${Pnv}"
+ cd "${WORKDIR}/${Pnv}"
+ econf \
+ --with-wx-version=2.8 \
+ $(use_enable debug)
+ emake || die "emake failed"
+}
+
+src_install() {
+ cd "${WORKDIR}/${Pnv}"
+ emake DESTDIR="${D}" install || die "einstall failed"
+
+ insinto /usr/share/pixmaps
+ newins "pgadmin/include/images/elephant48.xpm" pgadmin3.xpm
+
+ insinto /usr/share/pgadmin3
+ newins "pgadmin/include/images/elephant48.xpm" pgadmin3.xpm
+
+ insinto /usr/share/applications
+ doins "pkg/pgadmin3.desktop"
+
+ # Fixing world-writable files
+ chmod -R go-w "${D}/usr/share"
+}