summaryrefslogtreecommitdiff
path: root/virtual/miller-base
diff options
context:
space:
mode:
Diffstat (limited to 'virtual/miller-base')
-rw-r--r--virtual/miller-base/Manifest1
-rw-r--r--virtual/miller-base/miller-base-6-r26.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/virtual/miller-base/Manifest b/virtual/miller-base/Manifest
index ea85dd3..074e761 100644
--- a/virtual/miller-base/Manifest
+++ b/virtual/miller-base/Manifest
@@ -16,3 +16,4 @@ EBUILD miller-base-6-r22.ebuild 1862 RMD160 afaf2e96c5041d17836f6f3cf71713e75a7c
EBUILD miller-base-6-r23.ebuild 1994 RMD160 b6c73b60515bd886919722caff44b5293d0412ad SHA1 cc769f32c57fde9069cc47b82823636e769bcf82 SHA256 3111792c081e5d12893d07dc46fabe8a1b7d014bf77fa1cdb1724f9d60f8ca96
EBUILD miller-base-6-r24.ebuild 2208 RMD160 0513c248fd999884013960cab53dc57f6233fd95 SHA1 b94f615027a2e47171e3a339e6dd4918d1afba60 SHA256 7dbad9aad6f33982df79519009b60b4ea833f38550b1b10aa21f20a6310cb8fb
EBUILD miller-base-6-r25.ebuild 2230 RMD160 08f056b00edda07d4470d2b799b4e18f25f9d640 SHA1 55dd626296968b263b8ee20efca5f49f52f3b7bb SHA256 a79d674c28bb15745006dcf3b3949102206a109229c678d28b68a16d63b7a8b4
+EBUILD miller-base-6-r26.ebuild 2420 RMD160 841b7e2085cb07b86784d40bd5efc2cfe6968ea1 SHA1 719db4f48fec1c9919eceda1b5b47f096e0cb488 SHA256 29c4cf9aa71f404bcbdefde0edd67c750b388f0db4489eaf9349058214a24056
diff --git a/virtual/miller-base/miller-base-6-r26.ebuild b/virtual/miller-base/miller-base-6-r26.ebuild
new file mode 100644
index 0000000..94b1660
--- /dev/null
+++ b/virtual/miller-base/miller-base-6-r26.ebuild
@@ -0,0 +1,82 @@
+DESCRIPTION="Virtual for Miller servers"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 mips ppc ppc-macos sparc sparc-fbsd x86 x86-fbsd"
+IUSE="cdr nohardenedkernel nohourlyupdate fuse xfs bash-completion nomedia
+minimal"
+
+DEPEND="
+ !minimal? ( www-servers/apache )
+ net-fs/glusterfs
+ sys-apps/inotail
+ cdr? ( app-cdr/k3b )
+ !nomedia? ( media-tv/mythtv )
+ sys-apps/hdparm
+ sys-libs/unscd
+ !minimal? ( net-dns/bind-tools )
+ fuse? ( sys-fs/sshfs-fuse )
+ !minimal? ( || ( net-fs/mount-cifs net-fs/samba-client ) )
+ xfs? ( sys-fs/xfsdump )
+ sys-fs/lvm2
+ >=app-portage/gentoolkit-0.2.1
+ sys-process/vixie-cron
+ !minimal? ( sys-apps/eject )
+ app-admin/sudo
+ mail-client/mailx
+ sys-apps/pciutils
+ !minimal? ( app-dicts/myspell-en )
+ net-misc/ntp
+ !minimal? ( net-analyzer/netcat )
+ !minimal? ( net-ftp/ncftp )
+ dev-util/cvs
+ !minimal? ( x11-apps/xauth )
+ sys-process/lsof
+ app-portage/layman
+ !minimal? ( net-analyzer/net-snmp )
+ app-admin/syslog-ng
+ app-admin/logrotate
+ !minimal? ( app-admin/gkrellm )
+ app-antivirus/clamav
+ nohardenedkernel? ( sys-kernel/gentoo-sources )
+ !nohardenedkernel? ( sys-kernel/hardened-sources )
+ !minimal? ( app-text/unix2dos )
+ app-misc/screen
+ sys-boot/grub
+ app-vim/gentoo-syntax
+ sys-apps/kexec-tools
+ !minimal? ( app-text/dos2unix )
+ sys-auth/pam_ldap
+ sys-auth/nss_ldap
+ app-editors/gvim
+ dev-util/git
+ !minimal? ( dev-util/strace )
+ bash-completion? ( app-shells/bash-completion )
+ "
+
+src_install() {
+ exeinto /etc/cron.weekly
+ newexe "${FILESDIR}"/weekly-av-scan.cron av-scan || die
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/daily-av-update.cron av-update || die
+
+ if [ -n "${UPDATETIME}" ]; then
+ mkdir -p ${D}/etc/cron.d
+ echo "${UPDATETIME} root /sbin/gentoo-portage-update" > ${D}/etc/cron.d/gentoo-portage-update
+ exeinto /sbin
+ else
+ use nohourlyupdate && exeinto /etc/cron.daily
+ use !nohourlyupdate && exeinto /etc/cron.hourly
+ fi
+ newexe "${FILESDIR}"/update.portage.cron-2 gentoo-portage-update || die
+
+ exeinto /etc/portage/postsync.d/
+ newexe "${FILESDIR}"/sync-distclean-exec.cron 98-portage-distclean-exec || die
+ newexe "${FILESDIR}"/auto-download-packages 99-auto-download-package || die
+ newexe "${FILESDIR}"/auto-update-overlays 01-auto-update-overlays || die
+ newexe "${FILESDIR}"/write-new-updates 50-write-new-updates || die
+
+ exeinto /sbin
+ newexe "${FILESDIR}"/update-install update-install || die
+ newexe "${FILESDIR}"/update-kernel update-kernel || die
+}