summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ocfs2-tools/Manifest2
-rw-r--r--sys-fs/ocfs2-tools/ocfs2-tools-1.8.7.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/sys-fs/ocfs2-tools/Manifest b/sys-fs/ocfs2-tools/Manifest
index 5073807..ca29c81 100644
--- a/sys-fs/ocfs2-tools/Manifest
+++ b/sys-fs/ocfs2-tools/Manifest
@@ -1,4 +1,6 @@
AUX ocfs2.confd 1494 BLAKE2B 6390651f1d07fb82c98e7058a7ffa1267672fafc64b84fc320d58076de723e6472b4587ec7fd7ad6345a310f225b1a66f50296e39e772ff4a2c22d7fafa6943b SHA512 7cb63e889fad081d41283534032f41413bbb37202391d7a0f08f590170dc7a11c45bd90946910ba7680e401e4cb80eeb70fe85eb55ecbe9c16507e4d3d0b08c9
AUX ocfs2.initd 4004 BLAKE2B 8d9f839d9ad7607b45e768b95ebc589c0e6fb729d2fff3afac04cd28f5b72f2a2d958c8e9153ae8db7a5cc01dd4a8e397f6514f3fd4f615317ed6acbb2953208 SHA512 ab35d6916871eed469c3e05470dec6913b96bf806fd67d090f5a6af9eb28e4cd648707d768c0a47f6d2926f969421837adf9ef714b336c929b73df785dbfae1b
DIST ocfs2-tools-1.8.6.tar.gz 1492057 BLAKE2B 0275d10d4b07c20cb99920bc522331f9c51f77e6d978807b02c32ae732eeb1b1ab666e26afe70ead2c029d17e3aa0b0347d80e808458fbea1e32783a1a942f7b SHA512 71abe46152b065b9ba7db192b9f14ed28a1fbf0fa68822d4e8188c6f1654dfaaa29ae72ea4219bd68e7fade7791a08d36cbd5af5a16a2ee96e194ecb6f0d950b
+DIST ocfs2-tools-1.8.7.tar.gz 1492231 BLAKE2B 614ec2627dd70c2130bbe15c92154ff30ddec09c1c8a5571a93fceb3b45c139bc6881bad7abaff868084baddb8989497b482baa36b41030ad4341c1891fbd646 SHA512 10246ccb53ec1da59f2117f047bd8a9d7b4e5471e01dd262e8a694b530be2356d843f8faa6cf559f24ca39db45572d57540ee49a373b7658db23ff08c22541bb
EBUILD ocfs2-tools-1.8.6-r1.ebuild 1354 BLAKE2B 26a9f58bcec1c04472412f15b6e6b37a521251ba6808d11c4fc649a2af2686396f5f4d371e77c58bc1722eff39f36a8d934128cfd14e5ebd0920cd1872ab7642 SHA512 6576ea3aadb5f1cd6997e8bac0ef18cc3d63183813345688d82686f6a888db5895b649ddc7a6d0f7b025eb2b0e6cb02f3e6066fbdbf2bfabea92e74ad0ee22a7
+EBUILD ocfs2-tools-1.8.7.ebuild 1354 BLAKE2B 26a9f58bcec1c04472412f15b6e6b37a521251ba6808d11c4fc649a2af2686396f5f4d371e77c58bc1722eff39f36a8d934128cfd14e5ebd0920cd1872ab7642 SHA512 6576ea3aadb5f1cd6997e8bac0ef18cc3d63183813345688d82686f6a888db5895b649ddc7a6d0f7b025eb2b0e6cb02f3e6066fbdbf2bfabea92e74ad0ee22a7
diff --git a/sys-fs/ocfs2-tools/ocfs2-tools-1.8.7.ebuild b/sys-fs/ocfs2-tools/ocfs2-tools-1.8.7.ebuild
new file mode 100644
index 0000000..3a90c0b
--- /dev/null
+++ b/sys-fs/ocfs2-tools/ocfs2-tools-1.8.7.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="7"
+inherit autotools
+
+DESCRIPTION="Support programs for the Oracle Cluster Filesystem 2"
+HOMEPAGE="http://oss.oracle.com/projects/ocfs2-tools/ https://github.com/markfasheh/ocfs2-tools"
+SRC_URI="https://github.com/markfasheh/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug external"
+
+RDEPEND="
+ dev-libs/libaio
+ sys-apps/util-linux
+ external? (
+ sys-cluster/libdlm
+ sys-cluster/pacemaker[-heartbeat]
+ )
+ sys-fs/e2fsprogs
+ sys-libs/ncurses
+ sys-libs/readline
+ sys-process/psmisc
+"
+# 99% of deps this thing has is automagic
+# specialy cluster things corosync/pacemaker
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}-${P}"
+
+DOCS=(
+ "${S}/documentation/samples/cluster.conf"
+ "${S}/documentation/users_guide.txt"
+)
+
+MAKEOPTS+=" -j1"
+
+src_prepare() {
+ default
+ # gentoo uses /sys/kernel/dlm as dlmfs mountpoint
+ sed -e 's:"/dlm/":"/sys/kernel/dlm":g' \
+ -i libo2dlm/o2dlm_test.c \
+ -i libocfs2/dlm.c || die "sed failed"
+ AT_M4DIR=. eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug debug) \
+ $(use_enable debug debugexe) \
+ --enable-dynamic-fsck \
+ --enable-dynamic-ctl
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}/ocfs2.initd" ocfs2
+ newconfd "${FILESDIR}/ocfs2.confd" ocfs2
+}