summaryrefslogtreecommitdiff
path: root/sys-auth
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_mount/Manifest2
-rw-r--r--sys-auth/pam_mount/pam_mount-1.22.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/sys-auth/pam_mount/Manifest b/sys-auth/pam_mount/Manifest
new file mode 100644
index 0000000..1bed851
--- /dev/null
+++ b/sys-auth/pam_mount/Manifest
@@ -0,0 +1,2 @@
+DIST pam_mount-1.22.tar.bz2 326034 RMD160 b7b27234e0c2685476c7cda2e6360fd91af9006d SHA1 46dab50820beb75dacd045d66593c7bee6556b51 SHA256 e626b6faab394822a469178acb1e59bbbb63c4a56edf9c50172684a84ccbce02
+EBUILD pam_mount-1.22.ebuild 950 RMD160 46530176bced2f6f0f6646537db5b07004f4779e SHA1 11ebd6fe129c3fbf27bec8783c80006bf46a36ac SHA256 528e184816309afdfaca78cc3d8a87512a9081e13e82a0e578281da76b5c7e46
diff --git a/sys-auth/pam_mount/pam_mount-1.22.ebuild b/sys-auth/pam_mount/pam_mount-1.22.ebuild
new file mode 100644
index 0000000..7a3200c
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-1.22.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvs/lportage/sys-auth/pam_mount/pam_mount-1.22.ebuild,v 1.1 2009-04-10 20:28:11 randomdan Exp $
+
+inherit multilib
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt"
+DEPEND=">=sys-libs/pam-0.99
+ dev-libs/openssl
+ >=sys-libs/libhx-2.5
+ dev-libs/libxml2
+ dev-util/pkgconfig"
+RDEPEND=">=sys-libs/pam-0.99
+ dev-libs/openssl
+ >=sys-libs/libhx-2.5
+ dev-libs/libxml2
+ crypt? ( >=sys-fs/cryptsetup-1.0.5 )
+ sys-process/lsof"
+
+src_compile() {
+ econf --with-slibdir="/$(get_libdir)" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/*.txt || die "dodoc failed"
+}