summaryrefslogtreecommitdiff
path: root/media-video
diff options
context:
space:
mode:
Diffstat (limited to 'media-video')
-rw-r--r--media-video/openshot/Manifest2
-rw-r--r--media-video/openshot/openshot-1.0.0-r1.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/media-video/openshot/Manifest b/media-video/openshot/Manifest
new file mode 100644
index 0000000..905a9dd
--- /dev/null
+++ b/media-video/openshot/Manifest
@@ -0,0 +1,2 @@
+DIST openshot_1.0.0-1.tar.gz 11567926 RMD160 572d19dd040009185c9baef1e598dc1040a4f4c4 SHA1 751e054c4111d41efaa117eada9300776fb0481e SHA256 2de0e39940705306da78b018e460087a26610272f3e43ebe977a37f194e2feda
+EBUILD openshot-1.0.0-r1.ebuild 1268 RMD160 f332454a8f5bf8d24b2a47eb18866ce1aa4291bb SHA1 cffbc1297ad48ed84868edcd969d231b95476632 SHA256 5a0656c4d13b4fbdd713b075874c3336d8c704d60c3971fd8ce2744056e59c4c
diff --git a/media-video/openshot/openshot-1.0.0-r1.ebuild b/media-video/openshot/openshot-1.0.0-r1.ebuild
new file mode 100644
index 0000000..ea9fef6
--- /dev/null
+++ b/media-video/openshot/openshot-1.0.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvs/lportage/media-video/openshot/openshot-1.0.0-r1.ebuild,v 1.1 2010-02-13 14:18:27 randomdan Exp $
+
+EAPI=2
+
+inherit distutils fdo-mime
+
+DESCRIPTION="OpenShot Video Editor is a non-linear video editor"
+HOMEPAGE="http://www.openshotvideo.com"
+SRC_URI="http://launchpad.net/openshot/1.0/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="faac faad ieee1394 jack mp3 quicktime theora vorbis x264"
+
+DEPEND=""
+RDEPEND="
+ >=dev-lang/python-2.5[xml]
+ dev-python/pygtk
+ dev-python/pygoocanvas
+ dev-python/pyxdg
+ gnome-base/librsvg
+ >=media-libs/mlt-0.4.6-r1[dv,ffmpeg,frei0r,melt,python,quicktime?,xml]
+ media-sound/sox[encode,ffmpeg]
+ media-video/ffmpeg[encode,ieee1394?,jack?,x264?,vorbis?,theora?,faac?,faad?,mp3?]"
+
+src_prepare() {
+ # Avoid stuff covered by fdo-mime.eclass
+ # (update-mime-database update-desktop-database update-mime)
+ # export "FAKEROOTKEY=gentoo" does not work as this variable is filtered
+ # by portage
+ sed -i -e '/FAILED = /q' setup.py
+}
+
+# TODO: check stuff installed to site-packages as there are some parts
+# installed which shouldn't (locale, themes, profiles effects, etc...)
+# Afaik only python stuff should go there and the rest probably to
+# /usr/share/openshot
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}