summaryrefslogtreecommitdiff
path: root/media-tv
diff options
context:
space:
mode:
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythfs/Manifest4
-rw-r--r--media-tv/mythfs/mythfs-0.3.2.2.ebuild2
-rw-r--r--media-tv/mythfs/mythfs-0.3.3.ebuild39
3 files changed, 43 insertions, 2 deletions
diff --git a/media-tv/mythfs/Manifest b/media-tv/mythfs/Manifest
index b43dd5e..bba89d6 100644
--- a/media-tv/mythfs/Manifest
+++ b/media-tv/mythfs/Manifest
@@ -1,3 +1,5 @@
AUX service.conf 22 BLAKE2B ea8f574cac96db71e31fb292fa086451c8272eac4cf19c5cd9992e1bde0b38e9aa04da4c3a8f136e5ddbe814b11b2e09cf956976edcf1c54ab21f16d37001533 SHA512 2bf694aed9c0394df930c2558a7cb8f6d91a224dbdba9b0feae0d1b829d96c598e1da315413b9b13c791c2154f98d746fd7e0dfd7865ef6b54929f2ec9538bea
DIST mythfs-0.3.2.2.tar.xz 18212 BLAKE2B 29ec1a3adc67043387c50224becbf26d332d3eb1ae1660392c99e04916fbf6d5bfc63312ed21b3cdb3122a95a175774678bdc8b51b91186333da4d2dd7db500a SHA512 4cce00c8cc194b18f2c4c0fb92736c0009dfae989cca598b46fb08a1816dab0a59b8d8c4f66025ecacf534d5e1754a5a7236f71101b02932701821c386ff44c6
-EBUILD mythfs-0.3.2.2.ebuild 852 BLAKE2B 984947735b2250999916821282b6610c2cb28ad3af816e654bf0b721abad0af2083187a7c52fcfbfe4052b340ce5502b6e680fb84d196d0da6c50c1607addccb SHA512 2259454b6ef257351f240d0d6839b702af64eb1fea7dada1c8034e90e7dc0b46adbd6310f674e1be5ec1d4ff8e1c8b17110ab5687ed1c80f30d231aca43c9189
+DIST mythfs-0.3.3.tar.xz 18228 BLAKE2B ca3b311c35584b01d5813aaae99deb2c8af6dd9c18de062bb224bcf0f5f43d0143b20e1952fb7c0be89d1252436b63a11c68253db982b542e86fd7d9f3a7039b SHA512 395cb970c50d34167691cc541589de201553c9bdfebbba2c8bdcb4ac08df52a6a5ab4154416be2ede236e38db82352dd77b5f17e4100379ab74a63414f69336c
+EBUILD mythfs-0.3.2.2.ebuild 852 BLAKE2B 9e3b44e52e5543f6a4ace0389f35a3501eaa12903f2a730a919d532f83a9ce78abbef3ce770fa0146da2cc20f00d857833201a6e827c877009e1edec4b4ec6ef SHA512 e5fb01808779498269179ac511cc19b24307f528737790aa43103d04251b94819fdfeb0d0871d05b9062f353bc40089438fac2d58755afa17eceee05d226ec76
+EBUILD mythfs-0.3.3.ebuild 852 BLAKE2B b83d779bd802819185a3fb015ba316729f7aa5c1034250760b5a63e714d9cfc675f12a6e8497c786b3aa53880fe6b83dd5fe6c25aa7f029cca21aa18bae5a738 SHA512 823e5834d82af6bf66707e0b3d47fe56e537383274e173618749c54e453b6306ff310967860be1a77d86b7119fc61aab10139d93b6bfe24afb4b0a3db21726c0
diff --git a/media-tv/mythfs/mythfs-0.3.2.2.ebuild b/media-tv/mythfs/mythfs-0.3.2.2.ebuild
index a131a3f..0b6f9e3 100644
--- a/media-tv/mythfs/mythfs-0.3.2.2.ebuild
+++ b/media-tv/mythfs/mythfs-0.3.2.2.ebuild
@@ -18,7 +18,7 @@ RDEPEND="
dev-libs/libdbpp-mysql
dev-libs/boost:=
>=dev-libs/icetray-0.3:=
- >=sys-cluster/netfs-1.3
+ =sys-cluster/netfs-1.3*
dev-libs/libadhocutil:=
"
DEPEND="${RDEPEND}
diff --git a/media-tv/mythfs/mythfs-0.3.3.ebuild b/media-tv/mythfs/mythfs-0.3.3.ebuild
new file mode 100644
index 0000000..8802e3f
--- /dev/null
+++ b/media-tv/mythfs/mythfs-0.3.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="7"
+inherit bjam systemd
+
+DESCRIPTION="NetFS daemon module for MythTV"
+HOMEPAGE="http://mythfs.randomdan.homeip.net/"
+SRC_URI="https://git.randomdan.homeip.net/repo/${PN}/snapshot/${P}.tar.xz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+RDEPEND="
+ =sys-apps/icebox-service-1.11
+ >=dev-cpp/slicer-1.9:=[db]
+ dev-libs/libdbpp-mysql
+ dev-libs/boost:=
+ >=dev-libs/icetray-0.3:=
+ =sys-cluster/netfs-1.4*
+ dev-libs/libadhocutil:=
+"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/boost-build"
+
+src_compile() {
+ bjambuild mythfs//service
+}
+
+src_install() {
+ bjaminstall mythfs//install
+ insinto /etc/mythfs
+ doins mythfs/etc/icebox.config
+ insinto $(systemd_get_systemunitdir)/icebox@mythfs.service.d
+ doins mythfs/etc/service.conf
+}
+