summaryrefslogtreecommitdiff
path: root/media-tv
diff options
context:
space:
mode:
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythfs/Manifest2
-rw-r--r--media-tv/mythfs/mythfs-0.3.0.1.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/media-tv/mythfs/Manifest b/media-tv/mythfs/Manifest
index c763bd9..0941084 100644
--- a/media-tv/mythfs/Manifest
+++ b/media-tv/mythfs/Manifest
@@ -2,6 +2,8 @@ AUX service.conf 22 BLAKE2B ea8f574cac96db71e31fb292fa086451c8272eac4cf19c5cd999
DIST mythfs-0.2.2.4.tar.xz 18268 BLAKE2B 335cb00221a891d99c18ad44dc2139b32225e58ddd326b4602cda125db33eb432ab7695b57d91d59576bbf3d2b373b62a2239f62967599a1b5c4fb84922a6dba SHA512 4c01139734b2c5643799bd5b23e76f462fa6ddbda9975556b80ce6f2a80b7d4099a9c5979950e9d27bb8a33e4563b271d0b3f606e0b9c16a3f85323d572659a7
DIST mythfs-0.2.2.5.tar.xz 18160 BLAKE2B 51a72d65f4dbbe305e9e140dcbffc8a07a270f06a215836843a22d764a33d2426e0fb322801069286037be5ea71a01c4173286aa7bd978421786d9a82ae33ba9 SHA512 b84cfea82329777ac328193c41aae1261b8eb76c5b5a5486157436e4c74e62ba0b52b63834248ed8c319428a57ab083e21f90edaa4d0d3bf32c01630273641ab
DIST mythfs-0.2.3.tar.xz 18188 BLAKE2B 28590fdf6881292f7d71cac68ee31c896b09bb5da4ef8edef5a80498e18fe1d3e712f20266462d3c79f4dd3d18c53597d02b8110f22f3df156a73347ab135756 SHA512 5f74b503da4e49c12710fbc063d776b8224ce89f286bc04d8128fb2694f972284738c9e1c391f8bb6fec468520eacfa90adbec886808a11ccef1f544708eeb93
+DIST mythfs-0.3.0.1.tar.xz 18244 BLAKE2B 7a1b8e0cfa48d45938ab1e1233c6911bd32e6bc79b5f2e096194df121e8eea044da9a1908f45a7ba9bd81806f5ea7683e206a480f6c90c214491eb77c36e947b SHA512 56f70735c5e330a51d29bbd684e0121c9fee2ca3eedd46033c7809f126d9b1783ec9910683e9c4a18f59ed7074d9e407473c3674b377405d0ef5baf5a7d9042e
EBUILD mythfs-0.2.2.4.ebuild 866 BLAKE2B c1518773649900de38426c7428038c93302477113ca93bfa2ef1d7f94a6299cd43ac2349322f34ebc291cea10389d071cbb9a3bdf5f66f36a649229ee43a792a SHA512 aa872d66ca35ff03f8fa26125c89adc97be3decf2bfd89529b842fc3eda190348cd14dee6d54b90a7112d095b616dd2501dfd6412d5b02f7282160c94244702c
EBUILD mythfs-0.2.2.5.ebuild 827 BLAKE2B ca3f353610d89a5fb4b5d61a518d6105822374143d5ed52679736b49094f57e5293d3aa28c25c4645caf4abd0cd6de6d0d113487f46a9dc112bfb450ae718a1e SHA512 f70446d5553108dc155fa60cab9805a06be1b3b89daca39f63415520828c039344939ec10229a74259e251dc27853cc88c9dc1758496dac037a1a91704967248
EBUILD mythfs-0.2.3.ebuild 827 BLAKE2B ca3f353610d89a5fb4b5d61a518d6105822374143d5ed52679736b49094f57e5293d3aa28c25c4645caf4abd0cd6de6d0d113487f46a9dc112bfb450ae718a1e SHA512 f70446d5553108dc155fa60cab9805a06be1b3b89daca39f63415520828c039344939ec10229a74259e251dc27853cc88c9dc1758496dac037a1a91704967248
+EBUILD mythfs-0.3.0.1.ebuild 827 BLAKE2B a0dfbd1437fc7ff2e994a744cf93556d497150f0dced690a4036b8770f210be35f03ba6b724b48786ca6c20b55ee11d77f29109d6b385ae195c47ea0071448c2 SHA512 bc8e7c37137f85960f6bf6dec9b75c9f324d1a907bf0880b44f9ffcc53146296c9e28ffc3f5d0cc5d22d5972f83ee7e414967f5a117c099a270844d5f54fb4e3
diff --git a/media-tv/mythfs/mythfs-0.3.0.1.ebuild b/media-tv/mythfs/mythfs-0.3.0.1.ebuild
new file mode 100644
index 0000000..5c5387f
--- /dev/null
+++ b/media-tv/mythfs/mythfs-0.3.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit bjam systemd
+
+DESCRIPTION="NetFS daemon module for MythTV"
+HOMEPAGE="http://mythfs.randomdan.homeip.net/"
+SRC_URI="https://git.randomdan.homeip.net/repo/${PN}/snapshot/${P}.tar.xz"
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="
+ =sys-apps/icebox-service-1.11
+ >=dev-cpp/slicer-1.8:=[db]
+ dev-libs/libdbpp-mysql
+ dev-libs/boost
+ >=dev-libs/icetray-0.2:=
+ >=sys-cluster/netfs-1.3
+ dev-libs/libadhocutil:=
+"
+RDEPEND="${DEPEND}
+ dev-util/boost-build"
+
+src_compile() {
+ bjambuild mythfs//service
+}
+
+src_install() {
+ bjaminstall mythfs//install
+ insinto /etc/mythfs
+ doins mythfs/etc/icebox.config
+ insinto $(systemd_get_systemunitdir)/icebox@mythfs.service.d
+ doins mythfs/etc/service.conf
+}
+