summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-tv/mythtv-bindings/Manifest2
-rw-r--r--media-tv/mythtv-bindings/mythtv-bindings-0.29.1.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/media-tv/mythtv-bindings/Manifest b/media-tv/mythtv-bindings/Manifest
index 8876c25..d5d98b2 100644
--- a/media-tv/mythtv-bindings/Manifest
+++ b/media-tv/mythtv-bindings/Manifest
@@ -1,2 +1,4 @@
DIST mythtv-0.28.1.tar.gz 104477892 BLAKE2B bdecfc5723ec3495ab6e49c72caaa5c2dc62c75a11ce7524d3fd5cb8daec82b53b415591b6198eab00322bbbcaff2de7d4f1b7a165d449007f4c3742a69d304b SHA512 67a81858cd19b90f519113b234119ecc248366d8545c862d887755f256cddf04d9ca16a7bf67f63e06f7628730e7dbde2a2099ca8aaeb9061b2e55a5a0b7d5e7
+DIST mythtv-0.29.1.tar.gz 105656634 BLAKE2B 8b9dfc6b1e1178bfd1b35e8d499afe570edeb1f07cefa64fc91c2ed74f8155f5ca00cee49a024848f715c0bb782fc22f3c4d04fd8eac8562d108e105d3a41421 SHA512 c80d84c40c019d093d44487fb4cd07d9ce3174781ff8f24a4709fd10294cb8f6186b3e480dad3a09f7a496835fa0cffcc9eca114f807794b693ffcd57acd4e39
EBUILD mythtv-bindings-0.28.1-r1.ebuild 840 BLAKE2B b62caccb8b58c6b47c69b7e2328136ac55a1c92a5c902f83dd232fa43ff2fb819eca8e8d9b453239224f044780e57fa04413dd01c56eba60b6f8f218753153f2 SHA512 c581b02d8153427a5d0a8c77e1c2ac5a86cb1cb433318d1d5c7e746ded22691596b020c7c6c4c9c5bee0ccefbde77ea87865f013ea47307c1215120b0dbdae61
+EBUILD mythtv-bindings-0.29.1.ebuild 840 BLAKE2B b8bc14cb09f04f69b8b01c39a650623e54177c250b0d9ea06f15adeac0faf097987ec458db910b16b7057cc3bc9e88f184c2589b61acc9c02296fb6c6be468dd SHA512 329cb0980df0dae0370e89597cd495367af754853a3513484a6319e750a39fd53d808d8c4d88213b7c08cc6f205c2dce21049c5a847446092245b93bd74aa1a2
diff --git a/media-tv/mythtv-bindings/mythtv-bindings-0.29.1.ebuild b/media-tv/mythtv-bindings/mythtv-bindings-0.29.1.ebuild
new file mode 100644
index 0000000..3a6e78b
--- /dev/null
+++ b/media-tv/mythtv-bindings/mythtv-bindings-0.29.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+BACKPORTS="d8a2db77f5731cf32c6d31127452391c6cf7f91f"
+MY_P=${P%_p*}
+MY_PV=${PV%_p*}
+
+inherit eutils vcs-snapshot
+
+DESCRIPTION="Homebrew PVR project bindings"
+HOMEPAGE="https://www.mythtv.org"
+SRC_URI="https://github.com/MythTV/mythtv/archive/${BACKPORTS}.tar.gz -> mythtv-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0/${PV}"
+IUSE="python perl"
+
+S="${WORKDIR}/mythtv-${BACKPORTS}/mythtv"
+
+src_unpack() {
+ tar -zxf "${DISTDIR}/${A}" mythtv-${BACKPORTS}/mythtv/bindings
+ find ${S} -name .gitignore -delete
+ find ${S} -name Makefile -delete
+}
+
+src_install() {
+ insinto /usr/share/mythtv/bindings
+ doins -r ${S}/bindings/php
+ use perl && doins -r ${S}/bindings/perl
+ use python && doins -r ${S}/bindings/python
+}
+