summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-vim/youcompleteme/Manifest1
-rw-r--r--app-vim/youcompleteme/youcompleteme-20200203-r3.ebuild118
2 files changed, 119 insertions, 0 deletions
diff --git a/app-vim/youcompleteme/Manifest b/app-vim/youcompleteme/Manifest
index 05fe8a4..adf9a11 100644
--- a/app-vim/youcompleteme/Manifest
+++ b/app-vim/youcompleteme/Manifest
@@ -5,3 +5,4 @@ DIST requests-futures-148451a06781d8196e5fb7e0e2bca7a765368ff1.tar.gz 7823 BLAKE
DIST ycmd-d3378ca3a3103535c14b104cb916dcbcdaf93eeb.tar.gz 4504015 BLAKE2B f79a3616c9ea2789cd10dd7e1d2b60d651c1f592b213cc0806f92ba12a115ddb3408ac7565e9e486c827ee87a8d4518c55a029f73d518749d3cfa0cd01cd5f00 SHA512 c4af6810995262a5c145ca8eeed9bf92c6ac204ac507f27571b68ed3258affae5734b5edfccdc6ae5f7fa310e1dbf9f74f2681d9c6d774685469ee314ada2573
DIST youcompleteme-124661f218e80b96c1f9f3d124e99f9a2fd2d83b.tar.gz 317144 BLAKE2B 6fc1d421a41e13923dd677deeabda9b5350c526558acae53d1e38eba4f911ba8d99c28f9b60fcbadd36452fdf985e1c01d456d14ffdb6e86c4bd3fcf38567939 SHA512 7442ad4b72f7782f055ae9ed9e94221a579448f3aaf7054246218e50ab0b19a4f451239a0c67e3c59c27e6e9d8a005273d8524f1acc8f1f855eb14c1b0731078
EBUILD youcompleteme-20200203-r2.ebuild 3648 BLAKE2B a9ca4e5ed0f393b875ff79d9306ee4c105a587aebf9f19e68e363a396ccd0e1b8dfac2324dee56a865dc7d78657ffac8ff141d5a7fbc9c4dde6e619fd89d64b7 SHA512 f0320d7014cde6346ff2efe7a279eff7c7025a53ec2ecc0c6365780cfdc382b3c551df07c257d8e308b484d539b2ee25394fa501543237fb82a660a8c74c9860
+EBUILD youcompleteme-20200203-r3.ebuild 3650 BLAKE2B 1bc78a904ffec7e37c5a501eb924e817d0d124346a88dabe449a0bfb6019452e465244cb7a0c674bec1efa3eb86ea54e4841757dd095deab0529f3d1a5d1d4d9 SHA512 03fe79bdfbca3274f786cbf3172dd2badcee6667f99c2d56042b5a28d4abf5bca0db1ca7579d663da9c18f5600ab2ed6011c5a66509e1f4c22e40a316da32c15
diff --git a/app-vim/youcompleteme/youcompleteme-20200203-r3.ebuild b/app-vim/youcompleteme/youcompleteme-20200203-r3.ebuild
new file mode 100644
index 0000000..7cb484d
--- /dev/null
+++ b/app-vim/youcompleteme/youcompleteme-20200203-r3.ebuild
@@ -0,0 +1,118 @@
+EAPI="7"
+PYTHON_COMPAT=( python3_{4,5,6,7,8} )
+inherit multilib python-single-r1 cmake-utils vim-plugin
+
+youcompletemev="124661f218e80b96c1f9f3d124e99f9a2fd2d83b"
+ycmdv="d3378ca3a3103535c14b104cb916dcbcdaf93eeb"
+reqfuv="148451a06781d8196e5fb7e0e2bca7a765368ff1"
+ossv="e1902915c6790bcec00b8d551199c8a3537d33c9"
+gocodev="5bee97b488366fd20b054d0861b89834ff5bbfb2"
+
+KEYWORDS="~amd64 ~x86"
+SRC_URI="
+ https://github.com/Valloric/YouCompleteMe/archive/$youcompletemev.tar.gz -> youcompleteme-$youcompletemev.tar.gz
+ https://github.com/Valloric/ycmd/archive/$ycmdv.tar.gz -> ycmd-$ycmdv.tar.gz
+ https://github.com/ross/requests-futures/archive/$reqfuv.tar.gz -> requests-futures-$reqfuv.tar.gz
+ csharp? ( https://github.com/OmniSharp/omnisharp-server/archive/$ossv.tar.gz -> omnisharp-server-$ossv.tar.gz )
+ go? ( https://github.com/nsf/gocode/archive/$gocodev.tar.gz -> gocode-$gocodev.tar.gz )
+"
+
+DESCRIPTION="vim plugin: a code-completion engine for Vim"
+HOMEPAGE="http://valloric.github.io/YouCompleteMe/"
+
+LICENSE="GPL-3"
+IUSE="+clang test go csharp"
+#REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ clang? ( sys-devel/clang:10 )
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.65:=[python,threads,${PYTHON_MULTI_USEDEP}]
+ || (
+ app-editors/vim[python,${PYTHON_SINGLE_USEDEP}]
+ app-editors/gvim[python,${PYTHON_SINGLE_USEDEP}]
+ )
+ ')
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/bottle[${PYTHON_MULTI_USEDEP}]
+ dev-python/future[${PYTHON_MULTI_USEDEP}]
+ dev-python/jedi[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ dev-python/sh[${PYTHON_MULTI_USEDEP}]
+ dev-python/waitress[${PYTHON_MULTI_USEDEP}]
+ ')
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/mock-1.0.1[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/nose-1.3.0[${PYTHON_MULTI_USEDEP}]
+ dev-cpp/gmock
+ dev-cpp/gtest
+ ')
+ )
+"
+
+S="${WORKDIR}/YouCompleteMe-$youcompletemev"
+CMAKE_IN_SOURCE_BUILD=1
+CMAKE_USE_DIR=${S}/third_party/ycmd/cpp
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_prepare() {
+ echo $RDEPEND
+ echo $DEPEND
+
+ eapply ${FILESDIR}/remove-python2-support.patch
+ for third_party_module in ycmd requests-futures; do
+ rm -r "${S}"/third_party/${third_party_module} || die "Failed to remove third party module ${third_party_module}"
+ done
+ mv ${WORKDIR}/ycmd-$ycmdv ${S}/third_party/ycmd
+ use csharp && mv ${WORKDIR}/omnisharp-server-$ossv ${S}/third_party/ycmd/third_party/omnisharp-server
+ use go && mv ${WORKDIR}/gocode-$gocodev ${S}/third_party/ycmd/third_party/gocode
+ mv ${WORKDIR}/requests-futures-$reqfuv ${S}/third_party/requests-futures
+ cmake-utils_src_prepare
+ default
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_CLANG_COMPLETER=$(usex clang)
+ -DUSE_SYSTEM_LIBCLANG=$(usex clang)
+ -DPATH_TO_LLVM_ROOT=/usr/lib/llvm/10
+ -DUSE_SYSTEM_BOOST=ON
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cd "${S}/third_party/ycmd/cpp/ycm/tests"
+ LD_LIBRARY_PATH="${EROOT}"/usr/$(get_libdir)/llvm \
+ ./ycm_core_tests || die
+
+ cd "${S}"/python/ycm
+
+ local dirs=( "${S}"/third_party/*/ "${S}"/third_party/ycmd/third_party/*/ )
+ local -x PYTHONPATH=${PYTHONPATH}:$(IFS=:; echo "${dirs[*]}")
+
+ nosetests || die
+}
+
+src_install() {
+ dodoc *.md third_party/ycmd/*.md
+ rm -r *.md *.sh COPYING.txt third_party/ycmd/cpp || die
+ rm -r third_party/ycmd/{*.md,*.sh} || die
+ find python third_party/ycmd -depth -name '*test*' -exec rm -r {} + || die
+ find python third_party/ycmd -depth -name '*examples*' -exec rm -r {} + || die
+ rm third_party/ycmd/third_party/clang/lib/libclang.so.* || die
+
+ vim-plugin_src_install
+
+ python_optimize "${ED}"
+ python_fix_shebang "${ED}"
+}