summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-fs/ocfs2-tools/Manifest2
-rw-r--r--sys-fs/ocfs2-tools/ocfs2-tools-1.8.4.2.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/sys-fs/ocfs2-tools/Manifest b/sys-fs/ocfs2-tools/Manifest
index 865ed58..c7271f0 100644
--- a/sys-fs/ocfs2-tools/Manifest
+++ b/sys-fs/ocfs2-tools/Manifest
@@ -1,4 +1,6 @@
AUX ocfs2.confd 1494 BLAKE2B 6390651f1d07fb82c98e7058a7ffa1267672fafc64b84fc320d58076de723e6472b4587ec7fd7ad6345a310f225b1a66f50296e39e772ff4a2c22d7fafa6943b SHA512 7cb63e889fad081d41283534032f41413bbb37202391d7a0f08f590170dc7a11c45bd90946910ba7680e401e4cb80eeb70fe85eb55ecbe9c16507e4d3d0b08c9
AUX ocfs2.initd 4004 BLAKE2B 8d9f839d9ad7607b45e768b95ebc589c0e6fb729d2fff3afac04cd28f5b72f2a2d958c8e9153ae8db7a5cc01dd4a8e397f6514f3fd4f615317ed6acbb2953208 SHA512 ab35d6916871eed469c3e05470dec6913b96bf806fd67d090f5a6af9eb28e4cd648707d768c0a47f6d2926f969421837adf9ef714b336c929b73df785dbfae1b
DIST ocfs2-tools-1.8.4.1.tar.gz 1481310 BLAKE2B 58ed030055003f60707be342ee23bd1ac0630d9300c351b58789009627dc276740293b9584c4502264f13b77f51fa59dfc6b18b5a4aa618f38f4bf4fffc95721 SHA512 2f7131cd8595e8f495f9321d0ed3370c1355b0795766dc868602b02bc7cf675d131b0fcab27c5cc249f7e92a683b914a566f5f410b4f6b01ec06e7b761a9a2f3
+DIST ocfs2-tools-1.8.4.2.tar.gz 1481445 BLAKE2B 056b84eceb374662ee036c57005879238cbc72deed3d8d4a57116bf039f7e1a05f492f934011eee5efff429215eef281c986ce11c56e601109a431aa365d5b8e SHA512 4d8ad9c6e7f7fc4c298d3a025530d2a567db0b60cc6845161b37d0ce583c62282a04f13b0d76c4a106d16cef9bf0b05d1ab939597b250ebbadecfdccb947d9cc
EBUILD ocfs2-tools-1.8.4.1-r1.ebuild 1471 BLAKE2B b382709910e243c0dfa2fd80814e0acaa64aea319e38f24df4b9efe729b9461d5517ec359f1119adcdbe0f0ebb9d3ad27c5b2b0f0bd206f7c420ebacb5a30ef3 SHA512 db35f8ca34c27bff9ecad3b0d742f97b38fa94571007c6cbc7d848444bbef4bcaaaa680bd201ab70318231f0b2133c3a2ea0fcf7d1816d173196ace486714f26
+EBUILD ocfs2-tools-1.8.4.2.ebuild 1471 BLAKE2B b382709910e243c0dfa2fd80814e0acaa64aea319e38f24df4b9efe729b9461d5517ec359f1119adcdbe0f0ebb9d3ad27c5b2b0f0bd206f7c420ebacb5a30ef3 SHA512 db35f8ca34c27bff9ecad3b0d742f97b38fa94571007c6cbc7d848444bbef4bcaaaa680bd201ab70318231f0b2133c3a2ea0fcf7d1816d173196ace486714f26
diff --git a/sys-fs/ocfs2-tools/ocfs2-tools-1.8.4.2.ebuild b/sys-fs/ocfs2-tools/ocfs2-tools-1.8.4.2.ebuild
new file mode 100644
index 0000000..a7ad94b
--- /dev/null
+++ b/sys-fs/ocfs2-tools/ocfs2-tools-1.8.4.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+inherit autotools eutils python-single-r1
+
+DESCRIPTION="Support programs for the Oracle Cluster Filesystem 2"
+HOMEPAGE="http://oss.oracle.com/projects/ocfs2-tools/ https://github.com/rascalDan/ocfs2-tools"
+SRC_URI="https://github.com/rascalDan/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug external gtk"
+
+RDEPEND="
+ dev-libs/libaio
+ sys-apps/util-linux
+ external? (
+ sys-cluster/libdlm
+ sys-cluster/pacemaker[-heartbeat]
+ )
+ sys-fs/e2fsprogs
+ sys-libs/ncurses
+ sys-libs/readline
+ sys-process/psmisc
+ gtk? (
+ dev-python/pygtk
+ )
+"
+# 99% of deps this thing has is automagic
+# specialy cluster things corosync/pacemaker
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}-${P}"
+
+DOCS=(
+ "${S}/documentation/samples/cluster.conf"
+ "${S}/documentation/users_guide.txt"
+)
+
+MAKEOPTS+=" -j1"
+
+src_prepare() {
+ # gentoo uses /sys/kernel/dlm as dlmfs mountpoint
+ sed -e 's:"/dlm/":"/sys/kernel/dlm":g' \
+ -i libo2dlm/o2dlm_test.c \
+ -i libocfs2/dlm.c || die "sed failed"
+ AT_M4DIR=. eautoreconf
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug debug) \
+ $(use_enable debug debugexe) \
+ $(use_enable gtk ocfs2console) \
+ --enable-dynamic-fsck \
+ --enable-dynamic-ctl
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}/ocfs2.initd" ocfs2
+ newconfd "${FILESDIR}/ocfs2.confd" ocfs2
+}