summaryrefslogtreecommitdiff
path: root/www-apps
diff options
context:
space:
mode:
authorrandomdan <randomdan@localhost>2009-11-13 17:22:08 +0000
committerrandomdan <randomdan@localhost>2009-11-13 17:22:08 +0000
commit20a6af0f8a3a12299a73466f26d449a58b3f681f (patch)
treedbe214f9cf422c66939fa570433f0868cd323a4c /www-apps
parentMyth still bust (diff)
downloadportage-20a6af0f8a3a12299a73466f26d449a58b3f681f.tar.bz2
portage-20a6af0f8a3a12299a73466f26d449a58b3f681f.tar.xz
portage-20a6af0f8a3a12299a73466f26d449a58b3f681f.zip
My fix for bug292697
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/bugzilla/Manifest6
-rw-r--r--www-apps/bugzilla/bugzilla-3.4.3-r1.ebuild104
-rw-r--r--www-apps/bugzilla/files/3.4/bugzilla.cron.daily5
-rw-r--r--www-apps/bugzilla/files/3.4/bugzilla.cron.tab1
-rw-r--r--www-apps/bugzilla/files/3.4/postinstall-en.txt12
-rw-r--r--www-apps/bugzilla/files/3.4/reconfig19
6 files changed, 147 insertions, 0 deletions
diff --git a/www-apps/bugzilla/Manifest b/www-apps/bugzilla/Manifest
new file mode 100644
index 0000000..8dd5870
--- /dev/null
+++ b/www-apps/bugzilla/Manifest
@@ -0,0 +1,6 @@
+AUX 3.4/bugzilla.cron.daily 115 RMD160 248700f6e811dd958fc3774b63c07d5e85ae477e SHA1 f7811fd35ce2abc6f8358abfdb5afd5b903d6cf4 SHA256 004cf631625c9a6f2b0aeccf2a2ead815008f59029326c13b28658586023b241
+AUX 3.4/bugzilla.cron.tab 54 RMD160 199919c125f0b214e17d6eadf909f7172b025137 SHA1 cbfc9f2051c3ce7f2f968f65a683c0fe7c8884df SHA256 ccbc9369bf52e6afd91e31ba2a89fa9a0bbbdae080e0fa7eb26d06fa21ef1eab
+AUX 3.4/postinstall-en.txt 579 RMD160 c2f5b399dc9804b97d9507e4b34ef99e372acb07 SHA1 cee9f8a6636d55a8086d5851dcc74026302b501a SHA256 c73178e29071fbdfe97b70b94e45c27923dc265f58c911d53d12bcbd6964ac17
+AUX 3.4/reconfig 349 RMD160 e5658372e9a1b67a39a0090e1a638261e05cf10a SHA1 93651b403924a270f1c693491c3c564999528b03 SHA256 8301aeda585234ed30cc8ffa8fc6e72138ed8e9d50c695dd2455dcc7d175aa50
+DIST bugzilla-3.4.3.tar.gz 2466883 RMD160 c22012fab4cf820165a95614478d1ff7d63c773e SHA1 6b899d2ef3bbafb843aba579ba196b9f29a8df68 SHA256 a2ab0e61e079d7aa316a4f70b2839f529fbca9444a6f66b3796f7c29d2aaf6ee
+EBUILD bugzilla-3.4.3-r1.ebuild 2517 RMD160 ab0cbe3b3e3582beb73c343f28193b9a0e25567f SHA1 eaac17247f967d4f3a4555380a6ca55c72287b79 SHA256 80aac51d97dcd785e88fd70af9bb96f4c331d2323443433ac82d5bf0b560b00d
diff --git a/www-apps/bugzilla/bugzilla-3.4.3-r1.ebuild b/www-apps/bugzilla/bugzilla-3.4.3-r1.ebuild
new file mode 100644
index 0000000..6d17e4e
--- /dev/null
+++ b/www-apps/bugzilla/bugzilla-3.4.3-r1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvs/lportage/www-apps/bugzilla/bugzilla-3.4.3-r1.ebuild,v 1.1 2009-11-13 17:22:08 randomdan Exp $
+
+EAPI="2"
+
+inherit webapp depend.apache versionator eutils
+
+MY_PB=$(get_version_component_range 1-2)
+
+DESCRIPTION="Bugzilla is the Bug-Tracking System from the Mozilla project"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/webtools/${P}.tar.gz"
+HOMEPAGE="http://www.bugzilla.org"
+
+LICENSE="MPL-1.1 NPL-1.1"
+# KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+IUSE="modperl extras graphviz mysql postgres"
+
+RDEPEND="
+ virtual/httpd-cgi
+ >=dev-lang/perl-5.8.8
+
+ >=dev-perl/DBI-1.601
+ >=dev-perl/DateTime-0.50
+ >=dev-perl/DateTime-Locale-0.43
+ >=dev-perl/DateTime-TimeZone-0.71
+ >=dev-perl/URI-1.38
+ || ( >=dev-perl/Email-MIME-1.900
+ ( >=dev-perl/Email-MIME-Modifier-1.442
+ >=dev-perl/Email-MIME-1.861 ) )
+ >=dev-perl/Email-MIME-Encodings-1.313
+ >=dev-perl/Email-Send-2.190
+ >=dev-perl/MIME-tools-5.427
+ >=dev-perl/Template-Toolkit-2.22
+ >=dev-perl/TimeDate-1.16
+ >=virtual/perl-CGI-3.29
+ >=virtual/perl-Digest-SHA-5.46
+ >=virtual/perl-File-Spec-3.27.01
+ >=virtual/perl-MIME-Base64-3.07
+
+ mysql? ( >=dev-perl/DBD-mysql-4.00.5 )
+ postgres? ( >=dev-perl/DBD-Pg-1.49 )
+ graphviz? ( media-gfx/graphviz )
+
+ modperl? (
+ >=dev-perl/Apache-DBI-1.06
+ www-apache/mod_perl:1
+ )
+
+ extras? (
+ dev-perl/Authen-SASL
+ >=dev-perl/Chart-2.4.1
+ dev-perl/Email-MIME-Attachment-Stripper
+ dev-perl/Email-Reply
+ >=dev-perl/GD-2.35
+ dev-perl/GDGraph
+ dev-perl/GDTextUtil
+ >=dev-perl/HTML-Parser-3.60
+ dev-perl/HTML-Scrubber
+ dev-perl/libwww-perl
+ >=dev-perl/PatchReader-0.9.5
+ dev-perl/perl-ldap
+ dev-perl/SOAP-Lite
+ dev-perl/Template-GD
+ dev-perl/XML-Twig
+ media-gfx/imagemagick[perl]
+ dev-perl/TheSchwartz
+ dev-perl/Daemon-Generic
+ )
+"
+# from extras we miss:
+# (nothing)
+
+want_apache modperl
+
+pkg_setup() {
+ depend.apache_pkg_setup modperl
+ webapp_pkg_setup
+}
+
+src_prepare() {
+ ecvs_clean
+}
+
+src_install () {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ for f in bugzilla.cron.daily bugzilla.cron.tab; do
+ doins "${FILESDIR}"/${MY_PB}/${f}
+ done
+
+ webapp_hook_script "${FILESDIR}"/${MY_PB}/reconfig
+ webapp_postinst_txt en "${FILESDIR}"/${MY_PB}/postinstall-en.txt
+ webapp_src_install
+
+ # bug #124282
+ chmod +x "${D}${MY_HTDOCSDIR}"/*.cgi
+ # configuration must be executable
+ chmod u+x "${D}${MY_HTDOCSDIR}"/checksetup.pl
+}
diff --git a/www-apps/bugzilla/files/3.4/bugzilla.cron.daily b/www-apps/bugzilla/files/3.4/bugzilla.cron.daily
new file mode 100644
index 0000000..e3e8658
--- /dev/null
+++ b/www-apps/bugzilla/files/3.4/bugzilla.cron.daily
@@ -0,0 +1,5 @@
+#!/bin/sh
+cd /var/www/bugzilla/
+./collectstats.pl
+./whineatnews.pl
+echo "*** Bugzilla nighlty flush has done! ***"
diff --git a/www-apps/bugzilla/files/3.4/bugzilla.cron.tab b/www-apps/bugzilla/files/3.4/bugzilla.cron.tab
new file mode 100644
index 0000000..0ac2ef6
--- /dev/null
+++ b/www-apps/bugzilla/files/3.4/bugzilla.cron.tab
@@ -0,0 +1 @@
+0 0 * * * /var/www/bugzilla/bugzilla.cron.daily
diff --git a/www-apps/bugzilla/files/3.4/postinstall-en.txt b/www-apps/bugzilla/files/3.4/postinstall-en.txt
new file mode 100644
index 0000000..c1d9007
--- /dev/null
+++ b/www-apps/bugzilla/files/3.4/postinstall-en.txt
@@ -0,0 +1,12 @@
+0. Bugzilla has been installed into ${MY_INSTALLDIR}
+
+1. To finish the installation, please read
+ http://www.bugzilla.org/docs/3.4/html/installing-bugzilla.html
+ You will need to run ${MY_INSTALLDIR}/checksetup.pl
+
+2. Please read the Release Notes, especially if you are upgrading:
+ http://www.bugzilla.org/releases/3.4/release-notes.html
+
+3. Please note that Apache2 sets AllowOverride None by default. You may have
+ to edit it to process the .htaccess file provided by Bugzilla. Please see
+ http://httpd.apache.org/docs/2.2/mod/core.html#allowoverride for more info.
diff --git a/www-apps/bugzilla/files/3.4/reconfig b/www-apps/bugzilla/files/3.4/reconfig
new file mode 100644
index 0000000..71b0ace
--- /dev/null
+++ b/www-apps/bugzilla/files/3.4/reconfig
@@ -0,0 +1,19 @@
+#!/bin/bash
+
+FILE="bugzilla.cron.daily bugzilla.cron.tab"
+
+function die ()
+{
+ echo
+ echo "***"
+ echo "*** Fatal error: $*"
+ echo "***"
+ exit 1
+}
+
+if [ $1 = "install" ]; then
+ cd "${MY_INSTALLDIR}" || die "Cannot find install dir ${MY_INSTALLDIR}"
+ sed -e "s|/var/www/bugzilla|${MY_INSTALLDIR}|g" -i ${FILE} || die "sed failed"
+else
+ echo "done."
+fi