summaryrefslogtreecommitdiff
path: root/www-apps/dbweb
diff options
context:
space:
mode:
authorrandomdan <randomdan@localhost>2008-11-16 18:57:45 +0000
committerrandomdan <randomdan@localhost>2008-11-16 18:57:45 +0000
commitd6360458e4b8427eac5f9ef003308671fafcc290 (patch)
treedbc892208550bdf56e7330ea23e38988dcfb6aba /www-apps/dbweb
parent*** empty log message *** (diff)
downloadportage-d6360458e4b8427eac5f9ef003308671fafcc290.tar.bz2
portage-d6360458e4b8427eac5f9ef003308671fafcc290.tar.xz
portage-d6360458e4b8427eac5f9ef003308671fafcc290.zip
First dbweb
Diffstat (limited to 'www-apps/dbweb')
-rw-r--r--www-apps/dbweb/Manifest1
-rw-r--r--www-apps/dbweb/dbweb-0.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/www-apps/dbweb/Manifest b/www-apps/dbweb/Manifest
new file mode 100644
index 0000000..8f090d7
--- /dev/null
+++ b/www-apps/dbweb/Manifest
@@ -0,0 +1 @@
+EBUILD dbweb-0.1.ebuild 853 RMD160 01fdf16ea87044b1f363b935cc3bd8b4787ccf7b SHA1 6c48692524e267ff25dc8e4e83f47bf4a06c59c5 SHA256 122d5972540240b6b2f03dade7d758af0ff0d6b6221b113ade602ae3c85ff4c9
diff --git a/www-apps/dbweb/dbweb-0.1.ebuild b/www-apps/dbweb/dbweb-0.1.ebuild
new file mode 100644
index 0000000..0d8e360
--- /dev/null
+++ b/www-apps/dbweb/dbweb-0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvs/lportage/www-apps/dbweb/dbweb-0.1.ebuild,v 1.1 2008-11-16 18:57:45 randomdan Exp $
+
+inherit cvs webapp
+
+DESCRIPTION="Database driven website engine"
+HOMEPAGE="http://dbweb.randomdan.homeip.net"
+
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+WEBAPP_MANUAL_SLOT="yes"
+
+DEPEND="dev-db/unixODBC www-apache/mod_transform"
+RDEPEND="${DEPEND}"
+
+ECVS_SERVER="cvs.random.lan:/var/cvs"
+ECVS_MODULE="dbweb"
+ECVS_TOP_DIR=${DISTDIR}/cvs-src/${PN}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_compile() {
+ cd ${WORKDIR}/dbweb/libmisc
+ econf
+ emake
+ cd ${WORKDIR}/dbweb/libodbcpp
+ econf
+ emake
+ cd ${WORKDIR}/dbweb/dbweb
+ econf
+ emake
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins ${WORKDIR}/dbweb/dbweb/htdocs/.htaccess
+ exeinto "${MY_HTDOCSDIR}"
+ doexe ${WORKDIR}/dbweb/dbweb/dbweb
+
+ webapp_src_install
+}