summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorDan Goodliffe <dan@randomdan.homeip.net>2019-01-01 11:49:13 +0000
committerDan Goodliffe <dan@randomdan.homeip.net>2019-01-01 11:49:13 +0000
commit97cf49beddf6f7518a5a636b858c4ed73e470585 (patch)
treebad7a02e00452cb48555a8a55fddc0c937085f5f /sys-fs
parentSwitch to non-deprecated parent profile and update use flags accordingly (diff)
downloadportage-97cf49beddf6f7518a5a636b858c4ed73e470585.tar.bz2
portage-97cf49beddf6f7518a5a636b858c4ed73e470585.tar.xz
portage-97cf49beddf6f7518a5a636b858c4ed73e470585.zip
Add gitfs
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/gitfs/Manifest4
-rw-r--r--sys-fs/gitfs/files/python36.patch11
-rw-r--r--sys-fs/gitfs/files/requirements.patch8
-rw-r--r--sys-fs/gitfs/gitfs-0.4.5.1.ebuild33
4 files changed, 56 insertions, 0 deletions
diff --git a/sys-fs/gitfs/Manifest b/sys-fs/gitfs/Manifest
new file mode 100644
index 0000000..6aaa35e
--- /dev/null
+++ b/sys-fs/gitfs/Manifest
@@ -0,0 +1,4 @@
+AUX python36.patch 328 BLAKE2B ae2995fb4e9c344098e1a0641beb26ae4ed69db6e5a15826dfbe9b726d79a139ebd6b9f1a73300a109bf67eedc37c8c0104172cf948c58fd1adac976d919ad39 SHA512 a2d6be3dbc24318b0edd2384c39f0c70fb32be00e8c291cc481b009da48aae01ef96a1e614a224632b43d517e311627a7faf6194090243666a2685653b9d2962
+AUX requirements.patch 206 BLAKE2B e9e43694013cdad9381925a1083db4bf2fcec19950e86c131b75b125d9497f40ffc34fc2dc34a6088bd8518ada866a22cc00f030507120574cb605536fc919fb SHA512 db6c98c427c868aeb716206dd91b92f601d6152f63a0c0b240e42f6a2f98c84352d538646441ef025bd910ddbb8a502651c415cc3a395d2dc83e5d85d5eb21a2
+DIST gitfs-0.4.5.1.tar.gz 57695 BLAKE2B 62e939b83709f555d7d71b3304f9c6bce342ae1834830cd19f470fd623871d32cb14bf841bd276722e42c9717ca4e09819621ab9ee38c2952b76548e75225e40 SHA512 c2eed4245480e20047e588cc3eb9ea0332e898f8ec5e2954006ff2b4baf6e8427ec9e9d6e2abd14486eaf17ff2671675da25cceb3c29ea71b86405b912c2cadb
+EBUILD gitfs-0.4.5.1.ebuild 663 BLAKE2B 83aba2815a1ab36a5b04e4c59f1449d96eea6e8b8bb51ab2ab2477f009e6d033ed8759d125f67ef221ba32681ef720e6df501fb9af9cc00382211067b886c768 SHA512 8790340f728df1e55a0dd2c18248a39c74abc64c78d2392a81ac2e38c953319d09a08e901f9d23eafb5da9eb3745e6d7983ff44efce632a4e5dd2eb590d7e82e
diff --git a/sys-fs/gitfs/files/python36.patch b/sys-fs/gitfs/files/python36.patch
new file mode 100644
index 0000000..891df3e
--- /dev/null
+++ b/sys-fs/gitfs/files/python36.patch
@@ -0,0 +1,11 @@
+--- a/Makefile 2018-12-31 15:39:05.213652020 +0000
++++ b/Makefile 2018-12-31 15:39:41.964704350 +0000
+@@ -39,7 +39,7 @@
+ @touch $@
+
+ $(VIRTUAL_ENV)/bin/pip:
+- virtualenv --setuptools $(VIRTUAL_ENV) -ppython3.4
++ virtualenv --setuptools $(VIRTUAL_ENV) -ppython3.6 --system-site-packages
+
+ virtualenv: $(VIRTUAL_ENV)/bin/pip
+
diff --git a/sys-fs/gitfs/files/requirements.patch b/sys-fs/gitfs/files/requirements.patch
new file mode 100644
index 0000000..ac32f40
--- /dev/null
+++ b/sys-fs/gitfs/files/requirements.patch
@@ -0,0 +1,8 @@
+--- a/requirements.txt 2018-12-31 17:20:22.871085868 +0000
++++ b/requirements.txt 2018-12-31 17:21:17.046070872 +0000
+@@ -1,5 +1,5 @@
+ fusepy==2.0.2
+-pygit2==0.24.1
++pygit2==0.27.3
+ six==1.10.0
+ atomiclong
diff --git a/sys-fs/gitfs/gitfs-0.4.5.1.ebuild b/sys-fs/gitfs/gitfs-0.4.5.1.ebuild
new file mode 100644
index 0000000..b6f6e6c
--- /dev/null
+++ b/sys-fs/gitfs/gitfs-0.4.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Version controlled file system"
+HOMEPAGE="https://www.presslabs.com/code/gitfs/"
+SRC_URI="https://github.com/presslabs/gitfs/archive/0.4.5.1.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+=dev-libs/libgit2-0.27*
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+dev-python/virtualenv
+"
+PATCHES="
+$FILESDIR/python36.patch
+$FILESDIR/requirements.patch
+"
+
+addpredict "/usr/lib/python3.6/site-packages/pycparser/__pycache__/"
+
+src_install() {
+ emake install PREFIX="/usr" DESTDIR="${D}"
+ keepdir "/var/lib/${PN}"
+}
+