summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authordan.goodliffe <dan.goodliffe@localhost>2008-11-20 11:08:49 +0000
committerdan.goodliffe <dan.goodliffe@localhost>2008-11-20 11:08:49 +0000
commit67ce88ba9908e8b827248cab3e1e65662ef01cf7 (patch)
tree972ebb520aeaaab4db33b13bcc2b9e1d23cff6b3 /sys-fs
parentInstall files (diff)
downloadportage-67ce88ba9908e8b827248cab3e1e65662ef01cf7.tar.bz2
portage-67ce88ba9908e8b827248cab3e1e65662ef01cf7.tar.xz
portage-67ce88ba9908e8b827248cab3e1e65662ef01cf7.zip
CurlFS
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/curlfs/Manifest1
-rw-r--r--sys-fs/curlfs/curlfs-0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-fs/curlfs/Manifest b/sys-fs/curlfs/Manifest
new file mode 100644
index 0000000..4b2fbf1
--- /dev/null
+++ b/sys-fs/curlfs/Manifest
@@ -0,0 +1 @@
+EBUILD curlfs-0.ebuild 726 RMD160 1a1c2766a5ce79db3694c6a4e6ac0d7ca6e141b7 SHA1 2a7fc4b412af2e05a62e2b086aed045e2358937b SHA256 64f4833697e410162d788a3575b34e31f343a821804631c98362e5ec1ddddb7b
diff --git a/sys-fs/curlfs/curlfs-0.ebuild b/sys-fs/curlfs/curlfs-0.ebuild
new file mode 100644
index 0000000..28c51b0
--- /dev/null
+++ b/sys-fs/curlfs/curlfs-0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvs/lportage/sys-fs/curlfs/curlfs-0.ebuild,v 1.1 2008-11-20 11:08:36 dan.goodliffe Exp $
+
+inherit cvs
+
+DESCRIPTION="CurlFS FUSE driver"
+HOMEPAGE="http://develop.millerbros.co.uk"
+
+LICENSE="MBL"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="sys-fs/fuse net-misc/curl"
+RDEPEND="${DEPEND}"
+
+ECVS_SERVER="cvs.millerbros.co.uk:/var/cvs"
+ECVS_MODULE="curlfs"
+ECVS_USER="cvsanon"
+ECVS_AUTH="ext"
+ECVS_TOP_DIR=${DISTDIR}/cvs-src/${PN}
+
+src_compile() {
+ cd ${WORKDIR}/curlfs/curlfs
+ econf
+ emake
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe ${WORKDIR}/curlfs/curlfs/curlfs
+ dosym ../usr/bin/curlfs /sbin/mount.curlfs
+}