summaryrefslogtreecommitdiff
path: root/sys-cluster
diff options
context:
space:
mode:
authorDan Goodliffe <dan@randomdan.homeip.net>2022-08-04 08:22:57 +0100
committerDan Goodliffe <dan@randomdan.homeip.net>2022-08-04 08:22:57 +0100
commitbf0c6e264d712f6326d6ffef1ba7aba35fa3eec3 (patch)
treebdc1ab2ad26269345f26d9ec6765d401d2ec0af1 /sys-cluster
parentBump youcompleteme while we're here (diff)
downloadportage-bf0c6e264d712f6326d6ffef1ba7aba35fa3eec3.tar.bz2
portage-bf0c6e264d712f6326d6ffef1ba7aba35fa3eec3.tar.xz
portage-bf0c6e264d712f6326d6ffef1ba7aba35fa3eec3.zip
crmsh tmp bump
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/crmsh/Manifest3
-rw-r--r--sys-cluster/crmsh/crmsh-4.4.0.ebuild45
-rw-r--r--sys-cluster/crmsh/metadata.xml11
3 files changed, 59 insertions, 0 deletions
diff --git a/sys-cluster/crmsh/Manifest b/sys-cluster/crmsh/Manifest
new file mode 100644
index 0000000..fc085e6
--- /dev/null
+++ b/sys-cluster/crmsh/Manifest
@@ -0,0 +1,3 @@
+DIST crmsh-4.4.0.tar.gz 1170623 BLAKE2B 574543ac86bbac6b0cd7df021cf6dbb277c1b7ac3d1766926a7005f1e8779138b29cf2b19762c5d6ba3473c19fd784dcf71cc69fcd43c12ac1b4ecafe00d8ac0 SHA512 297d8063c376f0b9497399e65a72cabd8b71c1ea555ce66815c86b94a9f64ff9eddd3bcda37769e756dff6cfbec6f53cfe6deeb2df5e31183ee069174653e293
+EBUILD crmsh-4.4.0.ebuild 962 BLAKE2B f799675d5492601f185cd703832dfceb51a0387d6d80175d59f8299214c4330fd29932fec9d4251ad37e9f74eab914755506b9605ff7ccd6db3e5d42f9fdf2e4 SHA512 13917d079af671b51e3904bce9e7ec0eab8dea38c3cf142333b12ad54d1523201b2e6a0f910067e214671cd14c5f5bd33b677a05ac5a1aa7bf577249cd9f5b89
+MISC metadata.xml 344 BLAKE2B 3dd1aba1bed81c9993d1d9527e5695c4538c32014dc4da3303c602031182421f50629296c69f2f821455d29a0beb01a94b86541421d31462d37b05bbd57b41f0 SHA512 8fddf2b64d5dbdc79ccc206e36e33c2aee2c17ffc1c6012c80431d3d487734538c6efc3e3b6803407535783b1afa91901b929220874f8d20ce2616ad6cdb967d
diff --git a/sys-cluster/crmsh/crmsh-4.4.0.ebuild b/sys-cluster/crmsh/crmsh-4.4.0.ebuild
new file mode 100644
index 0000000..e8cdad5
--- /dev/null
+++ b/sys-cluster/crmsh/crmsh-4.4.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9,10} )
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/crmsh/crmsh"
+ inherit git-3
+ S="${WORKDIR}/${PN}-${MY_TREE}"
+else
+ SRC_URI="https://github.com/crmsh/crmsh/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~hppa ~x86"
+fi
+
+inherit autotools python-r1
+
+DESCRIPTION="Pacemaker command line interface for management and configuration"
+HOMEPAGE="https://crmsh.github.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=sys-cluster/pacemaker-1.1.9"
+RDEPEND="${DEPEND}
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/parallax[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ python_foreach_impl python_optimize
+}
diff --git a/sys-cluster/crmsh/metadata.xml b/sys-cluster/crmsh/metadata.xml
new file mode 100644
index 0000000..ff3f856
--- /dev/null
+++ b/sys-cluster/crmsh/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>cluster@gentoo.org</email>
+ <name>Gentoo Cluster Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">crmsh/crmsh</remote-id>
+ </upstream>
+</pkgmetadata>