summaryrefslogtreecommitdiff
path: root/sys-apps
diff options
context:
space:
mode:
authorDan Goodliffe <dan@randomdan.homeip.net>2015-12-19 16:49:16 +0000
committerDan Goodliffe <dan@randomdan.homeip.net>2015-12-19 16:49:16 +0000
commit99ac0a9cfef839e89ee18cb568c9c8fa8fb52a21 (patch)
tree31f98ce8fe5f39a1011ac43b40e5391cac9d482c /sys-apps
parentBump (diff)
downloadportage-99ac0a9cfef839e89ee18cb568c9c8fa8fb52a21.tar.bz2
portage-99ac0a9cfef839e89ee18cb568c9c8fa8fb52a21.tar.xz
portage-99ac0a9cfef839e89ee18cb568c9c8fa8fb52a21.zip
Initial commit of autorestart
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/autorestart/Manifest2
-rw-r--r--sys-apps/autorestart/autorestart-0.1.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/autorestart/Manifest b/sys-apps/autorestart/Manifest
new file mode 100644
index 0000000..8b77780
--- /dev/null
+++ b/sys-apps/autorestart/Manifest
@@ -0,0 +1,2 @@
+DIST autorestart-0.1.tar.xz 5296 SHA256 c41ab62c55b3458006ad766218a010d6306984c081337c1489e9b70b82efe0a0 SHA512 010dc308ef1e62c14796e543cadd5b1f9bf9afe900ebf7bd68c6073b0eaa3298b9e769f7ce0e3af24e194cb4127c2bbee9548c9aae794971c59fe2ee92316dd6 WHIRLPOOL 75b8d06fedbd79de817a9b8a25e51fc2b6d68a5b2efe5c24bcfacc9397ff48420f1a359f30c976cd64938af583e1223bf93c82818220ec219a80514266a2ab87
+EBUILD autorestart-0.1.ebuild 686 SHA256 4045fb32e053a5f3f2639f716931132aa15811ef3166324ade656651a34fd45d SHA512 4fbeb46f5588dc9d592cc3722f0838f33757f20a56fcda2c62f76ef69861e67deb91cf340ee79db7aa131119fbf2c95828d3f827ae3f526f9eafece1f02f670f WHIRLPOOL c7d3b868d73c1eb56ab05e45f04bbf4f58c8a93295b2e567216c4cfebb4adc96a71d014eac2be65ecbd7306c656f99befd12b16e1efdc74e0646763d26c4918b
diff --git a/sys-apps/autorestart/autorestart-0.1.ebuild b/sys-apps/autorestart/autorestart-0.1.ebuild
new file mode 100644
index 0000000..d0e01ab
--- /dev/null
+++ b/sys-apps/autorestart/autorestart-0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Automatically restart systemd units as required."
+HOMEPAGE="http://git.randomdan.homeip.net/cgit.cgi/util/tree/autorestart"
+SRC_URI="http://git.randomdan.homeip.net/cgit.cgi/util/snapshot/${P}.tar.xz"
+
+LICENSE="gpl"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ mail-client/mailx
+ sys-apps/coreutils
+ sys-apps/findutils
+ sys-apps/systemd
+ sys-process/lsof
+ "
+
+src_install() {
+ exeinto /etc/portage/postsync.d
+ doexe ${S}/autorestart/scripts/95-systemd-restart-as-needed
+ insinto /etc/autorestart
+ doins -r ${S}/autorestart/etc/ignore.d
+}
+