summaryrefslogtreecommitdiff
path: root/net-vpn
diff options
context:
space:
mode:
authorDan Goodliffe <dan@randomdan.homeip.net>2019-06-26 20:49:37 +0100
committerDan Goodliffe <dan@randomdan.homeip.net>2019-06-26 20:49:37 +0100
commitd30d3b5ab7faef02bf83db1415f08aaedceb6196 (patch)
tree23f694d369f17dd7bebddd4d51e11a5e262432fa /net-vpn
parentAdd ctags and cproto (diff)
downloadportage-d30d3b5ab7faef02bf83db1415f08aaedceb6196.tar.bz2
portage-d30d3b5ab7faef02bf83db1415f08aaedceb6196.tar.xz
portage-d30d3b5ab7faef02bf83db1415f08aaedceb6196.zip
Add forticlientsslvpn
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/forticlientsslvpn/Manifest2
-rw-r--r--net-vpn/forticlientsslvpn/forticlientsslvpn-4.4.2334.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/net-vpn/forticlientsslvpn/Manifest b/net-vpn/forticlientsslvpn/Manifest
new file mode 100644
index 0000000..6b06e18
--- /dev/null
+++ b/net-vpn/forticlientsslvpn/Manifest
@@ -0,0 +1,2 @@
+DIST forticlientsslvpn_linux_4.4.2334.tar.gz 9052339 BLAKE2B aa018b84db181b2a0f79c1c46a70d104475bf29328ed3ffcb6a0c848c3f57429b09fbe7af75164ed4ec2959f87fb495a60f7e7806972e4b0a6176a7157ef8747 SHA512 21d13b81cd7a040cbecb16a73d056b5f15eb5249013a54d5902921488b2642a568aabf241d16bb6fea79f1182eefa062f2766785a26b2538937d060f387fe74b
+EBUILD forticlientsslvpn-4.4.2334.ebuild 682 BLAKE2B 3c26125865b50b3006adc3c03fe813f0bbe3b1ac2f4bb9117e0502091d3ed289e0e6fbd9ccb371cbbced4efa045cfdea8288b4ce3b223cadc98a8c1a1da19c4f SHA512 c51e2bc6c1eceebebf083005eb2626d9ebfe1ec7f21cb0300e93d657404b125e744b1713fe3ca8857eb835969261ab02050110bd0e75d77ff3d001ee722e4fda
diff --git a/net-vpn/forticlientsslvpn/forticlientsslvpn-4.4.2334.ebuild b/net-vpn/forticlientsslvpn/forticlientsslvpn-4.4.2334.ebuild
new file mode 100644
index 0000000..4761f47
--- /dev/null
+++ b/net-vpn/forticlientsslvpn/forticlientsslvpn-4.4.2334.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION=""
+HOMEPAGE="https://www.fortinet.com/"
+SRC_URI="${PN}_linux_${PV}.tar.gz"
+
+LICENSE="FortiClientSSLVPN"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="fetch bindist"
+
+DEPEND="net-dialup/ppp"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+QA_PREBUILT="
+opt/forticlientsslvpn/helper/*
+opt/forticlientsslvpn/forticlientsslvpn*
+"
+
+src_compile() { :; }
+
+src_install()
+{
+ bits=64bit
+ if [ "$ABI" != amd64 ]; then
+ bits=32bit
+ fi
+
+ mkdir -p "${D}/opt" || die
+ mv "${S}/${bits}" "${D}/opt/${PN}" || die
+ chmod u+s "${D}/opt/${PN}/helper/subproc" || die
+}
+