summaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorrandomdan <randomdan@localhost>2010-06-20 11:33:11 +0000
committerrandomdan <randomdan@localhost>2010-06-20 11:33:11 +0000
commita4c75e9c847e143cb4e918048959dd406d2f099a (patch)
treeb51f5b02eab96ccac389a6093dc9bb50c8d08526 /net-p2p
parentAdd a version transmission with the corrected checksums (diff)
downloadportage-a4c75e9c847e143cb4e918048959dd406d2f099a.tar.bz2
portage-a4c75e9c847e143cb4e918048959dd406d2f099a.tar.xz
portage-a4c75e9c847e143cb4e918048959dd406d2f099a.zip
Copy in files dir
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/transmission/Manifest2
-rw-r--r--net-p2p/transmission/files/transmission-daemon.confd.167
-rw-r--r--net-p2p/transmission/files/transmission-daemon.initd.2136
3 files changed, 205 insertions, 0 deletions
diff --git a/net-p2p/transmission/Manifest b/net-p2p/transmission/Manifest
index 4ac7536..ad529aa 100644
--- a/net-p2p/transmission/Manifest
+++ b/net-p2p/transmission/Manifest
@@ -1,2 +1,4 @@
+AUX transmission-daemon.confd.1 1519 RMD160 decaf106064e8c393fce35758d6dc63e8302cc5c SHA1 372fd7f999a1c2f14fb24a8fe40094013774f673 SHA256 45ed8e0b966267d671acaff7d130cd843ba7aeac6773db2564e2aa9b2cbc2149
+AUX transmission-daemon.initd.2 3953 RMD160 f78589fe9de1db4160aa7c6333cef1fc835c0888 SHA1 7ca57cd2135688d27401441667cc373e22434bd1 SHA256 0266ecb32e9a359b078a61c8ba40413d9d222b6622b6f7d5e8fc0a4e2ed7587d
DIST transmission-2.00.tar.bz2 4259539 RMD160 ef8d4ee09c0f01de4ebe37204c276bde75927971 SHA1 19d852e64c07f7f7c0466dcb6d09dd20698bbfce SHA256 370abe5058f378382826511a8611e20a98f81a726e07ce74e4040e9b9fb5f0e7
EBUILD transmission-2.00.ebuild 2276 RMD160 6c7373661552f410ad9212607918c08fd6aa15a4 SHA1 93045e5e6f01f7bb6e2cb3444417db7ed12e5fac SHA256 1d7afbb8f59cc5d609ea3b9030c2eee1d429deea2dce59656eedff61686be5e7
diff --git a/net-p2p/transmission/files/transmission-daemon.confd.1 b/net-p2p/transmission/files/transmission-daemon.confd.1
new file mode 100644
index 0000000..28674dd
--- /dev/null
+++ b/net-p2p/transmission/files/transmission-daemon.confd.1
@@ -0,0 +1,67 @@
+# This is the transmission-daemon config file
+# Default settings are commented, uncomment and adapt as needed
+
+# Allowed IP addresses.
+#allowed=127.0.0.1
+
+# Enable peer blocklists (yes or no)
+#blocklist=no
+
+# Directory to watch for new .torrent files (empty string to disable)
+#watch_dir=
+
+# Where to look for configuration files
+#config_dir=/var/transmission/config
+
+# RPC port
+#port=9091
+
+# Require authentication (yes or no)
+#auth=no
+
+# Set username for authentication (only used when auth=yes)
+#username=
+
+# Set password for authentication (only used when auth=yes)
+#password=
+
+# Where to save downloaded data
+#download_dir=/var/transmission/downloads
+
+# Port for incoming peers
+#peerport=51413
+
+# Enable portmapping via NAT-PMP or UPnP (yes or no)
+#portmap=no
+
+# Maximum overall number of peers
+#peerlimit_global=240
+
+# Maximum number of peers per torrent
+#peerlimit_torrent=60
+
+# How to encrypt peer connections (required, preferred, tolerated)
+#encryption=preferred
+
+# Where to listen for peer connections (ipv4 address)
+#bind_address_ipv4=
+
+# Where to listen for peer connections (ipv6 address)
+#bind_address_ipv6=
+
+# Where to listen for RPC connections
+#rpc_bind_address=
+
+# Misc. settings
+
+
+# Location of pidfile
+#pidfile=/var/run/transmission.pid
+
+# Location of logfile
+# (Note: works only on systems with sys-apps/openrc, leave unset otherwise)
+#logfile=
+
+# Run daemon as another user (username or username:groupname)
+# (Note: works only on systems with sys-apps/openrc, leave unset otherwise)
+#runas_user=
diff --git a/net-p2p/transmission/files/transmission-daemon.initd.2 b/net-p2p/transmission/files/transmission-daemon.initd.2
new file mode 100644
index 0000000..f68c3f6
--- /dev/null
+++ b/net-p2p/transmission/files/transmission-daemon.initd.2
@@ -0,0 +1,136 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/files/transmission-daemon.initd.2,v 1.1 2009/06/20 12:55:37 ssuominen Exp $
+
+# Read options from conf.d file, or set sensible defaults
+allowed=${allowed:-127.0.0.1}
+blocklist=${blocklist:-no}
+watch_dir=${watch_dir:-}
+config_dir=${config_dir:-/var/transmission/config}
+port=${port:-9091}
+auth=${auth:-no}
+username=${username:-}
+password=${password:-}
+download_dir=${download_dir:=/var/transmission/downloads}
+peerport=${peerport:-51413}
+portmap=${portmap:-no}
+peerlimit_global=${peerlimit_global:-240}
+peerlimit_torrent=${peerlimit_torrent:-60}
+encryption=${encryption:-preferred}
+bind_address_ipv4=${bind_address_ipv4:-}
+bind_address_ipv6=${bind_address_ipv6:-}
+rpc_bind_address=${rpc_bind_address:-}
+
+# Misc options
+pidfile=${pidfile:-/var/run/transmission.pid}
+logfile=${logfile:-}
+runas_user=${runas_user:-}
+
+
+# Convert settings into stuff that transmission-daemon can grok as arguments
+allowed_opt="--allowed ${allowed}"
+
+blocklist_opt="--no-blocklist"
+if [ "x${blocklist}" = "xyes" ]; then
+ blocklist_opt="--blocklist"
+fi
+
+watch_dir_opt="--no-watch-dir"
+if [ -n "${watch_dir}" ]; then
+ watch_dir_opt="--watch-dir ${watch_dir}"
+fi
+
+config_dir_opt="--config-dir ${config_dir}"
+
+port_opt="--port ${port}"
+
+auth_opt="--no-auth"
+username_opt=""
+password_opt=""
+if [ "x${auth}" = "xyes" ]; then
+ auth_opt="--auth"
+ # Set username and password also
+ username_opt="--username ${username}"
+ password_opt="--password ${password}"
+fi
+
+download_dir_opt="--download-dir ${download_dir}"
+
+peerport_opt="--peerport ${peerport}"
+
+portmap_opt="--no-portmap"
+if [ "x${portmap}" = "xyes" ]; then
+ portmap_opt="--portmap"
+fi
+
+peerlimit_global_opt="--peerlimit-global ${peerlimit_global}"
+
+peerlimit_torrent_opt="--peerlimit-torrent ${peerlimit_torrent}"
+
+case "${encryption}" in
+ 'required') encryption_opt="--encryption-required" ;;
+ 'tolerated') encryption_opt="--encryption-tolerated" ;;
+ *) encryption_opt="--encryption-preferred" ;;
+esac
+
+bind_address_ipv4_opt=""
+if [ -n "${bind_address_ipv4}" ]; then
+ bind_address_ipv4_opt="--bind-address-ipv4 ${bind_address_ipv4}"
+fi
+
+bind_address_ipv6_opt=""
+if [ -n "${bind_address_ipv6}" ]; then
+ bind_address_ipv6_opt="--bind-address-ipv6 ${bind_address_ipv6}"
+fi
+
+rpc_bind_address_opt=""
+if [ -n "${rpc_bind_address}" ]; then
+ rpc_bind_address_opt="--rpc-bind-address ${rpc_bind_address}"
+fi
+
+# Note: works only on systems with sys-apps/openrc
+logfile_opt=""
+if [ -n "${logfile}" ]; then
+ logfile_opt="--stdout ${logfile} --stderr ${logfile}"
+fi
+
+# Note: works only on systems with sys-apps/openrc
+# This could be done in baselayout-1 with --chuid, but since
+# openrc detection is vague at best (b.g.o #270646), just ignore it.
+runas_user_opt=""
+if [ -n "${runas_user}" ]; then
+ runas_user_opt="--user ${runas_user}"
+fi
+
+# Actual init script stuff below this line
+
+opts="start stop"
+description="Transmission is a fast, easy and free bittorrent client"
+description_start="Start transmission-daemon server and web interface"
+description_stop="Stop transmission-daemon server and web interface"
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting transmission daemon"
+ start-stop-daemon --start --quiet --background --make-pidfile \
+ --pidfile ${pidfile} ${runas_user_opt} \
+ ${logfile_opt} --exec \
+ /usr/bin/transmission-daemon -- --foreground ${allowed_opt} \
+ ${blocklist_opt} ${watch_dir_opt} ${config_dir_opt} ${port_opt} \
+ ${auth_opt} ${username_opt} ${password_opt} ${download_dir_opt} \
+ ${peerport_opt} ${portmap_opt} ${peerlimit_global_opt} \
+ ${peerlimit_torrent_opt} ${encryption_opt} \
+ ${bind_address_ipv4_opt} ${bind_address_ipv6_opt} ${rpc_bind_address_opt}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping transmission daemon"
+ start-stop-daemon --stop --quiet --retry TERM/45/QUIT/15 \
+ --pidfile ${pidfile}
+ eend $?
+}