summaryrefslogtreecommitdiff
path: root/net-fs/glusterfs
diff options
context:
space:
mode:
authorrandomdan <randomdan@localhost>2009-01-21 23:13:27 +0000
committerrandomdan <randomdan@localhost>2009-01-21 23:13:27 +0000
commit12b8cac66b6b803bb31a992acba53353b059ad57 (patch)
treec133f70891ede682719b6d0e48f9fd60df1d4703 /net-fs/glusterfs
parentRemove things now in Gentoo portage tree (diff)
downloadportage-12b8cac66b6b803bb31a992acba53353b059ad57.tar.bz2
portage-12b8cac66b6b803bb31a992acba53353b059ad57.tar.xz
portage-12b8cac66b6b803bb31a992acba53353b059ad57.zip
init
Diffstat (limited to 'net-fs/glusterfs')
-rw-r--r--net-fs/glusterfs/Manifest4
-rw-r--r--net-fs/glusterfs/files/glusterfs-1.3.10.confd3
-rwxr-xr-xnet-fs/glusterfs/files/glusterfs-1.3.10.initd27
-rw-r--r--net-fs/glusterfs/glusterfs-2.0.0_rc1.ebuild75
4 files changed, 109 insertions, 0 deletions
diff --git a/net-fs/glusterfs/Manifest b/net-fs/glusterfs/Manifest
new file mode 100644
index 0000000..a21662d
--- /dev/null
+++ b/net-fs/glusterfs/Manifest
@@ -0,0 +1,4 @@
+AUX glusterfs-1.3.10.confd 101 RMD160 02d71bc7c20ff30f38ebd4bfd0c7d62a94fc8227 SHA1 931e7757a6acccab7a1346d15fec52db0e9e26b9 SHA256 97e3d0d2a656500737856988b1b83107c34c41876d4f4ee4f5d87a25b0bdf648
+AUX glusterfs-1.3.10.initd 581 RMD160 c0a69bbea6b5d84d8c3838a218a66cbaeaa5c309 SHA1 186f57dafe02546293ed4189bf17796a42617d56 SHA256 186c083a79c3e5473079997750fe7cc3842c990e70999078c0c0acdec4abef16
+DIST glusterfs-2.0.0rc1.tar.gz 1396957 RMD160 a4573eb540a8768239190d12b61deac53a8ee1c8 SHA1 6c39b69b73ed6be3ecae38f7a24ff8254fa6761a SHA256 4703bfdc57b004461f65ea74b08ce22d557e033fbaf30909b3730aabbd01cf4c
+EBUILD glusterfs-2.0.0_rc1.ebuild 2477 RMD160 4bacb3ef1824594b7632a0b129fa8805f80ce423 SHA1 9c1274bc9339ac739de9337e91d801212009a9fb SHA256 52c420ada4853efee53cfc49b56550c03b71858d46a89e9bf487e25bb6bf55eb
diff --git a/net-fs/glusterfs/files/glusterfs-1.3.10.confd b/net-fs/glusterfs/files/glusterfs-1.3.10.confd
new file mode 100644
index 0000000..1a441ea
--- /dev/null
+++ b/net-fs/glusterfs/files/glusterfs-1.3.10.confd
@@ -0,0 +1,3 @@
+CONF_FILE=/etc/glusterfs/${SVCNAME}.vol
+LOG_FILE=/var/log/glusterfs/${SVCNAME}.log
+LOG_LEVEL=WARNING
diff --git a/net-fs/glusterfs/files/glusterfs-1.3.10.initd b/net-fs/glusterfs/files/glusterfs-1.3.10.initd
new file mode 100755
index 0000000..f833a30
--- /dev/null
+++ b/net-fs/glusterfs/files/glusterfs-1.3.10.initd
@@ -0,0 +1,27 @@
+#!/sbin/runscript
+
+PID_FILE=/var/run/${SVCNAME}.pid
+EXECUTABLE=`which glusterfsd`
+
+depend() {
+ before glusterfs-client
+}
+
+start() {
+ if [ -z "${CONF_FILE}" -o ! -f "${CONF_FILE}" -o -z "${LOG_FILE}" -o -z "${LOG_LEVEL}" ]; then
+ eerror "Please specify all params in /etc/conf.d/${SVCNAME}"
+ return 1
+ fi
+
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --exec ${EXECUTABLE} --start -- \
+ -f "${CONF_FILE}" --pidfile=${PID_FILE} \
+ -l "${LOG_FILE}" -L "${LOG_LEVEL}"
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --pidfile ${PID_FILE} --stop
+ eend $?
+}
diff --git a/net-fs/glusterfs/glusterfs-2.0.0_rc1.ebuild b/net-fs/glusterfs/glusterfs-2.0.0_rc1.ebuild
new file mode 100644
index 0000000..6d58633
--- /dev/null
+++ b/net-fs/glusterfs/glusterfs-2.0.0_rc1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvs/lportage/net-fs/glusterfs/glusterfs-2.0.0_rc1.ebuild,v 1.1 2009-01-21 23:13:00 randomdan Exp $
+
+#EAPI=0
+
+inherit autotools eutils versionator
+
+DESCRIPTION="GlusterFS is a powerful network/cluster filesystem"
+HOMEPAGE="http://www.gluster.org/"
+
+SLOT="0"
+MY_PV="$(replace_version_separator '_' '')"
+MY_P="${PN}-${MY_PV}"
+MY_PV_1="$(get_version_component_range "1-2")"
+MY_PV_2="$(get_version_component_range "1-3")"
+SRC_URI="http://europe.gluster.org/${PN}/${MY_PV_1}/${MY_PV_2}/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+
+KEYWORDS="~amd64 ~ppc ~ppc64"
+IUSE="fuse"
+
+COMMON_DEPEND="fuse? ( >=sys-fs/fuse-2.7.3 )"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/bison
+ sys-devel/flex
+"
+RDEPEND="${COMMON_DEPEND}
+ || ( net-misc/ntp net-misc/ntpclient )"
+# infiniband? ( sys-cluster/libibverbs )
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf \
+ --disable-static \
+ --disable-mod_glusterfs \
+ $(use_enable fuse fuse-client) \
+ --disable-bdb \
+ --localstatedir=/var --docdir=/usr/share/doc/${PF}
+
+ emake LIBTOOLFLAGS="--quiet" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBTOOLFLAGS="--quiet" install -j1 || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS || die "dodoc failed"
+
+ newinitd "${FILESDIR}/${PN}-1.3.10.initd" "${PN}" || die "newinitd failed"
+ newconfd "${FILESDIR}/${PN}-1.3.10.confd" "${PN}" || die "newconfd failed"
+
+ keepdir /var/log/${PN} || die "keepdir failed"
+}
+
+pkg_postinst() {
+ einfo "The glusterfs startup script can be multiplexed."
+ einfo "The default startup script uses /etc/conf.d/glusterfs to configure the"
+ einfo "separate service. To create additional instances of the glusterfs service"
+ einfo "simply create a symlink to the glusterfs startup script that is prefixed"
+ einfo "with \"glusterfs.\""
+ einfo
+ einfo "Example:"
+ einfo " # cd /etc/init.d"
+ einfo " # ln -s glusterfs glusterfs.client"
+ einfo "You can now treat glusterfs.client like any other service"
+ echo
+ einfo "You can mount exported GlusterFS filesystems through /etc/fstab instead of"
+ einfo "through a startup script instance. For more information visit:"
+ einfo "http://www.gluster.org/docs/index.php/Mounting_a_GlusterFS_Volume"
+ echo
+ ewarn "You need to use a ntp client to keep the clocks synchronized across all"
+ ewarn "of your servers. Setup a NTP synchronizing service before attempting to"
+ ewarn "run GlusterFS."
+}