summaryrefslogtreecommitdiff
path: root/net-analyzer
diff options
context:
space:
mode:
authorDan Goodliffe <dan@randomdan.homeip.net>2022-07-17 14:46:20 +0100
committerDan Goodliffe <dan@randomdan.homeip.net>2022-07-17 14:46:20 +0100
commite0c1e1ccc00c86c227832fb1cbbc7fb0d4f9bdc4 (patch)
treedcba7c783291d02da50572e379fa517a6b0389cb /net-analyzer
parentAdd NagiosGraph (diff)
downloadportage-e0c1e1ccc00c86c227832fb1cbbc7fb0d4f9bdc4.tar.bz2
portage-e0c1e1ccc00c86c227832fb1cbbc7fb0d4f9bdc4.tar.xz
portage-e0c1e1ccc00c86c227832fb1cbbc7fb0d4f9bdc4.zip
Fixup nagiosgraph
Patch to fix warnings, rrdtool[graph] dep, shortened desc
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nagiosgraph/Manifest3
-rw-r--r--net-analyzer/nagiosgraph/files/multi_param.patch20
-rw-r--r--net-analyzer/nagiosgraph/nagiosgraph-1.5.2-r1.ebuild (renamed from net-analyzer/nagiosgraph/nagiosgraph-1.5.2.ebuild)9
3 files changed, 29 insertions, 3 deletions
diff --git a/net-analyzer/nagiosgraph/Manifest b/net-analyzer/nagiosgraph/Manifest
index 378d901..f399714 100644
--- a/net-analyzer/nagiosgraph/Manifest
+++ b/net-analyzer/nagiosgraph/Manifest
@@ -1,2 +1,3 @@
+AUX multi_param.patch 767 BLAKE2B 9eb84fc9c433b7220135d2091c20602d2dbcb75a3f28ec3eb2a38ec9d8ffc8ae783c2c3d752da0fdb610dda83e45b470527de2c105cfee44423e0f8719fc8de5 SHA512 9b2775c6e934d943f1115d55979d149d1b375c71cccc82ccf80253607ddeeef4f631ad26cdaf06e0253a7860a39281ed551af39ad0dd18347df8ed7dc17e2599
DIST nagiosgraph-1.5.2.tar.gz 329978 BLAKE2B 7a54a0db5b220d3e270d9df92d3e6b4e8096c3ba189654e0646071a0460e613b51816b299d1da4dd905c2967acb7cd291cfc1c9e4c224acdddcaab56dee7d0d5 SHA512 bde1c177b5a805d5a23024a5cc513d84b36c16d1e320143d95ec4d44d57a232adee786c37a95baea88877139eef47d7b1175a33b11948af0793a63c00391910f
-EBUILD nagiosgraph-1.5.2.ebuild 809 BLAKE2B 24a7e906e520441e847b856eb20ce0c1418a084907b24ff0195b8ac0d3907a54656b9b96d3e02a81b84a35368044566d439a1c27bb3acb8bcbe44ede117c21bf SHA512 749fe51a0803a0b9f8356e527cf1828c723d4990c0467a6a700822f32e2c7163d9dc31cbb0601dc0eb30c29b72e9fd421d0c44e7b0f9217a70e798977192a00e
+EBUILD nagiosgraph-1.5.2-r1.ebuild 878 BLAKE2B 41808fff7493685478e702b4b3ee9ee3f9ad4ce9779ae3a8ad280ee8fbc486a4ae20d0803e9b6fd2036a2f659ca1b1e2ef93e680e3dfe8cffdc31fd655a54056 SHA512 992498fe6adc1925a9325d414179576465c3bc811ffab755804b6725ddf908df26a3ff7213bf67014eb0171ec4890251ef657f69ec6222773acc76b72d528dd3
diff --git a/net-analyzer/nagiosgraph/files/multi_param.patch b/net-analyzer/nagiosgraph/files/multi_param.patch
new file mode 100644
index 0000000..431190b
--- /dev/null
+++ b/net-analyzer/nagiosgraph/files/multi_param.patch
@@ -0,0 +1,20 @@
+--- a/etc/ngshared.pm 2022-07-17 14:39:52.988032864 +0100
++++ b/etc/ngshared.pm 2022-07-17 14:39:40.553988303 +0100
+@@ -231,7 +231,7 @@
+ my ($cgi, $params) = getparams();
+ getdebug($app, $params->{host}, $params->{service});
+
+- $errmsg = readi18nfile($cgi->param('language'));
++ $errmsg = readi18nfile($cgi->multi_param('language'));
+ if ($errmsg ne q()) {
+ debug(DBWRN, $errmsg);
+ }
+@@ -381,7 +381,7 @@
+ my @rval = $cgi->param($ii);
+ $rval{$ii} = \@rval;
+ } elsif ($ii eq 'db' || $ii eq 'label') {
+- $rval{$ii} = [$cgi->param($ii),];
++ $rval{$ii} = [$cgi->multi_param($ii),];
+ } else {
+ $rval{$ii} = $cgi->param($ii);
+ }
diff --git a/net-analyzer/nagiosgraph/nagiosgraph-1.5.2.ebuild b/net-analyzer/nagiosgraph/nagiosgraph-1.5.2-r1.ebuild
index c3b9f31..b52d20a 100644
--- a/net-analyzer/nagiosgraph/nagiosgraph-1.5.2.ebuild
+++ b/net-analyzer/nagiosgraph/nagiosgraph-1.5.2-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-DESCRIPTION="nagiosgraph extracts information from the Nagios output and inserts it into RRD files"
+DESCRIPTION="nagiosgraph extracts info from the Nagios output and inserts it into RRD files"
HOMEPAGE="https://sourceforge.net/p/nagiosgraph"
SRC_URI="https://netix.dl.sourceforge.net/project/${PN}/${PN}/${PV}/${P}.tar.gz"
@@ -14,11 +14,16 @@ KEYWORDS="~amd64"
DEPEND=""
RDEPEND="
dev-lang/perl
-net-analyzer/rrdtool[perl]
+net-analyzer/rrdtool[perl,graph]
dev-perl/GD
"
BDEPEND=""
+src_prepare() {
+ eapply ${FILESDIR}/multi_param.patch
+ eapply_user
+}
+
src_configure() {
sed -i "s|/opt/nagiosgraph/etc|/etc/${PN}|g" ${S}/cgi/*.cgi ${S}/lib/*.pl
}