summaryrefslogtreecommitdiff
path: root/net-analyzer/nagiosgraph
diff options
context:
space:
mode:
authorDan Goodliffe <dan@randomdan.homeip.net>2022-07-17 13:12:24 +0100
committerDan Goodliffe <dan@randomdan.homeip.net>2022-07-17 13:12:24 +0100
commitdbec013355ba7f0fd9df3578b41bc56f49850d49 (patch)
tree384f6c140d2850ae2db8ad4fa37a3cf9c20ad111 /net-analyzer/nagiosgraph
parentAllow nmap[ncat] provide nc (it's better) (diff)
downloadportage-dbec013355ba7f0fd9df3578b41bc56f49850d49.tar.bz2
portage-dbec013355ba7f0fd9df3578b41bc56f49850d49.tar.xz
portage-dbec013355ba7f0fd9df3578b41bc56f49850d49.zip
Add NagiosGraph
Diffstat (limited to 'net-analyzer/nagiosgraph')
-rw-r--r--net-analyzer/nagiosgraph/Manifest2
-rw-r--r--net-analyzer/nagiosgraph/nagiosgraph-1.5.2.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/nagiosgraph/Manifest b/net-analyzer/nagiosgraph/Manifest
new file mode 100644
index 0000000..378d901
--- /dev/null
+++ b/net-analyzer/nagiosgraph/Manifest
@@ -0,0 +1,2 @@
+DIST nagiosgraph-1.5.2.tar.gz 329978 BLAKE2B 7a54a0db5b220d3e270d9df92d3e6b4e8096c3ba189654e0646071a0460e613b51816b299d1da4dd905c2967acb7cd291cfc1c9e4c224acdddcaab56dee7d0d5 SHA512 bde1c177b5a805d5a23024a5cc513d84b36c16d1e320143d95ec4d44d57a232adee786c37a95baea88877139eef47d7b1175a33b11948af0793a63c00391910f
+EBUILD nagiosgraph-1.5.2.ebuild 809 BLAKE2B 24a7e906e520441e847b856eb20ce0c1418a084907b24ff0195b8ac0d3907a54656b9b96d3e02a81b84a35368044566d439a1c27bb3acb8bcbe44ede117c21bf SHA512 749fe51a0803a0b9f8356e527cf1828c723d4990c0467a6a700822f32e2c7163d9dc31cbb0601dc0eb30c29b72e9fd421d0c44e7b0f9217a70e798977192a00e
diff --git a/net-analyzer/nagiosgraph/nagiosgraph-1.5.2.ebuild b/net-analyzer/nagiosgraph/nagiosgraph-1.5.2.ebuild
new file mode 100644
index 0000000..c3b9f31
--- /dev/null
+++ b/net-analyzer/nagiosgraph/nagiosgraph-1.5.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="nagiosgraph extracts information from the Nagios output and inserts it into RRD files"
+HOMEPAGE="https://sourceforge.net/p/nagiosgraph"
+SRC_URI="https://netix.dl.sourceforge.net/project/${PN}/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=""
+RDEPEND="
+dev-lang/perl
+net-analyzer/rrdtool[perl]
+dev-perl/GD
+"
+BDEPEND=""
+
+src_configure() {
+ sed -i "s|/opt/nagiosgraph/etc|/etc/${PN}|g" ${S}/cgi/*.cgi ${S}/lib/*.pl
+}
+
+src_install() {
+ insinto /etc/${PN}
+ doins ${S}/etc/*
+ exeinto /usr/$(get_libdir)/${PN}/bin
+ doexe ${S}/lib/*.pl
+ exeinto /usr/$(get_libdir)/${PN}/cgi-bin
+ doexe ${S}/cgi/*.cgi
+ insinto /usr/$(get_libdir)/${PN}/share
+ doins ${S}/share/*
+}