summaryrefslogtreecommitdiff
path: root/net-analyzer/nagiosgraph/nagiosgraph-1.5.2-r2.ebuild
diff options
context:
space:
mode:
authorDan Goodliffe <dan.goodliffe@octal.co.uk>2025-01-13 11:19:50 +0000
committerDan Goodliffe <dan.goodliffe@octal.co.uk>2025-01-13 11:19:50 +0000
commit69c5f58c466d486e424be9b53f57943860c3f3a9 (patch)
treef6643d1f0a10ecfc8c6f9034e7fc88985ec31f8b /net-analyzer/nagiosgraph/nagiosgraph-1.5.2-r2.ebuild
parentStablise latest youcompleteme (diff)
downloadportage-main.tar.bz2
portage-main.tar.xz
portage-main.zip
Add James' multiselect patchHEADmain
Diffstat (limited to 'net-analyzer/nagiosgraph/nagiosgraph-1.5.2-r2.ebuild')
-rw-r--r--net-analyzer/nagiosgraph/nagiosgraph-1.5.2-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-analyzer/nagiosgraph/nagiosgraph-1.5.2-r2.ebuild b/net-analyzer/nagiosgraph/nagiosgraph-1.5.2-r2.ebuild
new file mode 100644
index 0000000..54d1cac
--- /dev/null
+++ b/net-analyzer/nagiosgraph/nagiosgraph-1.5.2-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="nagiosgraph extracts info from the Nagios output and inserts it into RRD files"
+HOMEPAGE="https://sourceforge.net/p/nagiosgraph"
+SRC_URI="https://netix.dl.sourceforge.net/project/${PN}/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=""
+RDEPEND="
+dev-lang/perl
+net-analyzer/rrdtool[perl,graph]
+dev-perl/GD
+"
+BDEPEND=""
+
+src_prepare() {
+ eapply ${FILESDIR}/multi_param.patch
+ eapply ${FILESDIR}/multiselect.patch
+ eapply_user
+}
+
+src_configure() {
+ sed -i "s|/opt/nagiosgraph/etc|/etc/${PN}|g" ${S}/cgi/*.cgi ${S}/lib/*.pl
+}
+
+src_install() {
+ insinto /etc/${PN}
+ doins ${S}/etc/*
+ exeinto /usr/$(get_libdir)/${PN}/bin
+ doexe ${S}/lib/*.pl
+ exeinto /usr/$(get_libdir)/${PN}/cgi-bin
+ doexe ${S}/cgi/*.cgi
+ insinto /usr/$(get_libdir)/${PN}/share
+ doins ${S}/share/*
+}