summaryrefslogtreecommitdiff
path: root/media-tv
diff options
context:
space:
mode:
authorDan Goodliffe <dan@randomdan.homeip.net>2017-11-17 18:57:08 +0000
committerDan Goodliffe <dan@randomdan.homeip.net>2017-11-17 19:02:42 +0000
commitf5a21cf00b7840fc0e9e9d614c34152df2a19e9f (patch)
tree0cdfa39fe75eccd84a5df0c10583cdae70487c2e /media-tv
parentDon't auto enable ntpd (diff)
downloadportage-f5a21cf00b7840fc0e9e9d614c34152df2a19e9f.tar.bz2
portage-f5a21cf00b7840fc0e9e9d614c34152df2a19e9f.tar.xz
portage-f5a21cf00b7840fc0e9e9d614c34152df2a19e9f.zip
Add package that just installs the mythtv script bindings
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythtv-bindings/Manifest2
-rw-r--r--media-tv/mythtv-bindings/mythtv-bindings-0.28.1-r1.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/media-tv/mythtv-bindings/Manifest b/media-tv/mythtv-bindings/Manifest
new file mode 100644
index 0000000..bb0ed72
--- /dev/null
+++ b/media-tv/mythtv-bindings/Manifest
@@ -0,0 +1,2 @@
+DIST mythtv-0.28.1.tar.gz 104477892 SHA256 73dd4de0de6fe5688c290781b76de6380b256a87159f2c6e3dad66870389da1f SHA512 67a81858cd19b90f519113b234119ecc248366d8545c862d887755f256cddf04d9ca16a7bf67f63e06f7628730e7dbde2a2099ca8aaeb9061b2e55a5a0b7d5e7 WHIRLPOOL 370f3a528438d50d302ab6adadba5089b32749f8127cbf270b85ef16d35ca15026e0947e292920a3dd6acf2ed65de68af8754d985944bd59f3310a42b03551de
+EBUILD mythtv-bindings-0.28.1-r1.ebuild 840 SHA256 dd6e6f9f6b6a77e41bd42919b2f7dfcddaca2c809e6069c17501086cd33811bb SHA512 c581b02d8153427a5d0a8c77e1c2ac5a86cb1cb433318d1d5c7e746ded22691596b020c7c6c4c9c5bee0ccefbde77ea87865f013ea47307c1215120b0dbdae61 WHIRLPOOL 7de0cbbf0355b9f1cf5c9a9affed5cebe8ab641db8d0d360195e8d57aeba7f5c68e822df442112cf651d81cd48adaba5ed866aa483660c0b33a9b66f5415d408
diff --git a/media-tv/mythtv-bindings/mythtv-bindings-0.28.1-r1.ebuild b/media-tv/mythtv-bindings/mythtv-bindings-0.28.1-r1.ebuild
new file mode 100644
index 0000000..127c718
--- /dev/null
+++ b/media-tv/mythtv-bindings/mythtv-bindings-0.28.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+BACKPORTS="03f44039848bd09444ff4baa8dc158bd61454079"
+MY_P=${P%_p*}
+MY_PV=${PV%_p*}
+
+inherit eutils vcs-snapshot
+
+DESCRIPTION="Homebrew PVR project bindings"
+HOMEPAGE="https://www.mythtv.org"
+SRC_URI="https://github.com/MythTV/mythtv/archive/${BACKPORTS}.tar.gz -> mythtv-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0/${PV}"
+IUSE="python perl"
+
+S="${WORKDIR}/mythtv-${BACKPORTS}/mythtv"
+
+src_unpack() {
+ tar -zxf "${DISTDIR}/${A}" mythtv-${BACKPORTS}/mythtv/bindings
+ find ${S} -name .gitignore -delete
+ find ${S} -name Makefile -delete
+}
+
+src_install() {
+ insinto /usr/share/mythtv/bindings
+ doins -r ${S}/bindings/php
+ use perl && doins -r ${S}/bindings/perl
+ use python && doins -r ${S}/bindings/python
+}
+