summaryrefslogtreecommitdiff
path: root/dev-util
diff options
context:
space:
mode:
authorDan Goodliffe <dan@randomdan.homeip.net>2021-08-08 16:20:14 +0100
committerDan Goodliffe <dan@randomdan.homeip.net>2021-08-08 16:20:14 +0100
commit0ba3a393cdda6eb1726284f6a6c65e39f8c20808 (patch)
tree8594c095030765a3d2e660653d501add1c598578 /dev-util
parentTmp unmask of pkg-config (diff)
downloadportage-0ba3a393cdda6eb1726284f6a6c65e39f8c20808.tar.bz2
portage-0ba3a393cdda6eb1726284f6a6c65e39f8c20808.tar.xz
portage-0ba3a393cdda6eb1726284f6a6c65e39f8c20808.zip
Recent cppcheck now in portage
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cppcheck/Manifest4
-rw-r--r--dev-util/cppcheck/cppcheck-2.3.ebuild81
-rw-r--r--dev-util/cppcheck/cppcheck-2.4.1.ebuild81
3 files changed, 0 insertions, 166 deletions
diff --git a/dev-util/cppcheck/Manifest b/dev-util/cppcheck/Manifest
deleted file mode 100644
index 01e9972..0000000
--- a/dev-util/cppcheck/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-DIST cppcheck-2.3.tar.gz 3594620 BLAKE2B 6e8d67ea877a9e5ec89338c590bde9e0d1df5d93b0efd75a170e02a98c2c7e93ddbc6373d6aff4baaabc54091a689d695bcecbf89925782d25aba11d506dac3c SHA512 1da7985e1b0636a4cd2c85c07fcb0ca938445ae1d0a7543d059a1851125cb263053d4fe41f38a469d5a3c5c9eb0092b527b1d07ac6aa71e3b83ab1482a2a1007
-DIST cppcheck-2.4.1.tar.gz 3761646 BLAKE2B 4c791088621f989e2529c92de38a73676fc3394e8cac72822596f7a75594283d0983693d693aa903a3ffb80bc0e1e20e71b55db5682d4d01c135ed77b2fc2e3c SHA512 8fb1ed5faa0071fc69405b7eb5b41e9f94b77d097158ea0d4f5e4da8a5087b9d1ab7bf37f8dc73d00096d3d2494aeb431af8029f0d4f1e2085f5b9b72bdc2d09
-EBUILD cppcheck-2.3.ebuild 1695 BLAKE2B f717e1b7ab2205550224a79c84c5e977c3b43c967fe6613f4448745f61ea664389a7154339fa3e4fd7e76a00d6b5e982ce1fad9cc94ec17826978da540b123b9 SHA512 59dc0d2a00e6d8791be65814d67f9eb30671476449578f1f7dfa06769602d6fde9e8cd767f4792d44e43680591b819df1ce86821b63c5676fbeffd8eeeea14bb
-EBUILD cppcheck-2.4.1.ebuild 1695 BLAKE2B f717e1b7ab2205550224a79c84c5e977c3b43c967fe6613f4448745f61ea664389a7154339fa3e4fd7e76a00d6b5e982ce1fad9cc94ec17826978da540b123b9 SHA512 59dc0d2a00e6d8791be65814d67f9eb30671476449578f1f7dfa06769602d6fde9e8cd767f4792d44e43680591b819df1ce86821b63c5676fbeffd8eeeea14bb
diff --git a/dev-util/cppcheck/cppcheck-2.3.ebuild b/dev-util/cppcheck/cppcheck-2.3.ebuild
deleted file mode 100644
index 5fe3832..0000000
--- a/dev-util/cppcheck/cppcheck-2.3.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7,3_8,3_9} )
-inherit distutils-r1 toolchain-funcs cmake
-
-DESCRIPTION="Static analyzer of C/C++ code"
-HOMEPAGE="https://github.com/danmar/cppcheck"
-SRC_URI="https://github.com/danmar/cppcheck/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86"
-IUSE="htmlreport pcre qt5 +z3"
-
-RDEPEND="
- htmlreport? ( dev-python/pygments[${PYTHON_USEDEP}] )
- pcre? ( dev-libs/libpcre )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qthelp:5
- dev-qt/qtprintsupport:5
- )
-"
-DEPEND="${RDEPEND}
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt
- virtual/pkgconfig
- z3? ( sci-mathematics/z3 )
-"
-
-src_prepare() {
- cmake_src_prepare
-}
-
-src_configure() {
-
- local mycmakeargs=(
- -DHAVE_RULES="$(usex pcre)"
- -DBUILD_GUI="$(usex qt5)"
- -DUSE_Z3="$(usex z3)"
- -DFILESDIR="/usr/share/${PN}/"
- -DENABLE_OSS_FUZZ=OFF
- )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-
- if use htmlreport ; then
- pushd htmlreport || die
- distutils-r1_src_compile
- popd || die
- fi
-}
-
-src_install() {
- # it's not autotools-based, so "${ED}" here, not "${D}", bug 531760
- emake install DESTDIR="${ED}" \
- FILESDIR="/usr/share/${PN}/"
-
- insinto "/usr/share/${PN}/cfg"
- doins cfg/*.cfg
- if use qt5 ; then
- dobin "${WORKDIR}/${P}_build/bin/${PN}-gui"
- dodoc gui/{projectfile.txt,gui.${PN}}
- fi
- if use htmlreport ; then
- pushd htmlreport || die
- distutils-r1_src_install
- popd || die
- find "${D}" -name "*.egg-info" -delete
- else
- rm "${ED}/usr/bin/cppcheck-htmlreport" || die
- fi
-
- dodoc -r tools/triage
-}
diff --git a/dev-util/cppcheck/cppcheck-2.4.1.ebuild b/dev-util/cppcheck/cppcheck-2.4.1.ebuild
deleted file mode 100644
index 5fe3832..0000000
--- a/dev-util/cppcheck/cppcheck-2.4.1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7,3_8,3_9} )
-inherit distutils-r1 toolchain-funcs cmake
-
-DESCRIPTION="Static analyzer of C/C++ code"
-HOMEPAGE="https://github.com/danmar/cppcheck"
-SRC_URI="https://github.com/danmar/cppcheck/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86"
-IUSE="htmlreport pcre qt5 +z3"
-
-RDEPEND="
- htmlreport? ( dev-python/pygments[${PYTHON_USEDEP}] )
- pcre? ( dev-libs/libpcre )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qthelp:5
- dev-qt/qtprintsupport:5
- )
-"
-DEPEND="${RDEPEND}
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt
- virtual/pkgconfig
- z3? ( sci-mathematics/z3 )
-"
-
-src_prepare() {
- cmake_src_prepare
-}
-
-src_configure() {
-
- local mycmakeargs=(
- -DHAVE_RULES="$(usex pcre)"
- -DBUILD_GUI="$(usex qt5)"
- -DUSE_Z3="$(usex z3)"
- -DFILESDIR="/usr/share/${PN}/"
- -DENABLE_OSS_FUZZ=OFF
- )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-
- if use htmlreport ; then
- pushd htmlreport || die
- distutils-r1_src_compile
- popd || die
- fi
-}
-
-src_install() {
- # it's not autotools-based, so "${ED}" here, not "${D}", bug 531760
- emake install DESTDIR="${ED}" \
- FILESDIR="/usr/share/${PN}/"
-
- insinto "/usr/share/${PN}/cfg"
- doins cfg/*.cfg
- if use qt5 ; then
- dobin "${WORKDIR}/${P}_build/bin/${PN}-gui"
- dodoc gui/{projectfile.txt,gui.${PN}}
- fi
- if use htmlreport ; then
- pushd htmlreport || die
- distutils-r1_src_install
- popd || die
- find "${D}" -name "*.egg-info" -delete
- else
- rm "${ED}/usr/bin/cppcheck-htmlreport" || die
- fi
-
- dodoc -r tools/triage
-}