summaryrefslogtreecommitdiff
path: root/dev-libs
diff options
context:
space:
mode:
authorDan Goodliffe <dan@randomdan.homeip.net>2015-07-21 21:19:02 +0100
committerDan Goodliffe <dan@randomdan.homeip.net>2015-07-21 21:19:02 +0100
commite2cbb6a01599b30d86445ae723d5bf7afe5f72e7 (patch)
treecb8e438ac1db45ed586de208c4c7368361f4ae68 /dev-libs
parentAdd git and git-extras (diff)
downloadportage-e2cbb6a01599b30d86445ae723d5bf7afe5f72e7.tar.bz2
portage-e2cbb6a01599b30d86445ae723d5bf7afe5f72e7.tar.xz
portage-e2cbb6a01599b30d86445ae723d5bf7afe5f72e7.zip
Patch to not look for libs with ++11 appeneded
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/Ice/Ice-3.6.0-r2.ebuild279
-rw-r--r--dev-libs/Ice/Manifest2
-rw-r--r--dev-libs/Ice/files/dont-append-c++11-to-libs.patch22
3 files changed, 303 insertions, 0 deletions
diff --git a/dev-libs/Ice/Ice-3.6.0-r2.ebuild b/dev-libs/Ice/Ice-3.6.0-r2.ebuild
new file mode 100644
index 0000000..a429859
--- /dev/null
+++ b/dev-libs/Ice/Ice-3.6.0-r2.ebuild
@@ -0,0 +1,279 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/Ice/Ice-3.5.1.ebuild,v 1.11 2015/04/08 17:51:56 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+RUBY_OPTIONAL="yes"
+USE_RUBY="ruby19"
+
+inherit toolchain-funcs versionator python-r1 mono-env ruby-ng db-use
+
+DESCRIPTION="ICE middleware C++ library and generator tools"
+HOMEPAGE="http://www.zeroc.com/"
+SRC_URI="https://github.com/zeroc-ice/ice/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ia64 x86 ~x86-linux ~x64-macos"
+IUSE="doc examples +ncurses mono python ruby test debug c++0x"
+
+RDEPEND=">=dev-libs/expat-2.0.1
+ >=app-arch/bzip2-1.0.5
+ >=dev-libs/openssl-0.9.8o:0
+ || (
+ sys-libs/db:5.3[cxx]
+ sys-libs/db:5.1[cxx]
+ sys-libs/db:4.8[cxx]
+ )
+ ~dev-cpp/libmcpp-2.7.2
+ python? ( ${PYTHON_DEPS} )
+ ruby? ( $(ruby_implementation_depend ruby19) )
+ mono? ( dev-lang/mono )
+ !dev-python/IcePy
+ !dev-ruby/IceRuby"
+DEPEND="${RDEPEND}
+ ncurses? ( sys-libs/ncurses sys-libs/readline )
+ test? ( ${PYTHON_DEPS} )"
+
+# Maintainer notes:
+# - yes, we have to do the trickery with the move for the python functions
+# since the build and test frameworks deduce various settings from the path
+# and they can't be tricked by a symlink. And we also need
+# SUPPORT_PYTHON_ABIS=1 otherwise we can't get pyc/pyo anymore the sane way.
+# TODO: php bindings
+# TODO: java bindings
+
+#overwrite ruby-ng.eclass default
+S="${WORKDIR}/${P,,}"
+
+pkg_setup() {
+ # prevent ruby-ng.eclass from messing with src_unpack
+ :;
+}
+
+src_unpack() {
+ # prevent ruby-ng.eclass from messing with src_unpack
+ default
+ epatch ${FILESDIR}/dont-separate-c++11-libs.patch
+ epatch ${FILESDIR}/dont-append-c++11-to-libs.patch
+}
+
+src_prepare() {
+ sed -i \
+ -e 's|\(install_docdir[[:space:]]*\):=|\1?=|' \
+ -e 's|\(install_configdir[[:space:]]*\):=|\1?=|' \
+ cpp/config/Make.rules || die "sed failed"
+
+ sed -i \
+ -e 's|\(install_pythondir[[:space:]]*\):=|\1?=|' \
+ -e 's|\(install_rubydir[[:space:]]*\):=|\1?=|' \
+ -e 's|\(install_libdir[[:space:]]*\):=|\1?=|' \
+ {python,ruby}/config/Make.rules || die "sed failed"
+
+ sed -i \
+ -e 's|-O2 ||g' \
+ -e 's|-Werror ||g' \
+ cpp/config/Make.rules.Linux || die "sed failed"
+
+ sed -i \
+ -e 's|install-common||' \
+ -e 's|demo||' \
+ {cpp,csharp,php,python,ruby}/Makefile || die "sed failed"
+
+ sed -i \
+ -e 's|-f -root|-f -gacdir $(GAC_DIR) -root|' \
+ csharp/config/Make.rules.cs || die "sed failed"
+
+ # skip mono tests, bug #498484
+ sed -i \
+ -e 's|^\(SUBDIRS.*\)test|\1|' \
+ csharp/Makefile || die "sed failed"
+
+ if ! use test ; then
+ sed -i \
+ -e 's|^\(SUBDIRS.*\)test|\1|' \
+ {cpp,php,python,ruby}/Makefile || die "sed failed"
+ fi
+}
+
+suitable_db_version() {
+ local tested_slots="5.3 5.1 4.8"
+ for ver in ${tested_slots}; do
+ if [[ -n $(db_findver sys-libs/db:${ver}) ]]; then
+ echo ${ver}
+ return 0
+ fi
+ done
+ die "No suitable BerkDB versions found, aborting"
+}
+
+src_configure() {
+ MAKE_RULES="prefix=\"${ED}/usr\"
+ install_docdir=\"${ED}/usr/share/doc/${PF}\"
+ install_configdir=\"${ED}/usr/share/Ice-${PV}/config\"
+ install_mandir=\"${ED}/usr/share/man\"
+ embedded_runpath_prefix=\"${EPREFIX}/usr\"
+ LP64=yes"
+
+ use ncurses && MAKE_RULES="${MAKE_RULES} USE_READLINE=yes" || MAKE_RULES="${MAKE_RULES} USE_READLINE=no"
+ use debug && MAKE_RULES="${MAKE_RULES} OPTIMIZE=no" || MAKE_RULES="${MAKE_RULES} OPTIMIZE=yes"
+ use c++0x && MAKE_RULES="${MAKE_RULES} CPP11=yes" || MAKE_RULES="${MAKE_RULES} CPP11=no"
+
+ local BERKDB_VERSION="$(suitable_db_version)"
+ MAKE_RULES="${MAKE_RULES} DB_FLAGS=-I$(db_includedir ${BERKDB_VERSION})"
+ sed -i \
+ -e "s|g++|$(tc-getCXX)|" \
+ -e "s|\(CFLAGS[[:space:]]*=\)|\1 ${CFLAGS}|" \
+ -e "s|\(CXXFLAGS[[:space:]]*=\)|\1 ${CXXFLAGS}|" \
+ -e "s|\(LDFLAGS[[:space:]]*=\)|\1 ${LDFLAGS}|" \
+ -e "s|\(DB_LIBS[[:space:]]*=\) \-ldb_cxx|\1 -ldb_cxx-$(db_findver sys-libs/db:${BERKDB_VERSION})|" \
+ cpp/config/Make.rules{,.Linux} python/config/Make.rules || die "sed failed"
+
+ if use python ; then
+ S=${S}/python python_copy_sources
+
+ # make a place for the symlink
+ rm -r python/python || die
+ fi
+
+ if use ruby ; then
+ SITERUBY="$(ruby19 -r rbconfig -e 'print Config::CONFIG["sitedir"]')"
+ MAKE_RULES_RB="install_rubydir=\"${ED}/${SITERUBY}\"
+ install_libdir=\"${ED}/${SITERUBY}\""
+
+ # make it use ruby19 only
+ sed -i \
+ -e 's|RUBY = ruby|\019|' \
+ ruby/config/Make.rules || die "sed failed"
+ fi
+
+ MAKE_RULES_CS="GACINSTALL=yes GAC_ROOT=\"${ED}/usr/$(get_libdir)\" GAC_DIR=${EPREFIX}/usr/$(get_libdir)"
+
+ use test && python_export_best
+}
+
+src_compile() {
+ # Do not remove this export or build will break!
+ tc-export CXX
+
+ emake -C cpp ${MAKE_RULES} || die "emake failed"
+
+ if use doc ; then
+ emake -C cpp/doc || die "building docs failed"
+ fi
+
+ if use python ; then
+ building() {
+ emake -C "${BUILD_DIR}" ${MAKE_RULES} || die "emake py-${EPYTHON} failed"
+ }
+ BUILD_DIR=python python_foreach_impl building
+ fi
+
+ if use ruby ; then
+ emake -C ruby ${MAKE_RULES} ${MAKE_RULES_RB} || die "emake ruby failed"
+ fi
+
+ if use mono ; then
+ emake -C csharp ${MAKE_RULES} ${MAKE_RULES_CS} || die "emake csharp failed"
+ fi
+}
+
+src_install() {
+ insinto /usr/share/${P}
+ doins -r slice
+
+ emake -C cpp ${MAKE_RULES} install || die "emake install failed"
+
+ docinto cpp
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples-cpp
+ doins cpp/config/*.cfg
+ doins -r cpp/demo/*
+ fi
+
+ if use doc ; then
+ dohtml -r cpp/doc/reference/*
+ dodoc "${DISTDIR}/${P}.pdf"
+ fi
+
+ if use python ; then
+ installation() {
+ mkdir -p "${D}/$(python_get_sitedir)" || die
+
+ emake -C "${BUILD_DIR}" ${MAKE_RULES} \
+ install_pythondir="\"${D}/$(python_get_sitedir)\"" \
+ install_libdir="\"${D}/$(python_get_sitedir)\"" \
+ install || die "emake py-${EPYTHON} install failed"
+ }
+ BUILD_DIR=python python_foreach_impl installation
+
+ docinto python
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples-py
+ doins -r python/demo/*
+ fi
+ fi
+
+ if use ruby ; then
+ dodir "${SITERUBY}"
+ emake -C ruby ${MAKE_RULES} ${MAKE_RULES_RB} install || die "emake ruby install failed"
+
+ docinto ruby
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples-rb
+ doins -r ruby/demo/*
+ fi
+ fi
+
+ if use mono ; then
+ emake -C csharp ${MAKE_RULES} ${MAKE_RULES_CS} install || die "emake csharp install failed"
+
+ # TODO: anyone has an idea what those are for?
+ rm "${ED}"/usr/bin/*.xml
+
+ docinto csharp
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples-cs
+ doins -r csharp/demo/*
+ fi
+ fi
+}
+
+run_tests() {
+ # Run tests through the script interface since Python test runner
+ # fails to exit with non-zero code for some reason.
+
+ pushd "${1}" >/dev/null || die
+ ./allTests.py --script | sh
+ ret=${?}
+ popd >/dev/null || die
+
+ return ${ret}
+}
+
+src_test() {
+ run_tests cpp || die "emake cpp test failed"
+
+ if use python ; then
+ testing() {
+ # tests require that the directory is named 'python'
+ run_tests python || die "emake py-${EPYTHON} test failed"
+ }
+ BUILD_DIR=python python_foreach_impl testing
+ fi
+
+ if use ruby ; then
+ run_tests ruby || die "emake ruby test failed"
+ fi
+
+ if use mono ; then
+ # skip mono tests, bug #498484
+ ewarn "Tests for C# are currently disabled."
+# run_tests csharp || die "emake csharp test failed"
+ fi
+}
diff --git a/dev-libs/Ice/Manifest b/dev-libs/Ice/Manifest
index 0145af8..3f8cf81 100644
--- a/dev-libs/Ice/Manifest
+++ b/dev-libs/Ice/Manifest
@@ -1,3 +1,5 @@
+AUX dont-append-c++11-to-libs.patch 601 SHA256 50d17e49d05197dc4eaf0dd65a33b349cfb1e505b35ad6887bff7299fbb466df SHA512 db606339e17e10283f296e83050c661307030d5d93cd2924fcce5f18897c89f64b94ac0000bfa8f965df000d3006fb5128780a420d0617b5d805a17c7af59629 WHIRLPOOL ec1a1167bfe08c279ab05aa10686dad3ce06da0cc781a51ded26aa342c54d41cb16dcb5d9c737f4644076102e19fbf29b90e7d3fd8ff1b60570e7d2beef51d98
AUX dont-separate-c++11-libs.patch 557 SHA256 ca20324e948d4a1a89a1e81be401a5c1d7cd50beb5c1e82c038481dc8951cd3b SHA512 ca1ae59b2a6d67bdeae0fc01011e2bd8a0296d789063f8b130da270d390e682910a6d697205882beaf90ea17eec261c7433fade85de3741d36c124190986d664 WHIRLPOOL fe4e92c795ed2b03fd09a8fe2c96f70433465eab4aaf73211cca453606d8df7faf0937b3db7866762388dcc7950ea1714e5fc3cf94e66e4f356c6773afad1dc9
DIST Ice-3.6.0.tar.gz 5300956 SHA256 77933580cdc7fade0ebfce517935819e9eef5fc6b9e3f4143b07404daf54e25e SHA512 720767c09ebfea538b694e6f816de3cd3c8a204b5d8024689e93fb746e51ac19cd87b67bb213ad6b17e08e78ff88d3c0674e13cb960a8da2847c197047b1d928 WHIRLPOOL b2161cdf19a4ce36ad017f97bdef5a41e273293edf1615418b2f1a5ddc5a489aeea0cd82e2e909f879f9c890f539cbe7315b7b7b6f99eecb2ee520a2c91a0afe
EBUILD Ice-3.6.0-r1.ebuild 7276 SHA256 bb848bee6f57cc983216f4df9ae473dae35bc6c9529a8278f4cf77a7a63e7bb2 SHA512 572245d9131c89509b49e52011cd55f01c16602b1ead4451d3481f5c22715cfe54e5ee93e69aa910cc560a708e837eb9a362f7b3637cfb0114811b5cb2b0a730 WHIRLPOOL 662b1f9f5605c0122fb1634e0f716a786ce8b82bccb82d6d9bbd61b6aca33d12c6e880856076a43e5e4c918c94f23a8e36e374ed84d3370abd8ccac13eae01ab
+EBUILD Ice-3.6.0-r2.ebuild 7328 SHA256 d5ebf99aa6b11b4cc6a1da9c95db6b4e9af717c08e01aa300f220f0b772f11a6 SHA512 5a34f57b257634acdd575bab181b916ae1d6bf85a70bae9700981e4521d48e7c90be8b29d0f5e3152f36d8a9beb634d4c908b8c976a1d224c164cdaac76b1974 WHIRLPOOL 6cb462700927df1ae52ebcd67cf4ab7b435e374fe1a818fce5572bcab1641dc82cae5cf242837eb52209778fbf43d65b2b33c2cf1c7227dc7d3c26b76a37694c
diff --git a/dev-libs/Ice/files/dont-append-c++11-to-libs.patch b/dev-libs/Ice/files/dont-append-c++11-to-libs.patch
new file mode 100644
index 0000000..20fe1d8
--- /dev/null
+++ b/dev-libs/Ice/files/dont-append-c++11-to-libs.patch
@@ -0,0 +1,22 @@
+--- ice-3.6.0/cpp/src/Ice/DynamicLibrary.cpp
++++ ice-3.6.0/cpp/src/Ice/DynamicLibrary.cpp
+@@ -89,9 +89,6 @@
+ if(comma == string::npos)
+ {
+ libName = libSpec;
+-# if defined(ICE_CPP11) && defined(__GLIBCXX__)
+- libName += "++11";
+-# endif
+ if(useIceVersion)
+ {
+ int majorVersion = (ICE_INT_VERSION / 10000);
+@@ -119,9 +116,6 @@
+ return 0;
+ }
+ libName = libSpec.substr(0, comma);
+-# if defined(ICE_CPP11) && defined(__GLIBCXX__)
+- libName += "++11";
+-# endif
+ version = libSpec.substr(comma + 1);
+ }
+