summaryrefslogtreecommitdiff
path: root/dev-libs
diff options
context:
space:
mode:
authorDan Goodliffe <dan@randomdan.homeip.net>2024-06-03 18:10:22 +0100
committerDan Goodliffe <dan@randomdan.homeip.net>2024-06-04 01:23:30 +0100
commitc1f00fcae59d3f24c907a89db9bd695e6a3526ce (patch)
tree316142d9a27f2532b1e6d38d0afce85d71238d37 /dev-libs
parentRemove unrequired python things (diff)
downloadportage-c1f00fcae59d3f24c907a89db9bd695e6a3526ce.tar.bz2
portage-c1f00fcae59d3f24c907a89db9bd695e6a3526ce.tar.xz
portage-c1f00fcae59d3f24c907a89db9bd695e6a3526ce.zip
Remove packages now newer in official tree
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/Ice/Ice-3.7.10.ebuild260
-rw-r--r--dev-libs/Ice/Ice-3.7.9-r1.ebuild260
-rw-r--r--dev-libs/Ice/Manifest9
-rw-r--r--dev-libs/Ice/files/Ice-3.7.10-fix-musl-build.patch13
-rw-r--r--dev-libs/Ice/files/Ice-3.7.10-py3k11.patch45
-rw-r--r--dev-libs/Ice/files/Ice-3.7.9-fix-musl-build.patch13
-rw-r--r--dev-libs/Ice/files/Ice-3.7.9-py3k11.patch45
7 files changed, 0 insertions, 645 deletions
diff --git a/dev-libs/Ice/Ice-3.7.10.ebuild b/dev-libs/Ice/Ice-3.7.10.ebuild
deleted file mode 100644
index de5a733..0000000
--- a/dev-libs/Ice/Ice-3.7.10.ebuild
+++ /dev/null
@@ -1,260 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-RUBY_OPTIONAL="yes"
-USE_RUBY="ruby31"
-
-PHP_EXT_NAME="IcePHP"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-
-PHP_EXT_OPTIONAL_USE=php
-
-USE_PHP="php8-0 php8-1 php8-2"
-
-inherit php-ext-source-r3 python-r1 ruby-ng toolchain-funcs
-
-DESCRIPTION="ICE middleware C++ library and generator tools"
-HOMEPAGE="https://zeroc.com/products/ice"
-SRC_URI="https://github.com/zeroc-ice/ice/archive/v${PV}.tar.gz -> ${P}.tar.gz
- doc? ( https://download.zeroc.com/Ice/$(ver_cut 1-2)/${PN}-3.7.1.pdf )"
-LICENSE="GPL-2"
-SLOT="0/37"
-KEYWORDS="amd64 arm arm64 x86"
-IUSE="c++0x debug doc examples php python ruby test"
-RESTRICT="test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND=">=app-arch/bzip2-1.0.5
- >=dev-libs/expat-2.0.1
- dev-libs/libedit
- dev-cpp/libmcpp
- dev-db/lmdb:=
- dev-libs/openssl:0=
- virtual/libcrypt:=
- python? ( ${PYTHON_DEPS} )
- ruby? ( $(ruby_implementation_depend ruby31) )"
-DEPEND="${RDEPEND}
- test? (
- ${PYTHON_DEPS}
- dev-python/passlib[${PYTHON_USEDEP}]
- )"
-
-# Maintainer notes:
-# TODO: java bindings
-
-S="${WORKDIR}/${P,}"
-PHP_EXT_S="${S}/php"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-musl-build.patch"
-)
-
-pkg_setup() {
- # prevent ruby-ng.eclass from messing with pkg_setup
- return
-}
-
-src_unpack() {
- # prevent ruby-ng.eclass from messing with src_unpack
- default
-}
-
-src_prepare() {
- default
-
- sed -i \
- -e 's|-Werror ||g' \
- config/Make.rules.Linux || die
-
- # fix for x86 IceBox test
- sed -i \
- -e 's|"32"|""|' \
- scripts/IceBoxUtil.py || die
-
- if use !test; then
- # Disable building tests
- sed -i \
- -e 's|include \$(top_srcdir)/config/Make.tests.rules||' \
- config/Make.rules || die
- fi
-}
-
-src_configure() {
- CONFIGS+=("shared")
- use c++0x && CONFIGS+=("cpp11-shared")
- MAKE_RULES=(
- "embedded_runpath_prefix=\"${EPREFIX}/usr\""
- "OPTIMIZE=$(usex !debug)"
- "configs=${CONFIGS[*]}"
- "V=1"
- )
-
- if use python; then
- local S="${S}/python"
- python_copy_sources
- fi
-
- if use ruby; then
- SITERUBY="$(ruby31 -r rbconfig -e 'print RbConfig::CONFIG["sitelibdir"]')"
- SITERUBYARCH="$(ruby31 -r rbconfig -e 'print RbConfig::CONFIG["sitearchdir"]')"
- MAKE_RULES_RUBY=(
- "install_rubydir=\"${EPREFIX}/${SITERUBY}\""
- "install_rubylibdir=\"${EPREFIX}/${SITERUBYARCH}\""
- )
-
- # make it use ruby31 only
- sed -i \
- -e 's|RUBY ?= ruby|\031|' \
- ruby/config/Make.rules || die
- sed -i \
- -e 's|env ruby|\031|' \
- ruby/config/s2rb.rb || die
- sed -i \
- -e 's|env ruby|\031|' \
- ruby/scripts/slice2rb || die
- fi
-
- use test && python_setup
-}
-
-src_compile() {
- # Do not remove this export or build will break!
- tc-export CXX
-
- emake -C cpp "${MAKE_RULES[@]}"
-
- if use php; then
- local i
- for i in $(php_get_slots); do
- mkdir -p "${WORKDIR}/${i}" || die
- cp -r "${PHP_EXT_S}" "${WORKDIR}/${i}/" || die "Failed to copy source ${PHP_EXT_S} to PHP target directory"
-
- pushd "${WORKDIR}/${i}" >/dev/null || die
- ln -s "${S}/cpp" || die
- ln -s "${S}/config" || die
- ln -s "${S}/slice" || die
- ln -s "${S}/Makefile" || die
-
- emake -C php "${MAKE_RULES[@]}" "PHP_CONFIG=\"${EPREFIX}/usr/$(get_libdir)/${i}/bin/php-config\""
- popd >/dev/null || die
- done
- fi
-
- if use python; then
- building() {
- emake -C "${BUILD_DIR}" "${MAKE_RULES[@]}" PYTHON="${EPYTHON}"
- }
- local S="${S}/python"
- python_foreach_impl building
- fi
-
- if use ruby; then
- emake -C ruby "${MAKE_RULES[@]}" "${MAKE_RULES_RUBY[@]}"
- fi
-}
-
-src_test() {
- local -x LD_LIBRARY_PATH="${S}/cpp/$(get_libdir)${LD_LIBRARY_PATH+:}${LD_LIBRARY_PATH}"
- emake -C cpp "${MAKE_RULES[@]}" test
-
- # php tests require the extension loaded and are therefore skipped
-
- if use python; then
- testing() {
- PYTHONPATH="${BUILD_DIR}"/python emake -C "${BUILD_DIR}" \
- "${MAKE_RULES[@]}" \
- PYTHON="${EPYTHON}" \
- install_pythondir="\"$(python_get_sitedir)\"" \
- install_libdir="\"$(python_get_sitedir)\"" test
- }
- local S="${S}/python"
- python_foreach_impl testing
- fi
-
- if use ruby; then
- emake -C ruby "${MAKE_RULES[@]}" "${MAKE_RULES_RUBY[@]}" test
- fi
-}
-
-src_install() {
- local DOCS=( CHANGELOG*.md README.md )
- use doc && DOCS+=( "${DISTDIR}/${PN}-3.7.1.pdf" )
- einstalldocs
-
- MAKE_RULES_INSTALL=(
- "prefix=\"${ED}/usr\""
- "install_docdir=\"${ED}/usr/share/doc/${PF}\""
- "install_configdir=\"${ED}/usr/share/${P}/config\""
- "install_mandir=\"${ED}/usr/share/man/man1\""
- )
-
- insinto /usr/share/${P}
- doins -r slice
-
- emake -C cpp "${MAKE_RULES[@]}" "${MAKE_RULES_INSTALL[@]}" install
-
- if use examples; then
- docinto examples-cpp
- dodoc cpp/config/*.cfg
- docompress -x /usr/share/doc/${PF}/examples-cpp
- fi
-
- if use php; then
- insinto "/usr/share/php/${PN}"
-
- local i
- while IFS="" read -d $'\0' -r i; do
- doins "${i}"
- done < <(find "${S}/php/lib/" -name '*.php' -print0)
-
- pushd "${ED}/usr/share/${P}/slice" >/dev/null || die
-
- local -x LD_LIBRARY_PATH="${ED}/usr/$(get_libdir):${LD_LIBRARY_PATH}"
- for i in *; do
- mkdir -p "${ED}/usr/share/php/${i}" || die
- "${ED}"/usr/bin/slice2php \
- -I"${ED}/usr/share/${P}/slice/" --all \
- --output-dir "${ED}/usr/share/php/${i}" \
- --ice "${ED}/usr/share/${P}/slice/${i}"/*
- done
-
- for i in $(php_get_slots); do
- php_init_slot_env "${i}"
- insinto "${EXT_DIR}"
- newins "php/lib/ice.so" "${PHP_EXT_NAME}.so"
- done
- php-ext-source-r3_createinifiles
-
- popd >/dev/null || die
- fi
-
- if use python; then
- installation() {
- mkdir -p "${D}/$(python_get_sitedir)" || die
-
- emake -C "${BUILD_DIR}" \
- "${MAKE_RULES[@]}" \
- "${MAKE_RULES_INSTALL[@]}" \
- install_pythondir="\"${D}/$(python_get_sitedir)\"" \
- install_libdir="\"${D}/$(python_get_sitedir)\"" \
- install
- python_optimize
- }
- local S="${S}/python"
- python_foreach_impl installation
- fi
-
- if use ruby; then
- MAKE_RULES_RUBY=(
- "install_rubydir=\"${ED}/${SITERUBY}\""
- "install_rubylibdir=\"${ED}/${SITERUBYARCH}\""
- )
- dodir "${SITERUBY}"
- emake -C ruby "${MAKE_RULES[@]}" "${MAKE_RULES_INSTALL[@]}" "${MAKE_RULES_RUBY[@]}" install
- fi
-}
diff --git a/dev-libs/Ice/Ice-3.7.9-r1.ebuild b/dev-libs/Ice/Ice-3.7.9-r1.ebuild
deleted file mode 100644
index de5a733..0000000
--- a/dev-libs/Ice/Ice-3.7.9-r1.ebuild
+++ /dev/null
@@ -1,260 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-RUBY_OPTIONAL="yes"
-USE_RUBY="ruby31"
-
-PHP_EXT_NAME="IcePHP"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-
-PHP_EXT_OPTIONAL_USE=php
-
-USE_PHP="php8-0 php8-1 php8-2"
-
-inherit php-ext-source-r3 python-r1 ruby-ng toolchain-funcs
-
-DESCRIPTION="ICE middleware C++ library and generator tools"
-HOMEPAGE="https://zeroc.com/products/ice"
-SRC_URI="https://github.com/zeroc-ice/ice/archive/v${PV}.tar.gz -> ${P}.tar.gz
- doc? ( https://download.zeroc.com/Ice/$(ver_cut 1-2)/${PN}-3.7.1.pdf )"
-LICENSE="GPL-2"
-SLOT="0/37"
-KEYWORDS="amd64 arm arm64 x86"
-IUSE="c++0x debug doc examples php python ruby test"
-RESTRICT="test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND=">=app-arch/bzip2-1.0.5
- >=dev-libs/expat-2.0.1
- dev-libs/libedit
- dev-cpp/libmcpp
- dev-db/lmdb:=
- dev-libs/openssl:0=
- virtual/libcrypt:=
- python? ( ${PYTHON_DEPS} )
- ruby? ( $(ruby_implementation_depend ruby31) )"
-DEPEND="${RDEPEND}
- test? (
- ${PYTHON_DEPS}
- dev-python/passlib[${PYTHON_USEDEP}]
- )"
-
-# Maintainer notes:
-# TODO: java bindings
-
-S="${WORKDIR}/${P,}"
-PHP_EXT_S="${S}/php"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-musl-build.patch"
-)
-
-pkg_setup() {
- # prevent ruby-ng.eclass from messing with pkg_setup
- return
-}
-
-src_unpack() {
- # prevent ruby-ng.eclass from messing with src_unpack
- default
-}
-
-src_prepare() {
- default
-
- sed -i \
- -e 's|-Werror ||g' \
- config/Make.rules.Linux || die
-
- # fix for x86 IceBox test
- sed -i \
- -e 's|"32"|""|' \
- scripts/IceBoxUtil.py || die
-
- if use !test; then
- # Disable building tests
- sed -i \
- -e 's|include \$(top_srcdir)/config/Make.tests.rules||' \
- config/Make.rules || die
- fi
-}
-
-src_configure() {
- CONFIGS+=("shared")
- use c++0x && CONFIGS+=("cpp11-shared")
- MAKE_RULES=(
- "embedded_runpath_prefix=\"${EPREFIX}/usr\""
- "OPTIMIZE=$(usex !debug)"
- "configs=${CONFIGS[*]}"
- "V=1"
- )
-
- if use python; then
- local S="${S}/python"
- python_copy_sources
- fi
-
- if use ruby; then
- SITERUBY="$(ruby31 -r rbconfig -e 'print RbConfig::CONFIG["sitelibdir"]')"
- SITERUBYARCH="$(ruby31 -r rbconfig -e 'print RbConfig::CONFIG["sitearchdir"]')"
- MAKE_RULES_RUBY=(
- "install_rubydir=\"${EPREFIX}/${SITERUBY}\""
- "install_rubylibdir=\"${EPREFIX}/${SITERUBYARCH}\""
- )
-
- # make it use ruby31 only
- sed -i \
- -e 's|RUBY ?= ruby|\031|' \
- ruby/config/Make.rules || die
- sed -i \
- -e 's|env ruby|\031|' \
- ruby/config/s2rb.rb || die
- sed -i \
- -e 's|env ruby|\031|' \
- ruby/scripts/slice2rb || die
- fi
-
- use test && python_setup
-}
-
-src_compile() {
- # Do not remove this export or build will break!
- tc-export CXX
-
- emake -C cpp "${MAKE_RULES[@]}"
-
- if use php; then
- local i
- for i in $(php_get_slots); do
- mkdir -p "${WORKDIR}/${i}" || die
- cp -r "${PHP_EXT_S}" "${WORKDIR}/${i}/" || die "Failed to copy source ${PHP_EXT_S} to PHP target directory"
-
- pushd "${WORKDIR}/${i}" >/dev/null || die
- ln -s "${S}/cpp" || die
- ln -s "${S}/config" || die
- ln -s "${S}/slice" || die
- ln -s "${S}/Makefile" || die
-
- emake -C php "${MAKE_RULES[@]}" "PHP_CONFIG=\"${EPREFIX}/usr/$(get_libdir)/${i}/bin/php-config\""
- popd >/dev/null || die
- done
- fi
-
- if use python; then
- building() {
- emake -C "${BUILD_DIR}" "${MAKE_RULES[@]}" PYTHON="${EPYTHON}"
- }
- local S="${S}/python"
- python_foreach_impl building
- fi
-
- if use ruby; then
- emake -C ruby "${MAKE_RULES[@]}" "${MAKE_RULES_RUBY[@]}"
- fi
-}
-
-src_test() {
- local -x LD_LIBRARY_PATH="${S}/cpp/$(get_libdir)${LD_LIBRARY_PATH+:}${LD_LIBRARY_PATH}"
- emake -C cpp "${MAKE_RULES[@]}" test
-
- # php tests require the extension loaded and are therefore skipped
-
- if use python; then
- testing() {
- PYTHONPATH="${BUILD_DIR}"/python emake -C "${BUILD_DIR}" \
- "${MAKE_RULES[@]}" \
- PYTHON="${EPYTHON}" \
- install_pythondir="\"$(python_get_sitedir)\"" \
- install_libdir="\"$(python_get_sitedir)\"" test
- }
- local S="${S}/python"
- python_foreach_impl testing
- fi
-
- if use ruby; then
- emake -C ruby "${MAKE_RULES[@]}" "${MAKE_RULES_RUBY[@]}" test
- fi
-}
-
-src_install() {
- local DOCS=( CHANGELOG*.md README.md )
- use doc && DOCS+=( "${DISTDIR}/${PN}-3.7.1.pdf" )
- einstalldocs
-
- MAKE_RULES_INSTALL=(
- "prefix=\"${ED}/usr\""
- "install_docdir=\"${ED}/usr/share/doc/${PF}\""
- "install_configdir=\"${ED}/usr/share/${P}/config\""
- "install_mandir=\"${ED}/usr/share/man/man1\""
- )
-
- insinto /usr/share/${P}
- doins -r slice
-
- emake -C cpp "${MAKE_RULES[@]}" "${MAKE_RULES_INSTALL[@]}" install
-
- if use examples; then
- docinto examples-cpp
- dodoc cpp/config/*.cfg
- docompress -x /usr/share/doc/${PF}/examples-cpp
- fi
-
- if use php; then
- insinto "/usr/share/php/${PN}"
-
- local i
- while IFS="" read -d $'\0' -r i; do
- doins "${i}"
- done < <(find "${S}/php/lib/" -name '*.php' -print0)
-
- pushd "${ED}/usr/share/${P}/slice" >/dev/null || die
-
- local -x LD_LIBRARY_PATH="${ED}/usr/$(get_libdir):${LD_LIBRARY_PATH}"
- for i in *; do
- mkdir -p "${ED}/usr/share/php/${i}" || die
- "${ED}"/usr/bin/slice2php \
- -I"${ED}/usr/share/${P}/slice/" --all \
- --output-dir "${ED}/usr/share/php/${i}" \
- --ice "${ED}/usr/share/${P}/slice/${i}"/*
- done
-
- for i in $(php_get_slots); do
- php_init_slot_env "${i}"
- insinto "${EXT_DIR}"
- newins "php/lib/ice.so" "${PHP_EXT_NAME}.so"
- done
- php-ext-source-r3_createinifiles
-
- popd >/dev/null || die
- fi
-
- if use python; then
- installation() {
- mkdir -p "${D}/$(python_get_sitedir)" || die
-
- emake -C "${BUILD_DIR}" \
- "${MAKE_RULES[@]}" \
- "${MAKE_RULES_INSTALL[@]}" \
- install_pythondir="\"${D}/$(python_get_sitedir)\"" \
- install_libdir="\"${D}/$(python_get_sitedir)\"" \
- install
- python_optimize
- }
- local S="${S}/python"
- python_foreach_impl installation
- fi
-
- if use ruby; then
- MAKE_RULES_RUBY=(
- "install_rubydir=\"${ED}/${SITERUBY}\""
- "install_rubylibdir=\"${ED}/${SITERUBYARCH}\""
- )
- dodir "${SITERUBY}"
- emake -C ruby "${MAKE_RULES[@]}" "${MAKE_RULES_INSTALL[@]}" "${MAKE_RULES_RUBY[@]}" install
- fi
-}
diff --git a/dev-libs/Ice/Manifest b/dev-libs/Ice/Manifest
deleted file mode 100644
index 247c4f2..0000000
--- a/dev-libs/Ice/Manifest
+++ /dev/null
@@ -1,9 +0,0 @@
-AUX Ice-3.7.10-fix-musl-build.patch 568 BLAKE2B e320641208d46b27acc68d932aed336bf74407e3db8351e59b43172be771fe80ba813e01812a40b2cd57bd8002a0fe707f9a32fdef3f7b323c8a764f7f1c5c97 SHA512 be19a21ff3d4ddafb9d1b9c866f392b3eb081e450b9a061884485b7713f06ad5a7c58a0275328de8bdf39d0bfb2fcc085583105f47cae51e6cae42651a04ed3e
-AUX Ice-3.7.10-py3k11.patch 1500 BLAKE2B c7580ff44b3d29071f48c72c00069e9689d8e6d354027469b70c14b249bc1b8c4b7453df02a4282066869b936a3f71e850d17a93444f1b192ccfb9998d8e632b SHA512 ebe4e8458785d4191f42fca81995f31c9e7d6e9290a91491ef311b2104c193161b5d3a8489a34630e0d42cb9dd3870e3f48fe8089b8f0739afbe822e1a9db4fb
-AUX Ice-3.7.9-fix-musl-build.patch 568 BLAKE2B e320641208d46b27acc68d932aed336bf74407e3db8351e59b43172be771fe80ba813e01812a40b2cd57bd8002a0fe707f9a32fdef3f7b323c8a764f7f1c5c97 SHA512 be19a21ff3d4ddafb9d1b9c866f392b3eb081e450b9a061884485b7713f06ad5a7c58a0275328de8bdf39d0bfb2fcc085583105f47cae51e6cae42651a04ed3e
-AUX Ice-3.7.9-py3k11.patch 1500 BLAKE2B c7580ff44b3d29071f48c72c00069e9689d8e6d354027469b70c14b249bc1b8c4b7453df02a4282066869b936a3f71e850d17a93444f1b192ccfb9998d8e632b SHA512 ebe4e8458785d4191f42fca81995f31c9e7d6e9290a91491ef311b2104c193161b5d3a8489a34630e0d42cb9dd3870e3f48fe8089b8f0739afbe822e1a9db4fb
-DIST Ice-3.7.1.pdf 9351739 BLAKE2B 527f2c37aea19aedbfc580efd93ce4fae2eb7264342bb485822593e2da6fb75a61eea2b1a46187898af07f138d10bf9a213d0b2a0685c18cd1d4c624709a935b SHA512 199b59f14b87b2896ba970bf5aa32f6fd858cbd3fed18eac93acafe4e296db1361ca2d2000ed49f3390ed66c1d4ff8c1fcd3f14ab8197d7804c87fce422c8486
-DIST Ice-3.7.10.tar.gz 10120858 BLAKE2B a39a693975c53b7d1b1431f211e9682e8b8ffea62c63005c5158354a54807fc6966cff83f94ed6f86de1e5a2104cee3ac43eb12b9e9f406b67f9e77ffc78a800 SHA512 638ca8721db1559aae80c43663a1210ba9c8f72d58003f2d9457048c9100bee74036910917d1d10bf5b998ba49f0878177e094b436c83d3deb63613f9075483d
-DIST Ice-3.7.9.tar.gz 11098008 BLAKE2B f29013c0e58c83b26ee1b9c419a87a3e04e8e10a01220e2c0ab0e7cc2073cf4c6ad669ec73ccde8841272339557c54c29b94a91f2237760cc36b3f8336d43201 SHA512 07d7c439fbe1f69d808d05a11f32e09cdd8d4df2a93b6f253496304e0a521d417212ae688e316b4450dae406b59d1a460025b51ecd0614c69e48d86c0a6f81c5
-EBUILD Ice-3.7.10.ebuild 6053 BLAKE2B 115ce266158844c8194277350729161e7f0e943bdb3ca3b7c7abcd687c9f71555753fa34194a55b75b9f3f1321a8389608fae058747ecea2758b8d5587f86e49 SHA512 f81050713f31a8010f3aad692c5254849793395af7fc9105a573b9d2f2828d4d45a4cd2d6ba5793711839e4b446a7d596b6f7c88555d260dd3036a8c4cc091b1
-EBUILD Ice-3.7.9-r1.ebuild 6053 BLAKE2B 115ce266158844c8194277350729161e7f0e943bdb3ca3b7c7abcd687c9f71555753fa34194a55b75b9f3f1321a8389608fae058747ecea2758b8d5587f86e49 SHA512 f81050713f31a8010f3aad692c5254849793395af7fc9105a573b9d2f2828d4d45a4cd2d6ba5793711839e4b446a7d596b6f7c88555d260dd3036a8c4cc091b1
diff --git a/dev-libs/Ice/files/Ice-3.7.10-fix-musl-build.patch b/dev-libs/Ice/files/Ice-3.7.10-fix-musl-build.patch
deleted file mode 100644
index 76fa6c5..0000000
--- a/dev-libs/Ice/files/Ice-3.7.10-fix-musl-build.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-https://github.com/void-linux/void-packages/blob/master/srcpkgs/Ice/patches/fix-musl.patch
-
---- a/cpp/src/IceUtil/UtilException.cpp
-+++ b/cpp/src/IceUtil/UtilException.cpp
-@@ -43,7 +43,7 @@
- # endif
- # endif
-
--# if !defined(_AIX) && !defined(__sun) && !defined(__FreeBSD__) && !defined(__MINGW32__) && !defined(ICE_STATIC_LIBS)
-+# if !defined(_AIX) && !defined(__sun) && !defined(__FreeBSD__) && !defined(__MINGW32__) && !defined(ICE_STATIC_LIBS) && defined(__GLIBC__)
- # include <execinfo.h>
- # include <cxxabi.h>
- # include <stdint.h>
diff --git a/dev-libs/Ice/files/Ice-3.7.10-py3k11.patch b/dev-libs/Ice/files/Ice-3.7.10-py3k11.patch
deleted file mode 100644
index 7295aa6..0000000
--- a/dev-libs/Ice/files/Ice-3.7.10-py3k11.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From a98f34df525dce54a96f443806599978b293d7c5 Mon Sep 17 00:00:00 2001
-From: Jose <pepone@users.noreply.github.com>
-Date: Thu, 3 Nov 2022 16:52:58 +0100
-Subject: [PATCH] Python 3.11 build fixes (#1394)
-
----
- python/modules/IcePy/Slice.cpp | 7 ++++++-
- python/modules/IcePy/Util.cpp | 5 +++++
- 2 files changed, 11 insertions(+), 1 deletion(-)
-
-diff --git a/python/modules/IcePy/Slice.cpp b/python/modules/IcePy/Slice.cpp
-index e11365d8d40..7138e76dac0 100644
---- a/python/modules/IcePy/Slice.cpp
-+++ b/python/modules/IcePy/Slice.cpp
-@@ -14,7 +14,12 @@
- // Python headers needed for PyEval_EvalCode.
- //
- #include <compile.h>
--#include <eval.h>
-+// Use ceval.h instead of eval.h with Pyhthon 3.11 and greater
-+#if PY_VERSION_HEX >= 0x030B0000
-+# include <ceval.h>
-+#else
-+# include <eval.h>
-+#endif
-
- using namespace std;
- using namespace IcePy;
-diff --git a/python/modules/IcePy/Util.cpp b/python/modules/IcePy/Util.cpp
-index f15c7a5c690..73955c933a2 100644
---- a/python/modules/IcePy/Util.cpp
-+++ b/python/modules/IcePy/Util.cpp
-@@ -225,7 +225,12 @@ IcePy::getFunction()
- //
- // Get name of current function.
- //
-+ // Use PyEval_GetFrame with Pyhthon >= 3.11
-+#if PY_VERSION_HEX >= 0x030B0000
-+ PyFrameObject *f = PyEval_GetFrame();
-+#else
- PyFrameObject *f = PyThreadState_GET()->frame;
-+#endif
- PyObjectHandle code = getAttr(reinterpret_cast<PyObject*>(f), "f_code", false);
- assert(code.get());
- PyObjectHandle func = getAttr(code.get(), "co_name", false);
diff --git a/dev-libs/Ice/files/Ice-3.7.9-fix-musl-build.patch b/dev-libs/Ice/files/Ice-3.7.9-fix-musl-build.patch
deleted file mode 100644
index 76fa6c5..0000000
--- a/dev-libs/Ice/files/Ice-3.7.9-fix-musl-build.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-https://github.com/void-linux/void-packages/blob/master/srcpkgs/Ice/patches/fix-musl.patch
-
---- a/cpp/src/IceUtil/UtilException.cpp
-+++ b/cpp/src/IceUtil/UtilException.cpp
-@@ -43,7 +43,7 @@
- # endif
- # endif
-
--# if !defined(_AIX) && !defined(__sun) && !defined(__FreeBSD__) && !defined(__MINGW32__) && !defined(ICE_STATIC_LIBS)
-+# if !defined(_AIX) && !defined(__sun) && !defined(__FreeBSD__) && !defined(__MINGW32__) && !defined(ICE_STATIC_LIBS) && defined(__GLIBC__)
- # include <execinfo.h>
- # include <cxxabi.h>
- # include <stdint.h>
diff --git a/dev-libs/Ice/files/Ice-3.7.9-py3k11.patch b/dev-libs/Ice/files/Ice-3.7.9-py3k11.patch
deleted file mode 100644
index 7295aa6..0000000
--- a/dev-libs/Ice/files/Ice-3.7.9-py3k11.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From a98f34df525dce54a96f443806599978b293d7c5 Mon Sep 17 00:00:00 2001
-From: Jose <pepone@users.noreply.github.com>
-Date: Thu, 3 Nov 2022 16:52:58 +0100
-Subject: [PATCH] Python 3.11 build fixes (#1394)
-
----
- python/modules/IcePy/Slice.cpp | 7 ++++++-
- python/modules/IcePy/Util.cpp | 5 +++++
- 2 files changed, 11 insertions(+), 1 deletion(-)
-
-diff --git a/python/modules/IcePy/Slice.cpp b/python/modules/IcePy/Slice.cpp
-index e11365d8d40..7138e76dac0 100644
---- a/python/modules/IcePy/Slice.cpp
-+++ b/python/modules/IcePy/Slice.cpp
-@@ -14,7 +14,12 @@
- // Python headers needed for PyEval_EvalCode.
- //
- #include <compile.h>
--#include <eval.h>
-+// Use ceval.h instead of eval.h with Pyhthon 3.11 and greater
-+#if PY_VERSION_HEX >= 0x030B0000
-+# include <ceval.h>
-+#else
-+# include <eval.h>
-+#endif
-
- using namespace std;
- using namespace IcePy;
-diff --git a/python/modules/IcePy/Util.cpp b/python/modules/IcePy/Util.cpp
-index f15c7a5c690..73955c933a2 100644
---- a/python/modules/IcePy/Util.cpp
-+++ b/python/modules/IcePy/Util.cpp
-@@ -225,7 +225,12 @@ IcePy::getFunction()
- //
- // Get name of current function.
- //
-+ // Use PyEval_GetFrame with Pyhthon >= 3.11
-+#if PY_VERSION_HEX >= 0x030B0000
-+ PyFrameObject *f = PyEval_GetFrame();
-+#else
- PyFrameObject *f = PyThreadState_GET()->frame;
-+#endif
- PyObjectHandle code = getAttr(reinterpret_cast<PyObject*>(f), "f_code", false);
- assert(code.get());
- PyObjectHandle func = getAttr(code.get(), "co_name", false);