summaryrefslogtreecommitdiff
path: root/dev-libs/libdbpp-postgresql
diff options
context:
space:
mode:
authorDan Goodliffe <dan@randomdan.homeip.net>2022-03-11 19:45:45 +0000
committerDan Goodliffe <dan@randomdan.homeip.net>2022-03-12 12:44:11 +0000
commit1a372cd2bb0f66b62e9fd0fa03fd0eb36035870e (patch)
treed28e79c4c3f9f8013d7f9e29bfb9220b3f1ef101 /dev-libs/libdbpp-postgresql
parentAdd NSCA (diff)
downloadportage-1a372cd2bb0f66b62e9fd0fa03fd0eb36035870e.tar.bz2
portage-1a372cd2bb0f66b62e9fd0fa03fd0eb36035870e.tar.xz
portage-1a372cd2bb0f66b62e9fd0fa03fd0eb36035870e.zip
Big update
Diffstat (limited to 'dev-libs/libdbpp-postgresql')
-rw-r--r--dev-libs/libdbpp-postgresql/Manifest2
-rw-r--r--dev-libs/libdbpp-postgresql/libdbpp-postgresql-1.4.7.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/libdbpp-postgresql/Manifest b/dev-libs/libdbpp-postgresql/Manifest
index 66af734..0c43285 100644
--- a/dev-libs/libdbpp-postgresql/Manifest
+++ b/dev-libs/libdbpp-postgresql/Manifest
@@ -1,2 +1,4 @@
DIST libdbpp-postgresql-1.4.5.tar.xz 16620 BLAKE2B 8965386aaace62816cc14a66daa61d00f45f5b73a8fb084b5860b8d494ba65de1cbd3590741c8c361fa3374738688000f21e6151231679403de38301e999ef5f SHA512 c0d7abbc133bd5381191c331324a3d9d0c1d085352bbd6eb5ee89db32fc56580b4aaef274e7853771400a0b2d8c6c7ecce78d2a7ae56a6e00c7e2af4e2cede01
+DIST libdbpp-postgresql-1.4.7.tar.xz 17356 BLAKE2B 3407fbf662988b1e98b05e19a6b61587c6b1abcaba7affe2ff7b67654bcc5676904aca205efb0157a9441dfe88700c7995945526733a298ab4c047d32cf75988 SHA512 ee40a34348542d42465c9a82e1837e64fa489c3bda87c0dfd005159162596ba7e87520763fb03767967a9f4baad540bd9717d95c865c1cc53043afcf307b3906
EBUILD libdbpp-postgresql-1.4.5-r1.ebuild 564 BLAKE2B 9e9677cfb27de3c009bb4c5259919d93af53f04044570e423253fb05a28393cb4a0cc704c588c91e1cc5f795d3b9f81e3c79974865148432241a03e754fe9a9c SHA512 4c5bda6f739e11ba7326b243962816f2fa1512c20e59b80252cc1423b087266c3c9b68f1e79606f76f68dd245540d621885ff0544bd2ffc7ec68b46fca94a160
+EBUILD libdbpp-postgresql-1.4.7.ebuild 566 BLAKE2B 7958db434a58a738dede980e6847f735f2554e9fd08922889f99394074dea5bb43dd1160857a9c4636906bde4803dab8f7e860b40979623ae665c45fb5e50edf SHA512 7766c7d0c14cec0d33dbd628e41d7d3aa384d888d596ee2c4346c78bbec840b57b55ddce7a939003a4925edb6e36aaa9632ba4b5cdbf246723c090effdddd51d
diff --git a/dev-libs/libdbpp-postgresql/libdbpp-postgresql-1.4.7.ebuild b/dev-libs/libdbpp-postgresql/libdbpp-postgresql-1.4.7.ebuild
new file mode 100644
index 0000000..7e4f90a
--- /dev/null
+++ b/dev-libs/libdbpp-postgresql/libdbpp-postgresql-1.4.7.ebuild
@@ -0,0 +1,33 @@
+EAPI="7"
+
+inherit bjam
+
+DESCRIPTION="C++ database connectivity PostgreSQL components"
+HOMEPAGE="http://libdbpp.randomdan.homeip.net/postgresql"
+
+SRC_URI="https://git.randomdan.homeip.net/repo/${PN}/snapshot/${P}.tar.xz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="x86 amd64"
+
+RDEPEND="
+ dev-libs/boost:=
+ >=dev-libs/libdbpp-1.4.8:=
+ dev-db/postgresql
+ >=dev-libs/libadhocutil-0.8:=
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ dev-util/boost-build
+"
+
+src_compile() {
+ bjambuild libpqpp//dbpp-postgresql
+}
+
+src_install() {
+ bjaminstall libpqpp//install \
+ -i /dbpp-postgresql
+}
+