summaryrefslogtreecommitdiff
path: root/dev-libs/libdbpp-postgresql
diff options
context:
space:
mode:
authorDan Goodliffe <dan@randomdan.homeip.net>2015-09-25 20:07:09 +0100
committerDan Goodliffe <dan@randomdan.homeip.net>2015-09-25 20:07:09 +0100
commit0eff785320598afdaa960cbf8fe08953f15eac83 (patch)
treebfd8ceb4b9e2deb30d62b4db6f788df508a289f0 /dev-libs/libdbpp-postgresql
parentInitial commit of libdbpp (diff)
downloadportage-0eff785320598afdaa960cbf8fe08953f15eac83.tar.bz2
portage-0eff785320598afdaa960cbf8fe08953f15eac83.tar.xz
portage-0eff785320598afdaa960cbf8fe08953f15eac83.zip
Initial commit of libdbpp-postgresql
Diffstat (limited to 'dev-libs/libdbpp-postgresql')
-rw-r--r--dev-libs/libdbpp-postgresql/Manifest2
-rw-r--r--dev-libs/libdbpp-postgresql/libdbpp-postgresql-0.9_beta2.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/libdbpp-postgresql/Manifest b/dev-libs/libdbpp-postgresql/Manifest
new file mode 100644
index 0000000..84e16ac
--- /dev/null
+++ b/dev-libs/libdbpp-postgresql/Manifest
@@ -0,0 +1,2 @@
+DIST libdbpp-postgresql-0.9_beta2.tar.bz2 12670 SHA256 28f9a80f8bfd39d7cdf1fae49ea65ebeb3da0899d8caaa58d344c4f3133f3c9a SHA512 7b6801a8278a4f841717a50cb14c822cd6c9fe7e5561d4aabfe96b2f6c7397e47f0b88ad094fbc8b16c6d5b643c52022c01c73dbb4b1971e2399c46b442a2881 WHIRLPOOL 4b58bcdb52258df05f53a6b2ef051877bfdb4a88b1f230d8a26f70bd7ffb38b4cb9e52fe812b2971621945f2de51fccad2f60f5cfbca22d0c5a95461e9535434
+EBUILD libdbpp-postgresql-0.9_beta2.ebuild 816 SHA256 0b7f088319b04f95026e7946b03254729a4784952c89d1ff929e68ce42277fb5 SHA512 fcfff0256fc2c9281e8d83fa582a453f5e9b5eeb352f68c51f2b10345fec197e68ad2bcb19aba2a02defbf538ee33ee260a4b599acbdf5390c3701de72634a2f WHIRLPOOL 4989e120b68be41a552068911fec4d9d49f5aa9102929c2f83790dd67a9bb0088e487ec6ccff41809bdc3e8eea41580fb8ccb35d29546e5b7cfc407a5c29b617
diff --git a/dev-libs/libdbpp-postgresql/libdbpp-postgresql-0.9_beta2.ebuild b/dev-libs/libdbpp-postgresql/libdbpp-postgresql-0.9_beta2.ebuild
new file mode 100644
index 0000000..c69a399
--- /dev/null
+++ b/dev-libs/libdbpp-postgresql/libdbpp-postgresql-0.9_beta2.ebuild
@@ -0,0 +1,37 @@
+EAPI="5"
+
+DESCRIPTION="C++ database connectivity PostgreSQL components"
+HOMEPAGE="http://libdbpp.randomdan.homeip.net/postgresql"
+
+SRC_URI="http://releases.randomdan.homeip.net/git/${P}.tar.bz2"
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="x86 amd64"
+
+RDEPEND="
+ dev-libs/boost
+ dev-libs/libdbpp
+ dev-libs/libadhocutil
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/boost-build
+"
+
+src_prepare() {
+ sed -ie "s|^using gcc .*|using gcc : : : <compileflags>\"${CXXFLAGS}\" <linkflags>\"${LDFLAGS}\" ;|" ${S}/Jamroot.jam
+}
+
+src_compile() {
+ cd ${S}/libpqpp || die
+ setarch $(uname -m) -RL bjam ${BJAMOPTS} variant=release dbpp-postgresql -q || die
+}
+
+src_install() {
+ cd ${S}/libpqpp || die
+
+ setarch $(uname -m) -RL bjam ${BJAMOPTS} variant=release install -q \
+ --libdir=${D}/usr/lib \
+ --includedir=${D}/usr/include/dbpp-postgresql || die
+}
+