summaryrefslogtreecommitdiff
path: root/dev-libs/Ice
diff options
context:
space:
mode:
authorDan Goodliffe <dan@randomdan.homeip.net>2018-04-29 12:09:54 +0100
committerDan Goodliffe <dan@randomdan.homeip.net>2018-04-29 13:01:29 +0100
commit92bda7ee0642a987916fd081f6c093de73511630 (patch)
tree2a557c2bd574b88801fc2f52f60abd204e123d21 /dev-libs/Ice
parentBump libjsonpp (diff)
downloadportage-92bda7ee0642a987916fd081f6c093de73511630.tar.bz2
portage-92bda7ee0642a987916fd081f6c093de73511630.tar.xz
portage-92bda7ee0642a987916fd081f6c093de73511630.zip
Big update
Updates all projects to C++17 and Ice-3.7.
Diffstat (limited to 'dev-libs/Ice')
-rw-r--r--dev-libs/Ice/Ice-3.7.1.ebuild294
-rw-r--r--dev-libs/Ice/Manifest2
2 files changed, 296 insertions, 0 deletions
diff --git a/dev-libs/Ice/Ice-3.7.1.ebuild b/dev-libs/Ice/Ice-3.7.1.ebuild
new file mode 100644
index 0000000..bc4244e
--- /dev/null
+++ b/dev-libs/Ice/Ice-3.7.1.ebuild
@@ -0,0 +1,294 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+RUBY_OPTIONAL="yes"
+USE_RUBY="ruby22"
+
+PHP_EXT_NAME="IcePHP"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+PHP_EXT_OPTIONAL_USE=php
+
+USE_PHP="php7-0"
+
+# This variable does not belong to any eclass. It is solely used in this ebuild
+# db:6.2 breaks the build process
+BERKDB_SLOTS=( 6.1 5.3 5.1 4.8 )
+
+inherit db-use eutils mono-env php-ext-source-r2 python-r1 ruby-ng toolchain-funcs versionator
+
+DESCRIPTION="ICE middleware C++ library and generator tools"
+HOMEPAGE="http://www.zeroc.com/"
+ICEVERSION="$(get_version_component_range 1-2)"
+SRC_URI="https://github.com/zeroc-ice/ice/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0/37"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples libressl +ncurses mono php python ruby c++0x test debug"
+
+RDEPEND=">=dev-libs/expat-2.0.1
+ >=app-arch/bzip2-1.0.5
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ || (
+ $(for slot in ${BERKDB_SLOTS[@]} ; do printf '%s\n' "sys-libs/db:${slot}[cxx]" ; done)
+ )
+ >=dev-cpp/libmcpp-2.7.2-r3
+ =dev-db/lmdb-0.9*
+ python? ( ${PYTHON_DEPS} )
+ ruby? ( $(ruby_implementation_depend ruby22) )
+ mono? ( dev-lang/mono )
+ php? ( dev-lang/php:7.0 )
+ !dev-python/IcePy
+ !dev-ruby/IceRuby"
+DEPEND="${RDEPEND}
+ ncurses? ( sys-libs/ncurses:0= sys-libs/readline:0= )
+ test? (
+ ${PYTHON_DEPS}
+ dev-python/passlib[${PYTHON_USEDEP}]
+ )"
+
+# Maintainer notes:
+# TODO: java bindings, multiple ruby versions (supports 2.{1,2,3})
+
+S="${P/_/-}"
+S="${WORKDIR}/${S/I/i}"
+PHP_EXT_S="${S}/php"
+
+pkg_setup() {
+ # prevent ruby-ng.eclass from messing with pkg_setup
+ return
+}
+
+src_unpack() {
+ # prevent ruby-ng.eclass from messing with src_unpack
+ default
+}
+
+src_prepare() {
+ # prevent ruby-ng.eclass from messing with src_prepare
+ default
+}
+
+src_configure() {
+ suitable_db_version() {
+ local ver
+ for ver in "${BERKDB_SLOTS[@]}"; do
+ if [[ -n $(db_findver sys-libs/db:${ver}) ]]; then
+ echo "${ver}"
+ return 0
+ fi
+ done
+ die "No suitable BerkDB versions found, aborting"
+ }
+
+ CONFIGS=("shared")
+ use c++0x && CONFIGS+=("cpp11-shared")
+ MAKE_RULES=(
+ "prefix=\"${ED%/}/usr\""
+ "install_docdir=\"${ED%/}/usr/share/doc/${PF}\""
+ "install_configdir=\"${ED%/}/usr/share/${P}/config\""
+ "install_mandir=\"${ED%/}/usr/share/man\""
+ "embedded_runpath_prefix=\"${EPREFIX}/usr\""
+ "configs=${CONFIGS[*]}"
+ "new_dtags=yes"
+ "NOTEST=$(usex !test)"
+ "USE_READLINE=$(usex ncurses)"
+ "OPTIMIZE=$(usex !debug)"
+ )
+
+ local BERKDB_VERSION="$(suitable_db_version)"
+ MAKE_RULES+=("DB_FLAGS=-I$(db_includedir ${BERKDB_VERSION})")
+ sed -i \
+ -e "s|g++|$(tc-getCXX)|" \
+ -e "s|\(CFLAGS[[:space:]]*=\)|\1 ${CFLAGS}|" \
+ -e "s|\(CXXFLAGS[[:space:]]*=\)|\1 ${CXXFLAGS}|" \
+ -e "s|\(LDFLAGS[[:space:]]*=\)|\1 ${LDFLAGS}|" \
+ -e "s|\(DB_LIBS[[:space:]]*=\) \-ldb_cxx|\1 -ldb_cxx-$(db_findver sys-libs/db:${BERKDB_VERSION})|" \
+ cpp/config/Make.rules python/config/Make.rules || die "sed failed"
+
+ if use python; then
+ local S="${S}/python"
+ python_copy_sources
+ fi
+
+ if use ruby; then
+ SITERUBY="$(ruby22 -r rbconfig -e 'print RbConfig::CONFIG["sitelibdir"]')"
+ MAKE_RULES_RUBY=(
+ "install_rubydir=\"${ED%/}/${SITERUBY}\""
+ "install_libdir=\"${ED%/}/${SITERUBY}\""
+ )
+
+ # make it use ruby22 only
+ sed -i \
+ -e 's|RUBY = ruby|\022|' \
+ ruby/config/Make.rules || die "sed failed"
+ sed -i \
+ -e 's|env ruby|\022|' \
+ ruby/config/s2rb.rb || die "sed failed"
+ sed -i \
+ -e 's|env ruby|\022|' \
+ ruby/scripts/slice2rb || die "sed failed"
+ sed -i \
+ -e 's|output.write("ruby|\022|' \
+ scripts/TestUtil.py || die "sed failed"
+ fi
+
+ MAKE_RULES_MONO=(
+ "GACINSTALL=yes"
+ "GAC_ROOT=\"${ED%/}/usr/$(get_libdir)\""
+ "GAC_DIR=\"${EPREFIX}/usr/$(get_libdir)\""
+ "install_libdir=\"${ED%/}/usr/$(get_libdir)\""
+ "install_pkgconfigdir=\"${ED%/}/usr/$(get_libdir)/pkgconfig\""
+ )
+
+ if has_version ">dev-lang/mono-4"; then
+ MAKE_RULES_MONO+=("MCS=mcs")
+ fi
+
+ use test && python_setup
+}
+
+src_compile() {
+ # Do not remove this export or build will break!
+ tc-export CXX
+
+ emake -C cpp "${MAKE_RULES[@]}" srcs
+
+ if use php; then
+ local i
+ for i in $(php_get_slots); do
+ mkdir -p "${WORKDIR}/${i}" || die
+ cp -r "${PHP_EXT_S}" "${WORKDIR}/${i}/" || die "Failed to copy source ${PHP_EXT_S} to PHP target directory"
+
+ pushd "${WORKDIR}/${i}" >/dev/null || die
+ ln -s "${S}/cpp" || die
+ ln -s "${S}/config" || die
+ ln -s "${S}/slice" || die
+ ln -s "${S}/Makefile" || die
+
+ emake -C php "${MAKE_RULES[@]}" USE_NAMESPACES=yes "PHP_CONFIG=\"${EPREFIX}/usr/$(get_libdir)/${i}/bin/php-config\""
+ popd >/dev/null || die
+ done
+ fi
+
+ if use python; then
+ building() {
+ emake -C "${BUILD_DIR}" "${MAKE_RULES[@]}" PYTHON="${EPYTHON}"
+ }
+ local S="${S}/python"
+ python_foreach_impl building
+ fi
+
+ if use ruby; then
+ emake -C ruby "${MAKE_RULES[@]}" "${MAKE_RULES_RUBY[@]}"
+ fi
+
+ if use mono; then
+ emake -C csharp "${MAKE_RULES[@]}" "${MAKE_RULES_MONO[@]}"
+ fi
+}
+
+src_test() {
+ local -x LD_LIBRARY_PATH="${S}/cpp/$(get_libdir)${LD_LIBRARY_PATH+:}${LD_LIBRARY_PATH}"
+ emake -C cpp "${MAKE_RULES[@]}" tests
+
+ # php tests require the extension loaded and are therefore skipped
+
+ if use python; then
+ testing() {
+ emake -C "${BUILD_DIR}" \
+ "${MAKE_RULES[@]}" \
+ PYTHON="${EPYTHON}" \
+ install_pythondir="\"${D%/}/$(python_get_sitedir)\"" \
+ install_libdir="\"${D%/}/$(python_get_sitedir)\"" test
+ }
+ local S="${S}/python"
+ python_foreach_impl testing
+ fi
+
+ if use ruby; then
+ emake -C ruby "${MAKE_RULES[@]}" "${MAKE_RULES_RUBY[@]}" test
+ fi
+
+ if use mono; then
+ # skip mono tests, bug #498484
+ ewarn "Tests for C# are currently disabled."
+ #emake -C csharp "${MAKE_RULES[@]}" "${MAKE_RULES_MONO[@]}" test
+ fi
+}
+
+src_install() {
+ local DOCS=( CHANGELOG*.md README.md )
+ einstalldocs
+
+ insinto /usr/share/${P}
+ doins -r slice
+
+ emake -C cpp "${MAKE_RULES[@]}" install
+ find ${D}/usr/include ${D}/usr/share -type f -print0 | xargs -r0 chmod a-x
+
+ if use examples; then
+ docinto examples-cpp
+ dodoc cpp/config/*.cfg
+ docompress -x /usr/share/doc/${PF}/examples-cpp
+ fi
+
+ if use php; then
+ insinto "/usr/share/php/${PN}"
+
+ local i
+ while IFS="" read -d $'\0' -r i; do
+ doins "${i}"
+ done < <(find "${S}/php/lib/" -name '*.php' -print0)
+
+ pushd "${ED%/}/usr/share/${P}/slice" >/dev/null || die
+
+ local -x LD_LIBRARY_PATH="${ED%/}/usr/$(get_libdir):${LD_LIBRARY_PATH}"
+ for i in *; do
+ mkdir -p "${ED%/}/usr/share/php/${i}" || die
+ "${ED%/}"/usr/bin/slice2php \
+ -I"${ED%/}/usr/share/${P}/slice/" --all \
+ --output-dir "${ED%/}/usr/share/php/${i}" \
+ --ice "${ED%/}/usr/share/${P}/slice/${i}"/*
+ done
+
+ for i in $(php_get_slots); do
+ php_init_slot_env "${i}"
+ insinto "${EXT_DIR}"
+ newins "php/lib/${PHP_EXT_NAME}.so" "${PHP_EXT_NAME}.so"
+ done
+ php-ext-source-r2_createinifiles
+
+ popd >/dev/null || die
+ fi
+
+ if use python; then
+ installation() {
+ mkdir -p "${D%/}/$(python_get_sitedir)" || die
+
+ emake -C "${BUILD_DIR}" \
+ "${MAKE_RULES[@]}" \
+ install_pythondir="\"${D%/}/$(python_get_sitedir)\"" \
+ install_libdir="\"${D%/}/$(python_get_sitedir)\"" \
+ install
+ }
+ local S="${S}/python"
+ python_foreach_impl installation
+ fi
+
+ if use ruby; then
+ dodir "${SITERUBY}"
+ emake -C ruby "${MAKE_RULES[@]}" "${MAKE_RULES_RUBY[@]}" install
+ fi
+
+ if use mono; then
+ emake -C csharp "${MAKE_RULES[@]}" "${MAKE_RULES_MONO[@]}" install
+ fi
+}
diff --git a/dev-libs/Ice/Manifest b/dev-libs/Ice/Manifest
index 24ffdfe..a80cb86 100644
--- a/dev-libs/Ice/Manifest
+++ b/dev-libs/Ice/Manifest
@@ -8,5 +8,7 @@ DIST Ice-3.6.3.pdf 8844957 BLAKE2B 137e3ce85885305931cbbb2c838ccc52175dffb7ad512
DIST Ice-3.6.3.tar.gz 5512741 BLAKE2B 7219cd263ccf6207c0d1e788358004744bd53717bba79a53be468b5e38ddbc81895ef078ba31c98d90ac9ccdd9e17123f4a7ab590fa354c28f6d82f09bf0301d SHA512 6e17d21f55a8504af87a64c498a0c4d2084ed96a85c7a66d00319324774f671ace6afa03108d8d4e9bedf5fcfc2f3dba247949a27deecacdd0d298bd0bfe0a45
DIST Ice-3.6.4.pdf 8907736 BLAKE2B 5a631c1e2e147c8ed3b31a84192210c92bbe83e8644ec9d7d164d1b94a20069ce77f6baf54910ac00c7216cbc2979caac6fa78457e9292a84407e93000f9903a SHA512 9bd2d373eb83e08e563cab174a53063a490367dea3e4b910f93f0477c3817282c859f07e46e503006e9bd37678fb6da31a58b88bfabd217b5e371fff685321a0
DIST Ice-3.6.4.tar.gz 5523841 BLAKE2B 4e50dcf0f004f14a38c173f181cabb97fdc201786c338800b9750dc0cf6ce9b1397ea26b4357de1f6e1ac6b4e69abbe2bf464a5f9c2926f6ae45abbf5a69803b SHA512 fdb412ce591bca7aede2ac7d70600184f3b67279e8ffdfee3649f517d5531d2dfee54b37d0cc6de2ef5de8ecd281c39d6c951781b68f9a36316a7607cefb9e57
+DIST Ice-3.7.1.tar.gz 8765196 BLAKE2B ba97fcbd3ad09a45c5014b9ee6440991578f41f145c2fa37eca320733c9eb38c82a1288e1fd7fbb9327e1d600de23ca779b9cf797438c3742548590591944711 SHA512 dd438b8eb6cfcf7bba075975b2eb69946bcddb588d63921a0f30f2e79de82312d6ef30a7626d70580babf7dd64b0f2bc30c374a2c323433e1fbc82ccd65e966c
EBUILD Ice-3.6.3-r4.ebuild 9407 BLAKE2B 0f15afaa77cdb5a41a57babdf62bde7b981bfe7da219fd3d7273cdacbb9ab42d9729060960c0f6f334078f19089e7c27d7464bf2eca91c8216aa7b7880a2d254 SHA512 7f794f9f6d44e8afef704ec9f23ae534eb7010a3be4ffd2f79387b4a2a2354848e94c355a3ee15eea61d905f2e95191e27542e0790e9e20ba3cdbd6b844b6e66
EBUILD Ice-3.6.4.ebuild 9359 BLAKE2B 62f3d034c29e8730a1df1c61d587ff27856dd1ae8cbdb00db2688e8e51e978eaff40096b83e36cf0ad1a127eeafff906b44919cff1109b93cdefb2f09ec485d6 SHA512 332c4f130952630db33ee175998bc95522fe1de4cb17d2272e1e89094989b74640b2e495196e483d0a38bb9efc27fb15bd124367ad8f5e2aa0d24405505fcc98
+EBUILD Ice-3.7.1.ebuild 7474 BLAKE2B 39aa3b10385c7c8211e8fcd178688202f16f1a59d78f98e17a5ffbf4ba2e6221b6ec571097487b76bd37e103efe21a2d01417865350b08b3848d392a7b47b197 SHA512 b4af38bed045e4fb6384fff654f37e3d12c7d3c97bde7ba00f1590f135504d328ebda87c1e8d4ba24a3141a1a48b68db785c086ecc576df0ac8e40c6808124f4