summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorrandomdan <randomdan@localhost>2009-09-16 17:25:28 +0000
committerrandomdan <randomdan@localhost>2009-09-16 17:25:28 +0000
commitea749cd50246c2f1f30d6de10195f943f7d6886e (patch)
tree452ccb28ae63482b88975c7537b090db7d87dd44 /dev-db
parentAllow turning off media packages (diff)
downloadportage-ea749cd50246c2f1f30d6de10195f943f7d6886e.tar.bz2
portage-ea749cd50246c2f1f30d6de10195f943f7d6886e.tar.xz
portage-ea749cd50246c2f1f30d6de10195f943f7d6886e.zip
New postgresl and slony
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/slony1/Manifest2
-rw-r--r--dev-db/slony1/slony1-2.0.2.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-db/slony1/Manifest b/dev-db/slony1/Manifest
index 84d8044..f477e30 100644
--- a/dev-db/slony1/Manifest
+++ b/dev-db/slony1/Manifest
@@ -1,4 +1,6 @@
AUX slony1.conf 356 RMD160 698e0a48d8c3b5a4ee3f03e78cceb16e44a36756 SHA1 9592d7b6778d270a9d82458bb09e1becc624830c SHA256 f5d4ed7dc04b93492d5b008622a0984c073f03a759189675ecae3d419bc601a8
AUX slony1.init 721 RMD160 adc753b27b1669ad2125dc4f11cc43f3e08c00c5 SHA1 8961074c46c8f518e54988b2d7c6221723cc2fd6 SHA256 f2adccbcda30def2e848ab8a47d75ee2b79cf9f694ad9105a9220b804274a1a9
DIST slony1-1.2.15.tar.bz2 871479 RMD160 c99a862bda6aca8adf7f838a872fc66eac556732 SHA1 cc0f5e5d904070a2496a66fe9482c2fdbdda372c SHA256 a8330b409d834309ee9a3dbde85563f6ce4800941443b7490a34a459cbc1aca8
+DIST slony1-2.0.2.tar.bz2 933793 RMD160 a757aa8bb1fe6fdacd592ff5778858fba64b03e2 SHA1 7c23b02389be7b3236fa092114196a3cd69ad38a SHA256 937ff0aad51cb4c7ef57d92431654c2d35ab22e0ff0f038f0a38e9c8af3b723f
EBUILD slony1-1.2.15.ebuild 1237 RMD160 5c4f4f8bd281a3a542e42ea214d4a4e013815646 SHA1 a19b4a4e4081bf3287e42e875a04d918c27f3a77 SHA256 88c429ab0cceff381f5062773d4b10c6c9bdd9a7d471c6582612e6743ea67997
+EBUILD slony1-2.0.2.ebuild 1205 RMD160 f3c6c0c9d3448b8277d7bff5c291a90c4b2361d1 SHA1 d5bc2d42189e86abb026893c67ce4406de35cc55 SHA256 6b5afcd25b807703a6fab090074de360c7e85630cbeccbee8260a6c88a98d048
diff --git a/dev-db/slony1/slony1-2.0.2.ebuild b/dev-db/slony1/slony1-2.0.2.ebuild
new file mode 100644
index 0000000..e8721fb
--- /dev/null
+++ b/dev-db/slony1/slony1-2.0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvs/lportage/dev-db/slony1/slony1-2.0.2.ebuild,v 1.1 2009-09-16 17:24:50 randomdan Exp $
+
+inherit eutils
+
+IUSE="perl"
+
+DESCRIPTION="A replication system for the PostgreSQL Database Management System"
+HOMEPAGE="http://slony.info/"
+SRC_URI="http://main.slony.info/downloads/2.0/source/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="perl? ( dev-perl/DBD-Pg )"
+
+src_compile() {
+ local myconf=""
+
+ myconf="${myconf} --with-pgincludedir=/usr/include/postgresql/pgsql"
+ myconf="${myconf} --with-pgincludeserverdir=/usr/include/postgresql/server"
+ myconf="${myconf} $(use_with perl perltools)"
+
+ econf ${myconf} || die "econf failed!"
+ emake || die "emake failed!"
+
+ if use perl ; then
+ cd "${S}"/tools
+ emake || die "emake tools failed!"
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed!"
+
+ dodoc HISTORY-1.1 INSTALL README SAMPLE TODO UPGRADING doc/howto/*.txt
+ dohtml doc/howto/*.html
+
+ newinitd "${FILESDIR}"/slony1.init slony1 || die "newinitd failed!"
+ newconfd "${FILESDIR}"/slony1.conf slony1 || die "newconfd failed!"
+}