summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorrandomdan <randomdan@localhost>2011-05-17 03:04:08 +0000
committerrandomdan <randomdan@localhost>2011-05-17 03:04:08 +0000
commite6e6c585fff09537b87c74422efe2fd7a9772602 (patch)
tree2f36c03f0fcef9f7f1cc6b2b839d1d00e2ef5701 /dev-db
parent1.99_rc2 works with LVM mirrors (diff)
downloadportage-e6e6c585fff09537b87c74422efe2fd7a9772602.tar.bz2
portage-e6e6c585fff09537b87c74422efe2fd7a9772602.tar.xz
portage-e6e6c585fff09537b87c74422efe2fd7a9772602.zip
v1.14 beta
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pgadmin3/Manifest2
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.14.0_beta1.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-db/pgadmin3/Manifest b/dev-db/pgadmin3/Manifest
new file mode 100644
index 0000000..bb92413
--- /dev/null
+++ b/dev-db/pgadmin3/Manifest
@@ -0,0 +1,2 @@
+DIST pgadmin3-1.14.0-beta1.tar.gz 16813450 RMD160 64b0f7f21f57b7e3153f04f0f56d9c52dbf5c7d6 SHA1 156a3bf8d596cae75336f435b633b210dc9115b6 SHA256 a47f8244ce8021a368d6ad3eb34481dd04528c13453fbbc8ab013db278790558
+EBUILD pgadmin3-1.14.0_beta1.ebuild 1136 RMD160 b475f21fe9f993771f23f6a54f0cbb509557d0ee SHA1 97c32d79376bf4258b161d281249da47f7454352 SHA256 a9c30265104abbed8859560d120d3f9ef86e45fbee81afbc5dff9e20494469e3
diff --git a/dev-db/pgadmin3/pgadmin3-1.14.0_beta1.ebuild b/dev-db/pgadmin3/pgadmin3-1.14.0_beta1.ebuild
new file mode 100644
index 0000000..ad7e3ce
--- /dev/null
+++ b/dev-db/pgadmin3/pgadmin3-1.14.0_beta1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/pgadmin3-1.12.2.ebuild,v 1.5 2011/03/20 18:32:23 armin76 Exp $
+
+EAPI=3
+
+WX_GTK_VER="2.8"
+
+inherit wxwidgets
+
+DESCRIPTION="wxWidgets GUI for PostgreSQL."
+HOMEPAGE="http://www.pgadmin.org/"
+SRC_URI="mirror://postgresql/${PN}/release/v1.14.0-beta1/src/pgadmin3-1.14.0-beta1.tar.gz"
+
+LICENSE="Artistic"
+KEYWORDS="alpha amd64 ~ppc sparc x86 ~x86-fbsd"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="x11-libs/wxGTK:2.8[X]
+ dev-db/postgresql-base
+ >=dev-libs/libxml2-2.5
+ >=dev-libs/libxslt-1.1"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --with-wx-version=2.8 \
+ $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "einstall failed"
+
+ newicon "${S}/pgadmin/include/images/pgAdmin3.png" ${PN}.png || die
+
+ # icon location for the desktop file provided in pkg folder
+ insinto /usr/share/pgadmin3
+ doins "${S}/pgadmin/include/images/pgAdmin3.png" || die
+
+ domenu "${S}/pkg/pgadmin3.desktop" || die
+
+ # Fixing world-writable files
+ chmod -R go-w "${D}/usr/share" || die
+}