summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorrandomdan <randomdan@localhost>2010-06-06 16:03:19 +0000
committerrandomdan <randomdan@localhost>2010-06-06 16:03:19 +0000
commitd318ffb573ebc380ab12039c010ddf390ed48b28 (patch)
tree24e49ab15aa702322c8a0db73a4f5fa7c9b6d63d /dev-db
parentAdd v0.3 with basic file import support (diff)
downloadportage-d318ffb573ebc380ab12039c010ddf390ed48b28.tar.bz2
portage-d318ffb573ebc380ab12039c010ddf390ed48b28.tar.xz
portage-d318ffb573ebc380ab12039c010ddf390ed48b28.zip
Remove old stuff
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/slony1/Manifest4
-rw-r--r--dev-db/slony1/files/slony1.conf12
-rwxr-xr-xdev-db/slony1/files/slony1.init37
-rw-r--r--dev-db/slony1/slony1-2.0.3.ebuild43
4 files changed, 0 insertions, 96 deletions
diff --git a/dev-db/slony1/Manifest b/dev-db/slony1/Manifest
deleted file mode 100644
index 436d51e..0000000
--- a/dev-db/slony1/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX slony1.conf 356 RMD160 d0212736066cdcea5493d72bcbe15df0d0abe4d9 SHA1 4da1e7f7c4b644fcccb6531cc4e49522537ac67d SHA256 1d4016649e0a9520df3bca562036cbf5b7bab7f2c28fffdab0eef29621336402
-AUX slony1.init 721 RMD160 93f78e60d23a28c507a1c0358f218456e9851102 SHA1 02d95d73965732f7f04ac963d2be8a9705f45b29 SHA256 2fa54b31a29a7a3ca44bc80e78f662f3ca3bf7cd8e513b19e8d1ea445c0ef8cd
-DIST slony1-2.0.3.tar.bz2 1003446 RMD160 22313c6521befa2c06f9c259bc244eca6407e151 SHA1 ed07373f4fcf546acf65585bc01164ff8581e4f6 SHA256 0eb1deac15949b69f982ca5dd2f2cd2997505f598d733387f4ad450a609a44eb
-EBUILD slony1-2.0.3.ebuild 1205 RMD160 63ce3f5908c40289ced113301bf90d7c0bb42af1 SHA1 f6380786c8449fd5c20f6e88fbe01578298f5a20 SHA256 af02ddfd8224823e35a7cd34004c62c10fe23e503063624d825c30a421a492a0
diff --git a/dev-db/slony1/files/slony1.conf b/dev-db/slony1/files/slony1.conf
deleted file mode 100644
index acd4df1..0000000
--- a/dev-db/slony1/files/slony1.conf
+++ /dev/null
@@ -1,12 +0,0 @@
-# /etc/conf.d/slony1:
-# $Header: /var/cvs/lportage/dev-db/slony1/files/slony1.conf,v 1.1 2008-12-11 17:54:27 dan.goodliffe Exp $
-
-# Configuration file for /etc/init.d/slony1
-
-USER=postgres
-CLUSTER=your_cluster_name
-DBUSER=postgres
-DBNAME=your_database_name
-DBHOST=localhost
-LOGFILE=/var/lib/postgresql/data/slony1.log
-LOGLEVEL=1 # 1(minimum)..4(maximum)
diff --git a/dev-db/slony1/files/slony1.init b/dev-db/slony1/files/slony1.init
deleted file mode 100755
index 36f1ec3..0000000
--- a/dev-db/slony1/files/slony1.init
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvs/lportage/dev-db/slony1/files/slony1.init,v 1.1 2008-12-11 17:54:27 dan.goodliffe Exp $
-
-depend() {
- need postgresql
-}
-
-start() {
- ebegin "Starting slony1"
- /usr/bin/slon -p /var/run/slony1.pid -d $LOGLEVEL $CLUSTER "dbname=$DBNAME user=$DBUSER host=$DBHOST" >> $LOGFILE 2>&1 &
-
- while :
- do
- cnt=$(($cnt + 1))
- if [ -f "/var/run/slony1.pid" ]; then
- ret=0
- break
- fi
-
- if [ $cnt -eq 30 ]; then
- eerror "Please see log file: $LOGFILE"
- ret=1
- break
- fi
- sleep 1
- done
- eend $ret
-}
-
-stop() {
- ebegin "Stopping slony1"
- kill `cat /var/run/slony1.pid`
- eend $?
-}
-
diff --git a/dev-db/slony1/slony1-2.0.3.ebuild b/dev-db/slony1/slony1-2.0.3.ebuild
deleted file mode 100644
index e8721fb..0000000
--- a/dev-db/slony1/slony1-2.0.3.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvs/lportage/dev-db/slony1/slony1-2.0.2.ebuild,v 1.1 2009-09-16 17:24:50 randomdan Exp $
-
-inherit eutils
-
-IUSE="perl"
-
-DESCRIPTION="A replication system for the PostgreSQL Database Management System"
-HOMEPAGE="http://slony.info/"
-SRC_URI="http://main.slony.info/downloads/2.0/source/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-
-DEPEND="perl? ( dev-perl/DBD-Pg )"
-
-src_compile() {
- local myconf=""
-
- myconf="${myconf} --with-pgincludedir=/usr/include/postgresql/pgsql"
- myconf="${myconf} --with-pgincludeserverdir=/usr/include/postgresql/server"
- myconf="${myconf} $(use_with perl perltools)"
-
- econf ${myconf} || die "econf failed!"
- emake || die "emake failed!"
-
- if use perl ; then
- cd "${S}"/tools
- emake || die "emake tools failed!"
- fi
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed!"
-
- dodoc HISTORY-1.1 INSTALL README SAMPLE TODO UPGRADING doc/howto/*.txt
- dohtml doc/howto/*.html
-
- newinitd "${FILESDIR}"/slony1.init slony1 || die "newinitd failed!"
- newconfd "${FILESDIR}"/slony1.conf slony1 || die "newconfd failed!"
-}