summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorrandomdan <randomdan@localhost>2012-06-28 00:44:44 +0000
committerrandomdan <randomdan@localhost>2012-06-28 00:44:44 +0000
commit6ff0e47137f77a23903c4bff05172f1b4ae1108a (patch)
tree66ed92e5e0ec9a2f4b6a3e065d2ec495eff0290a /dev-db
parentNope (diff)
downloadportage-6ff0e47137f77a23903c4bff05172f1b4ae1108a.tar.bz2
portage-6ff0e47137f77a23903c4bff05172f1b4ae1108a.tar.xz
portage-6ff0e47137f77a23903c4bff05172f1b4ae1108a.zip
9.2 compatible beta
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pgadmin3/Manifest5
-rw-r--r--dev-db/pgadmin3/files/cflags.patch12
-rw-r--r--dev-db/pgadmin3/files/ssl-detect-r1.patch64
-rw-r--r--dev-db/pgadmin3/files/ssl-detect.patch43
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.16.0_beta2.ebuild58
5 files changed, 182 insertions, 0 deletions
diff --git a/dev-db/pgadmin3/Manifest b/dev-db/pgadmin3/Manifest
new file mode 100644
index 0000000..c29d7b6
--- /dev/null
+++ b/dev-db/pgadmin3/Manifest
@@ -0,0 +1,5 @@
+AUX cflags.patch 325 RMD160 1d3aafb87a35c6f2f24f9320bb540c128b038caf SHA1 e3f661cb86a3e6065bf2f6d73804d5ec9f122770 SHA256 8d98f5bf44ae705687438d5ff531d736479c62deaf913eb8878ffbcd3ec8fdab
+AUX ssl-detect-r1.patch 1953 RMD160 3ec01ca17976ae3bcf24feb9d7ef363e92c6e361 SHA1 e4bffba32927bb38f8dc0a4ca98f2364e314099e SHA256 87753c32869b428ca89a8142cc292894ab19417b068055cd8a88ad820cc1d1c6
+AUX ssl-detect.patch 1164 RMD160 98a74cedd8aae69f12e525e2bf3e934b59ad9608 SHA1 8317172ac696a63b22678e82738de5960889c89e SHA256 521ef777456e9597fd27f1abb85808b07dca359888197a3329356aa4e560aa5e
+DIST pgadmin3-1.16.0-beta2.tar.gz 13180228 RMD160 d4e40ad132793b72338a506897a8767b53834086 SHA1 1b63ecfa9a6fcd462f40d144d1ea6aaafd45fae1 SHA256 2a2f26320f489ff52589a240314852127b9e634d549a9f5bdbb2a4905e6f46b0
+EBUILD pgadmin3-1.16.0_beta2.ebuild 1443 RMD160 17d5ccb46bdcccc4305a7b7267c26acd236be6c9 SHA1 bf7535c6d656b4f0cc209e0a81d997310931daed SHA256 46ef006a58c03f1466eeefbca36a7856f2c8562db3aee83da95bf1978c713362
diff --git a/dev-db/pgadmin3/files/cflags.patch b/dev-db/pgadmin3/files/cflags.patch
new file mode 100644
index 0000000..fa5040f
--- /dev/null
+++ b/dev-db/pgadmin3/files/cflags.patch
@@ -0,0 +1,12 @@
+diff -Naur a/acinclude.m4 b/acinclude.m4
+--- a/acinclude.m4 2010-09-01 09:30:36.000000000 -0400
++++ b/acinclude.m4 2011-07-09 23:57:49.734641040 -0400
+@@ -805,8 +805,6 @@
+ AC_DEFUN([CLEANUP],
+ [
+ # CFLAGS/CXXFLAGS may well contain unwanted settings, so clear them.
+- CFLAGS=""
+- CXXFLAGS=""
+ ])
+
+ #########################
diff --git a/dev-db/pgadmin3/files/ssl-detect-r1.patch b/dev-db/pgadmin3/files/ssl-detect-r1.patch
new file mode 100644
index 0000000..a54b2ba
--- /dev/null
+++ b/dev-db/pgadmin3/files/ssl-detect-r1.patch
@@ -0,0 +1,64 @@
+--- pgadmin3-1.14.0-rc1.orig/acinclude.m4 2011-06-28 13:44:29.000000000 +0000
++++ pgadmin3-1.14.0-rc1/acinclude.m4 2011-09-05 21:10:03.222953210 +0000
+@@ -406,6 +406,13 @@
+ PGSQL_OLD_LDFLAGS="$LDFLAGS"
+ PGSQL_OLD_CPPFLAGS="$CPPFLAGS"
+
++ PG_INCLUDE=`${PG_CONFIG} --includedir`
++ PG_SVRINCLUDE=`${PG_CONFIG} --includedir-server`
++ PG_PKGINCLUDE=`${PG_CONFIG} --pkgincludedir`
++ CPPFLAGS="$CPPFLAGS -I${PG_INCLUDE} -I${PG_SVRINCLUDE} -I${PG_PKGINCLUDE}"
++
++ PG_VERSION=`${PG_CONFIG} --version`
++
+ AC_LANG_SAVE
+ AC_LANG_C
+ AC_CHECK_LIB(ssl, SSL_library_init, [LIB_SSL=yes], [LIB_SSL=no])
+@@ -477,33 +484,7 @@
+ if test "$LIB_SSL" = "yes"
+ then
+ # Check for SSL support
+- if test "$BUILD_STATIC" = "yes"
+- then
+- AC_MSG_CHECKING(for SSL_connect in libpq.a)
+- if test "$(nm ${PG_LIB}/libpq.a | grep -c SSL_connect)" -gt 0
+- then
+- AC_MSG_RESULT(present)
+- PG_SSL="yes"
+- else
+- AC_MSG_RESULT(not present)
+- PG_SSL="no"
+- fi
+- else
+- if test "$build_cpu-$build_vendor" = "powerpc-apple" -o "$build_cpu-$build_vendor" = "i386-apple" -o "$build_cpu-$build_vendor" = "i686-apple"
+- then
+- AC_MSG_CHECKING(for SSL_connect in -lpq)
+- if test "$(otool -L ${PG_LIB}/libpq.?.dylib | grep -c libssl)" -gt 0
+- then
+- AC_MSG_RESULT(present)
+- PG_SSL="yes"
+- else
+- AC_MSG_RESULT(not present)
+- PG_SSL="no"
+- fi
+- else
+- AC_CHECK_LIB(pq, SSL_connect, [PG_SSL=yes], [PG_SSL=no])
+- fi
+- fi
++ AC_CHECK_DECL([USE_SSL], [PG_SSL=yes], [PG_SSL=no], [[#include <pg_config.h>]])
+ else
+ PG_SSL="no"
+ fi
+@@ -547,12 +528,6 @@
+
+ AC_LANG_RESTORE
+
+- PG_INCLUDE=`${PG_CONFIG} --includedir`
+- PG_SVRINCLUDE=`${PG_CONFIG} --includedir-server`
+- PG_PKGINCLUDE=`${PG_CONFIG} --pkgincludedir`
+- CPPFLAGS="$CPPFLAGS -I${PG_INCLUDE} -I${PG_SVRINCLUDE} -I${PG_PKGINCLUDE}"
+-
+- PG_VERSION=`${PG_CONFIG} --version`
+
+ if test "$build_os" = "mingw32"
+ then
diff --git a/dev-db/pgadmin3/files/ssl-detect.patch b/dev-db/pgadmin3/files/ssl-detect.patch
new file mode 100644
index 0000000..38297d6
--- /dev/null
+++ b/dev-db/pgadmin3/files/ssl-detect.patch
@@ -0,0 +1,43 @@
+diff -Naur a/acinclude.m4 b/acinclude.m4
+--- a/acinclude.m4 2011-04-15 09:12:01.000000000 -0400
++++ b/acinclude.m4 2011-07-10 16:09:46.405593411 -0400
+@@ -476,19 +476,7 @@
+
+ if test "$LIB_SSL" = "yes"
+ then
+- # Check for SSL support
+- if test "$BUILD_STATIC" = "yes"
+- then
+- AC_MSG_CHECKING(for SSL_connect in libpq.a)
+- if test "$(nm ${PG_LIB}/libpq.a | grep -c SSL_connect)" -gt 0
+- then
+- AC_MSG_RESULT(present)
+- PG_SSL="yes"
+- else
+- AC_MSG_RESULT(not present)
+- PG_SSL="no"
+- fi
+- else
++ # Check for SSL support
+ if test "$build_cpu-$build_vendor" = "powerpc-apple" -o "$build_cpu-$build_vendor" = "i386-apple" -o "$build_cpu-$build_vendor" = "i686-apple"
+ then
+ AC_MSG_CHECKING(for SSL_connect in -lpq)
+@@ -501,9 +489,16 @@
+ PG_SSL="no"
+ fi
+ else
+- AC_CHECK_LIB(pq, SSL_connect, [PG_SSL=yes], [PG_SSL=no])
++ AC_MSG_CHECKING(for SSL_connect in libpq.a)
++ if test "$(nm ${PG_LIB}/libpq.a | grep -c SSL_connect)" -gt 0
++ then
++ AC_MSG_RESULT(present)
++ PG_SSL="yes"
++ else
++ AC_MSG_RESULT(not present)
++ PG_SSL="no"
++ fi
+ fi
+- fi
+ else
+ PG_SSL="no"
+ fi
diff --git a/dev-db/pgadmin3/pgadmin3-1.16.0_beta2.ebuild b/dev-db/pgadmin3/pgadmin3-1.16.0_beta2.ebuild
new file mode 100644
index 0000000..2f8bc52
--- /dev/null
+++ b/dev-db/pgadmin3/pgadmin3-1.16.0_beta2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/pgadmin3-1.14.3.ebuild,v 1.1 2012/06/07 15:40:51 titanofold Exp $
+
+EAPI="4"
+
+WX_GTK_VER="2.8"
+
+inherit multilib versionator wxwidgets
+
+DESCRIPTION="wxWidgets GUI for PostgreSQL."
+MY_PN="${PN}"
+MY_PV=$(replace_version_separator 3 '-')
+MY_P="${MY_PN}-${MY_PV}"
+S="${WORKDIR}/${MY_P}"
+HOMEPAGE="http://www.pgadmin.org/"
+SRC_URI="mirror://postgresql/${PN}/release/v${MY_PV}/src/${MY_P}.tar.gz"
+
+LICENSE="POSTGRESQL"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="x11-libs/wxGTK:2.8[X,debug=]
+ >=dev-db/postgresql-base-8.4.0
+ >=dev-libs/libxml2-2.6.18
+ >=dev-libs/libxslt-1.1"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ local pgslot=$(postgresql-config show)
+
+ if [[ ${pgslot//.} < 84 ]] ; then
+ eerror "PostgreSQL slot must be set to 8.4 or higher."
+ eerror " postgresql-config set 8.4"
+ die "PostgreSQL slot is not set to 8.4 or higher."
+ fi
+}
+
+src_configure() {
+ econf --with-wx-version=2.8 \
+ $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newicon "${S}/pgadmin/include/images/pgAdmin3.png" ${PN}.png
+
+ # icon location for the desktop file provided in pkg folder
+ insinto /usr/share/pgadmin3
+ doins "${S}/pgadmin/include/images/pgAdmin3.png"
+
+ domenu "${S}/pkg/pgadmin3.desktop"
+
+ # Fixing world-writable files
+ fperms -R go-w /usr/share
+}