summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorDan Goodliffe <dan@randomdan.homeip.net>2021-01-10 16:04:27 +0000
committerDan Goodliffe <dan@randomdan.homeip.net>2021-01-10 16:04:27 +0000
commit54657bb2f401cd28652c0f499d8351baa2adb5a3 (patch)
tree8b989281830c1f4a2e9da36e9994341e803656f4 /dev-db
parentSlicer bump (diff)
downloadportage-54657bb2f401cd28652c0f499d8351baa2adb5a3.tar.bz2
portage-54657bb2f401cd28652c0f499d8351baa2adb5a3.tar.xz
portage-54657bb2f401cd28652c0f499d8351baa2adb5a3.zip
Recent build of apgdiff (unreleased)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/apgdiff/Manifest3
-rw-r--r--dev-db/apgdiff/apgdiff-2.5.0_alpha20201105.ebuild53
-rw-r--r--dev-db/apgdiff/metadata.xml10
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-db/apgdiff/Manifest b/dev-db/apgdiff/Manifest
new file mode 100644
index 0000000..dfb3d73
--- /dev/null
+++ b/dev-db/apgdiff/Manifest
@@ -0,0 +1,3 @@
+DIST apgdiff-2.5.0_alpha20201105.zip 501650 BLAKE2B ba78017e8c938c635451b4a225c815b61e7dddc1aea7c10c7c6286da044b45bd894a9094f02e8ce40f681c392357189dc3997bae0fc17e5f666f901b48fb6a26 SHA512 f506ca0ec1f3cc0648f6f39a9a0e13faa9fa38ef5ebc4051f177fa67328032f6e70cad31134a50743a72fbcd1cc1532f13ed86bb26c06018efa54d860ec3a0f4
+EBUILD apgdiff-2.5.0_alpha20201105.ebuild 1197 BLAKE2B c5d1bc0a98e12ae5ba00cc992e573ef0a1b50d6bbd425d7478d3c0b38790065c7977a42d279f1beda97ef3336ac5393147c2a00333001c7ebd4ee4368cba37b9 SHA512 9aeb112842bb2e203046d560e6cbd0a7e05389419c362826f94afaa03807450763a7f61604b2caae35cc09cc39dc532de89e01df70331b91270da0cd46a9b128
+MISC metadata.xml 301 BLAKE2B f760bd727a4a0cc9572e5ff436dd66ef64d8f734e8605ce15599645a6ccfaef3b0d17348d916894171e99e6920ba60b0e4a13917f9445562473dbd5949ce6f55 SHA512 c38dc6bf13779d6e575526c42fc108080b160b9a7127aaea7f93b8a7ca46dbee5d349e95bfbc8a598c745ba0d2c8ce8ce6ea65a475854ad4d5a85e3620166552
diff --git a/dev-db/apgdiff/apgdiff-2.5.0_alpha20201105.ebuild b/dev-db/apgdiff/apgdiff-2.5.0_alpha20201105.ebuild
new file mode 100644
index 0000000..2cc9847
--- /dev/null
+++ b/dev-db/apgdiff/apgdiff-2.5.0_alpha20201105.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+JAVA_PKG_IUSE="doc source"
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="A simple PostgreSQL diff tool that is useful for schema upgrades"
+HOMEPAGE="https://apgdiff.com"
+USV="6c6defaa50aad109de8a85b37202591c0b98f784"
+SRC_URI="https://github.com/fordfrog/${PN}/archive/${USV}.zip -> ${P}.zip"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=">=virtual/jdk-1.6
+ >=dev-java/ant-core-1.7.0:0
+ >=dev-java/ant-junit-1.7.0:0
+ app-arch/zip:0
+ test? (
+ dev-java/hamcrest-core:0
+ >=dev-java/junit-4.4:4
+ )"
+
+RDEPEND=">=virtual/jre-1.6"
+S=${WORKDIR}/${PN}-${USV}
+
+java_prepare() {
+ mkdir "${S}"/lib
+ cd "${S}"/lib
+ if use test ; then
+ java-pkg_jar-from --build-only hamcrest-core
+ java-pkg_jar-from --build-only junit-4
+ fi
+}
+
+src_compile() {
+ eant -Dnoget=true jar $(use_doc)
+}
+
+src_install() {
+ java-pkg_newjar dist/${PN}-*.jar ${PN}.jar
+ java-pkg_dolauncher apgdiff --jar ${PN}.jar
+
+ use doc && java-pkg_dojavadoc dist/javadoc
+ use source && java-pkg_dosrc src/main/java/*
+}
+
+src_test() {
+ ANT_TASKS="ant-junit" eant -Dnoget=true test
+}
diff --git a/dev-db/apgdiff/metadata.xml b/dev-db/apgdiff/metadata.xml
new file mode 100644
index 0000000..1013bce
--- /dev/null
+++ b/dev-db/apgdiff/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">apgdiff</remote-id>
+ </upstream>
+</pkgmetadata>