summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorrandomdan <randomdan@localhost>2013-05-09 11:31:03 +0000
committerrandomdan <randomdan@localhost>2013-05-09 11:31:03 +0000
commit3aeda39dc84fc748a9aba2b3ec10a08c9e41ab8d (patch)
tree96af1734cc90d82dfa7ee123ad184ef9ca6c994a /dev-db
parentUpdate samba options (diff)
downloadportage-3aeda39dc84fc748a9aba2b3ec10a08c9e41ab8d.tar.bz2
portage-3aeda39dc84fc748a9aba2b3ec10a08c9e41ab8d.tar.xz
portage-3aeda39dc84fc748a9aba2b3ec10a08c9e41ab8d.zip
Adds MarkLogic, init script still required
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/marklogic/Manifest2
-rw-r--r--dev-db/marklogic/marklogic-5.0.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-db/marklogic/Manifest b/dev-db/marklogic/Manifest
new file mode 100644
index 0000000..8186a10
--- /dev/null
+++ b/dev-db/marklogic/Manifest
@@ -0,0 +1,2 @@
+DIST MarkLogic-5.0-5.x86_64.rpm 122927826 SHA256 2c8f5fe84a8c68f2c8b195082a0d2966314b5027932e169ae5c36f89a6dc2f78 SHA512 5bd95aed956482e80cb9390995bdf31c84886a9d29891368de826ca6fd98a76c61dd8ad7291e398c729be36a1707fb0b2c2dd0d536c1f2fe6a0cb1052722dd6a WHIRLPOOL d2ae8305e7902d0273ff1e25c8a5185d6ce6ce3d5a8650ebd8e7d2d9f6d185dfd3a9064da4f8cea0a3d08faf9e2f725009cda0c390e576b067e36fd484749075
+EBUILD marklogic-5.0.ebuild 619 SHA256 c413130c5da35511809744fdd0b98c646b6a2e5e834fca70a2a6f23452ca16b4 SHA512 abffedaaf10efed95bc693ed9288c0e45b8d0e8a02c9704ea497bca24fe45d01133a3d1ce9fc0a0627228642727160e21842c9974bd7d4483169838fb36cff6a WHIRLPOOL c2c6373f51466dd2386bf05ec0bacd512770942575fc4688b8a9e1a6c21339899de5eede79a7b125582981741e1e51636db6e57c9daa0c807266edb6f5e960f8
diff --git a/dev-db/marklogic/marklogic-5.0.ebuild b/dev-db/marklogic/marklogic-5.0.ebuild
new file mode 100644
index 0000000..222d3b1
--- /dev/null
+++ b/dev-db/marklogic/marklogic-5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+DESCRIPTION="MarkLogic"
+HOMEPAGE="http://www.marklogic.com/"
+SRC_URI="http://developer.marklogic.com/download/binaries/5.0/MarkLogic-5.0-5.x86_64.rpm"
+S="${WORKDIR}/MarkLogic-5.0-5.x86_64"
+
+LICENSE="marklogic"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="app-arch/rpm"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ cd ${WORKDIR}
+ rpmunpack ${DISTDIR}/MarkLogic-5.0-5.x86_64.rpm || die "Unpack failed"
+}
+
+src_install() {
+ mkdir -p ${D}/var/opt/MarkLogic
+ cp -a ${S}/opt ${D} || die "Install failed"
+}