summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authordangood <dangood@localhost>2005-04-07 10:57:08 +0000
committerdangood <dangood@localhost>2005-04-07 10:57:08 +0000
commit1240585cabc84c8c266c502f56518c60b1deaad7 (patch)
treee82e1ebc647f5d38bd58cbb4c47f5ab568c508f5 /dev-db
downloadportage-1240585cabc84c8c266c502f56518c60b1deaad7.tar.bz2
portage-1240585cabc84c8c266c502f56518c60b1deaad7.tar.xz
portage-1240585cabc84c8c266c502f56518c60b1deaad7.zip
Imported packages
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/oracle_odbc_driver/Manifest3
-rw-r--r--dev-db/oracle_odbc_driver/files/digest-oracle_odbc_driver-0.5.41
-rw-r--r--dev-db/oracle_odbc_driver/oracle_odbc_driver-0.5.4.ebuild27
3 files changed, 31 insertions, 0 deletions
diff --git a/dev-db/oracle_odbc_driver/Manifest b/dev-db/oracle_odbc_driver/Manifest
new file mode 100644
index 0000000..7393099
--- /dev/null
+++ b/dev-db/oracle_odbc_driver/Manifest
@@ -0,0 +1,3 @@
+MD5 240e2b37fde3e42ad2a4f76a3ec01091 .oracle-odbc-0.5.4.ebuild.swp 12288
+MD5 236afe04847310edd996a5307db886e7 oracle_odbc_driver-0.5.4.ebuild 440
+MD5 aa9beded315bfaa0a241e3a9ee9f3a80 files/digest-oracle_odbc_driver-0.5.4 76
diff --git a/dev-db/oracle_odbc_driver/files/digest-oracle_odbc_driver-0.5.4 b/dev-db/oracle_odbc_driver/files/digest-oracle_odbc_driver-0.5.4
new file mode 100644
index 0000000..046154d
--- /dev/null
+++ b/dev-db/oracle_odbc_driver/files/digest-oracle_odbc_driver-0.5.4
@@ -0,0 +1 @@
+MD5 a0fa2eb4ba6fbf5b2b370cb07e8fe5b9 oracle_odbc_driver.0.5.4.tar.gz 339627
diff --git a/dev-db/oracle_odbc_driver/oracle_odbc_driver-0.5.4.ebuild b/dev-db/oracle_odbc_driver/oracle_odbc_driver-0.5.4.ebuild
new file mode 100644
index 0000000..c05aae9
--- /dev/null
+++ b/dev-db/oracle_odbc_driver/oracle_odbc_driver-0.5.4.ebuild
@@ -0,0 +1,27 @@
+inherit eutils
+
+DESCRIPTION="ODBC driver for Oracle"
+SRC_URI="http://fndapl.fnal.gov/~dbox/oracle/odbc/${PN}.0.5.4.tar.gz"
+HOMEPAGE="http://fndapl.fnal.gov/~dbox/oracle/odbc/"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+DEPEND="dev-db/oracle-instantclient-basic dev-db/unixODBC"
+#RDEPEND=""
+
+src_compile() {
+ unset ARCH
+ cd ${WORKDIR}/${PN}
+ mv configure configure.old
+ # Fix Oracle include path in configure for 10g install
+ sed -e "s/\\/oci\\/include/\\/include/g" < configure.old > configure
+ chmod +x configure
+ econf || die
+ emake || die
+}
+
+src_install() {
+ cd ${WORKDIR}/${PN}
+ einstall || die
+}
+