summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorrandomdan <randomdan@localhost>2005-12-20 16:54:00 +0000
committerrandomdan <randomdan@localhost>2005-12-20 16:54:00 +0000
commit11b36db3f962168c0adc991b551f81c2453aeb61 (patch)
treee39cf314e9ec67e778e7d5a561eaa15b9ff98b3b /dev-db
parentMakes work with different versions of the Oracle client (diff)
downloadportage-11b36db3f962168c0adc991b551f81c2453aeb61.tar.bz2
portage-11b36db3f962168c0adc991b551f81c2453aeb61.tar.xz
portage-11b36db3f962168c0adc991b551f81c2453aeb61.zip
Update to the ODBC Oracle driver
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/oracle_odbc_driver/Manifest2
-rw-r--r--dev-db/oracle_odbc_driver/files/digest-oracle_odbc_driver-0.5.51
-rw-r--r--dev-db/oracle_odbc_driver/oracle_odbc_driver-0.5.5.ebuild27
3 files changed, 30 insertions, 0 deletions
diff --git a/dev-db/oracle_odbc_driver/Manifest b/dev-db/oracle_odbc_driver/Manifest
index d4b1743..5a1e23a 100644
--- a/dev-db/oracle_odbc_driver/Manifest
+++ b/dev-db/oracle_odbc_driver/Manifest
@@ -1,2 +1,4 @@
+MD5 0f14065ed977a985b5232a891c6d653d oracle_odbc_driver-0.5.5.ebuild 587
MD5 caab41c1b9f74e88c1e73abf05943422 oracle_odbc_driver-0.5.4.ebuild 591
MD5 aa9beded315bfaa0a241e3a9ee9f3a80 files/digest-oracle_odbc_driver-0.5.4 76
+MD5 a0f1f36dc2cc7bbca3baa09f7f95950b files/digest-oracle_odbc_driver-0.5.5 76
diff --git a/dev-db/oracle_odbc_driver/files/digest-oracle_odbc_driver-0.5.5 b/dev-db/oracle_odbc_driver/files/digest-oracle_odbc_driver-0.5.5
new file mode 100644
index 0000000..94f7b67
--- /dev/null
+++ b/dev-db/oracle_odbc_driver/files/digest-oracle_odbc_driver-0.5.5
@@ -0,0 +1 @@
+MD5 77a576b947437e915491ecd30f036c85 oracle_odbc_driver.0.5.5.tar.gz 483118
diff --git a/dev-db/oracle_odbc_driver/oracle_odbc_driver-0.5.5.ebuild b/dev-db/oracle_odbc_driver/oracle_odbc_driver-0.5.5.ebuild
new file mode 100644
index 0000000..bea1948
--- /dev/null
+++ b/dev-db/oracle_odbc_driver/oracle_odbc_driver-0.5.5.ebuild
@@ -0,0 +1,27 @@
+inherit eutils
+
+DESCRIPTION="ODBC driver for Oracle"
+SRC_URI="http://home.fnal.gov/~dbox/oracle/odbc/${PN}.0.5.5.tar.gz"
+HOMEPAGE="http://home.fnal.gov/~dbox/oracle/odbc/"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+DEPEND="dev-db/oracle-instantclient-basic dev-db/unixODBC"
+#RDEPEND=""
+
+src_compile() {
+ unset ARCH
+ cd ${WORKDIR}/${PN}
+ mv configure configure.old
+ # Fix Oracle include path in configure for 10g install
+ sed -e "s/\\/oci\\/include/\\/include/g" < configure.old > configure
+ chmod +x configure
+ econf || die
+ emake || die
+}
+
+src_install() {
+ cd ${WORKDIR}/${PN}
+ einstall || die
+}
+