summaryrefslogtreecommitdiff
path: root/dev-db/postgresql-fdw-tds
diff options
context:
space:
mode:
authorDan Goodliffe <daniel.goodliffe@pressassociation.com>2016-04-06 18:24:12 +0100
committerDan Goodliffe <daniel.goodliffe@pressassociation.com>2016-04-06 18:24:12 +0100
commit342042f0df3b66e9a147ba9439bdaa3d8612c285 (patch)
treebb6962157705e144a1c16185f421db878fe10131 /dev-db/postgresql-fdw-tds
parentRename to support multiple fix sets (diff)
downloadportage-342042f0df3b66e9a147ba9439bdaa3d8612c285.tar.bz2
portage-342042f0df3b66e9a147ba9439bdaa3d8612c285.tar.xz
portage-342042f0df3b66e9a147ba9439bdaa3d8612c285.zip
Add packages for PostgreSQL foreign data wrappers for MySQL and TDS
Diffstat (limited to 'dev-db/postgresql-fdw-tds')
-rw-r--r--dev-db/postgresql-fdw-tds/Manifest2
-rw-r--r--dev-db/postgresql-fdw-tds/postgresql-fdw-tds-1.0.7.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-db/postgresql-fdw-tds/Manifest b/dev-db/postgresql-fdw-tds/Manifest
new file mode 100644
index 0000000..541002f
--- /dev/null
+++ b/dev-db/postgresql-fdw-tds/Manifest
@@ -0,0 +1,2 @@
+DIST v1.0.7.tar.gz 22290 SHA256 952e7a32e79ba41772fe6ec4e82d95af0dd7317a7a558caf598d8dcd26031174 SHA512 55ec6cb5028055851170e9409b268ae2b23bddd38d0e4227b034b086384bfc4621f88219c6f9482203785600993bcfb4b132e1e3dca1e6a2222cb79ed65da4be WHIRLPOOL 8e6bd3ad244bee70ef476c70c76cafb20a538315582bee85d5c982ac6f1036edb87a4795c6f55aaf31d3502bff2d830da253aac0bfb13abb168654cb186cf000
+EBUILD postgresql-fdw-tds-1.0.7.ebuild 554 SHA256 c86a23150656b9fc8a4860f755846fab13f155e583d3e46b829f4a03efb79267 SHA512 5f30554dece3f6cc1d2ce3af685e515530cbbdd732a7d27469b9f024283c3bbb5eda965bffc505a0585c5aaa6a71a1c838f76ed9d755ea17c55564ba8a9955d8 WHIRLPOOL 72e5b191ad108e8535c28279165418b42fff53160701f15383ce278d88c115708ba630c2cf5507721926a1b3afbc93487ecdb20ef035054415c563657bf914d8
diff --git a/dev-db/postgresql-fdw-tds/postgresql-fdw-tds-1.0.7.ebuild b/dev-db/postgresql-fdw-tds/postgresql-fdw-tds-1.0.7.ebuild
new file mode 100644
index 0000000..435d032
--- /dev/null
+++ b/dev-db/postgresql-fdw-tds/postgresql-fdw-tds-1.0.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="PostgreSQL foreign data wrapper for TDS"
+HOMEPAGE="https://github.com/GeoffMontee/tds_fdw"
+SRC_URI="https://github.com/GeoffMontee/tds_fdw/archive/v${PV}.tar.gz"
+
+LICENSE="mysql_fdw"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S="${WORKDIR}/tds_fdw-${PV}"
+
+DEPEND="
+ dev-db/freetds
+ >=dev-db/postgresql-9.1
+ "
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ make USE_PGXS=1
+}
+
+src_install() {
+ make USE_PGXS=1 install DESTDIR="${D}"
+}
+