summaryrefslogtreecommitdiff
path: root/dev-db/postgresql-fdw-mysql
diff options
context:
space:
mode:
authorDan Goodliffe <dan.goodliffe@octal.co.uk>2019-01-15 11:17:29 +0000
committerDan Goodliffe <dan.goodliffe@octal.co.uk>2019-01-15 11:17:29 +0000
commitd5e91554d58112aa18f84c5865f86869a183df74 (patch)
tree44cad426fc94468241438ed316632b595d4822a6 /dev-db/postgresql-fdw-mysql
parentYCM works fine with boost-1.65 (diff)
downloadportage-d5e91554d58112aa18f84c5865f86869a183df74.tar.bz2
portage-d5e91554d58112aa18f84c5865f86869a183df74.tar.xz
portage-d5e91554d58112aa18f84c5865f86869a183df74.zip
Bump postgresql-fdw-mysql
Diffstat (limited to 'dev-db/postgresql-fdw-mysql')
-rw-r--r--dev-db/postgresql-fdw-mysql/Manifest2
-rw-r--r--dev-db/postgresql-fdw-mysql/postgresql-fdw-mysql-2.5.1.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-db/postgresql-fdw-mysql/Manifest b/dev-db/postgresql-fdw-mysql/Manifest
index 1e08f8f..15490a9 100644
--- a/dev-db/postgresql-fdw-mysql/Manifest
+++ b/dev-db/postgresql-fdw-mysql/Manifest
@@ -1,2 +1,4 @@
DIST REL-2_2_0.tar.gz 39615 BLAKE2B 5504776a45b75316261d3aace15b6695d20d8799b49cacbbe19ffd626327ca4ce0e577d166e304c25fad2f7fd3dfb2c47231ed058fc7fce79670974c8cb8f1fe SHA512 d8d9b646b2f411148956250fc3f4d3fa1ca7d634aa84c87df1f796136c877c4918f14bfb64776bab846a4705fb0b8d8c3df0e98db78270eee8cf71f6d96ee432
+DIST REL-2_5_1.tar.gz 42615 BLAKE2B 54e7162a2740ee15bf060e443317d23954b9ed7809c782dc8953982fcbad815aa08876340e4c5085cbecab551116bd297b2894575f6d81633f1cae60b5d26d0d SHA512 a3b10f165b15ca4bfdefabb4f4d173b7fc94012278fb718737e18d6d7a5bcc1be6fb9e0f97626e0ab444e33f3b2426b35f7b9986c625c09977535d8e5fcb6951
EBUILD postgresql-fdw-mysql-2.2.0.ebuild 588 BLAKE2B 064b8a52c6146ce3ae5517289142ce94a8d839c3b6bdcbd60ca443e95c320ee6d2957488f47e633b5834749ee5dbdae79d43d96d02462119d7af2ff2f6406259 SHA512 e0316048b05d961fe7112868dd68890c4fcb769a2c8d75e66afcb3fec80699668a534beae073f2a6ab4d6c8fb2d123d1e99952e1004c3dfca7da1544649d52e1
+EBUILD postgresql-fdw-mysql-2.5.1.ebuild 588 BLAKE2B 064b8a52c6146ce3ae5517289142ce94a8d839c3b6bdcbd60ca443e95c320ee6d2957488f47e633b5834749ee5dbdae79d43d96d02462119d7af2ff2f6406259 SHA512 e0316048b05d961fe7112868dd68890c4fcb769a2c8d75e66afcb3fec80699668a534beae073f2a6ab4d6c8fb2d123d1e99952e1004c3dfca7da1544649d52e1
diff --git a/dev-db/postgresql-fdw-mysql/postgresql-fdw-mysql-2.5.1.ebuild b/dev-db/postgresql-fdw-mysql/postgresql-fdw-mysql-2.5.1.ebuild
new file mode 100644
index 0000000..b2b81ca
--- /dev/null
+++ b/dev-db/postgresql-fdw-mysql/postgresql-fdw-mysql-2.5.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="PostgreSQL foreign data wrapper for MySQL"
+HOMEPAGE="https://github.com/EnterpriseDB/mysql_fdw"
+SRC_URI="https://github.com/EnterpriseDB/mysql_fdw/archive/REL-${PV//./_}.tar.gz"
+
+LICENSE="mysql_fdw"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE=""
+
+S="${WORKDIR}/mysql_fdw-REL-${PV//./_}"
+
+DEPEND="
+ virtual/libmysqlclient
+ >=dev-db/postgresql-9.4
+ "
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ make USE_PGXS=1
+}
+
+src_install() {
+ make USE_PGXS=1 install DESTDIR="${D}"
+}
+