summaryrefslogtreecommitdiff
path: root/dev-db/postgresql-fdw-mysql
diff options
context:
space:
mode:
authorDan Goodliffe <daniel.goodliffe@pressassociation.com>2016-04-06 18:24:12 +0100
committerDan Goodliffe <daniel.goodliffe@pressassociation.com>2016-04-06 18:24:12 +0100
commit342042f0df3b66e9a147ba9439bdaa3d8612c285 (patch)
treebb6962157705e144a1c16185f421db878fe10131 /dev-db/postgresql-fdw-mysql
parentRename to support multiple fix sets (diff)
downloadportage-342042f0df3b66e9a147ba9439bdaa3d8612c285.tar.bz2
portage-342042f0df3b66e9a147ba9439bdaa3d8612c285.tar.xz
portage-342042f0df3b66e9a147ba9439bdaa3d8612c285.zip
Add packages for PostgreSQL foreign data wrappers for MySQL and TDS
Diffstat (limited to 'dev-db/postgresql-fdw-mysql')
-rw-r--r--dev-db/postgresql-fdw-mysql/Manifest2
-rw-r--r--dev-db/postgresql-fdw-mysql/postgresql-fdw-mysql-2.1.2.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-db/postgresql-fdw-mysql/Manifest b/dev-db/postgresql-fdw-mysql/Manifest
new file mode 100644
index 0000000..bdae315
--- /dev/null
+++ b/dev-db/postgresql-fdw-mysql/Manifest
@@ -0,0 +1,2 @@
+DIST REL-2_1_2.tar.gz 38656 SHA256 5a9cd36d29d54d1325e26ca2c9a4cfb1265e4638ec8bb81aaaf1feba8d271186 SHA512 c22500f81b9ff19679bfd5b6dedb1deef263107c472101ef5eccc405b0a6244ca266974ce13fd4296733453a42a7c5800f22ab8202f3c93fb6a731b52c2ff76c WHIRLPOOL ff770dd826525b5d254692dba41f6d41c6c54dea02e8db1eebda1fd667438a6e93eee123acfccd3d002310b2890d16d85d41bb85dcb737316c3f78dd862a31a8
+EBUILD postgresql-fdw-mysql-2.1.2.ebuild 586 SHA256 6d523c2d523d0055b1bd4d623732fa0fe445bac59412ba65ade896e1c32753f8 SHA512 f054585e951ab5162f22b1725084f77dcdba6f5f77e30edf2684c59ad7eac260d0a4c23f232baf3ccd4380a8f01735879c9b2b85b85533da0f5e6f033e219eab WHIRLPOOL 1ed0802053faf5cb8f35833b7ab6182b159784637df699c151e8af161f52e143adbd24b57335c6239c74bba942bb3efa57e034dbe816b7550f83eb1f932b8d06
diff --git a/dev-db/postgresql-fdw-mysql/postgresql-fdw-mysql-2.1.2.ebuild b/dev-db/postgresql-fdw-mysql/postgresql-fdw-mysql-2.1.2.ebuild
new file mode 100644
index 0000000..7f90e14
--- /dev/null
+++ b/dev-db/postgresql-fdw-mysql/postgresql-fdw-mysql-2.1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="PostgreSQL foreign data wrapper for MySQL"
+HOMEPAGE="https://github.com/EnterpriseDB/mysql_fdw"
+SRC_URI="https://github.com/EnterpriseDB/mysql_fdw/archive/REL-${PV//./_}.tar.gz"
+
+LICENSE="mysql_fdw"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S="${WORKDIR}/mysql_fdw-REL-${PV//./_}"
+
+DEPEND="
+ >=virtual/mysql-5.2
+ >=dev-db/postgresql-9.4
+ "
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ make USE_PGXS=1
+}
+
+src_install() {
+ make USE_PGXS=1 install DESTDIR="${D}"
+}
+