summaryrefslogtreecommitdiff
path: root/app-shells/powerline-gitstatus
diff options
context:
space:
mode:
authorDan Goodliffe <dan@randomdan.homeip.net>2025-04-27 15:53:02 +0100
committerDan Goodliffe <dan@randomdan.homeip.net>2025-04-27 15:53:02 +0100
commit69ac915cf25fabf86f6e49f3be2d52ac96e0bedd (patch)
tree5e61df267609732348ce04b1b0a6b28f5516cd87 /app-shells/powerline-gitstatus
parentEnable glusterfs (diff)
downloadportage-69ac915cf25fabf86f6e49f3be2d52ac96e0bedd.tar.bz2
portage-69ac915cf25fabf86f6e49f3be2d52ac96e0bedd.tar.xz
portage-69ac915cf25fabf86f6e49f3be2d52ac96e0bedd.zip
Add DISTUTILS_USE_PEP517=setuptools as required
Diffstat (limited to 'app-shells/powerline-gitstatus')
-rw-r--r--app-shells/powerline-gitstatus/Manifest1
-rw-r--r--app-shells/powerline-gitstatus/powerline-gitstatus-1.3.2-r1.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/app-shells/powerline-gitstatus/Manifest b/app-shells/powerline-gitstatus/Manifest
index 9f9dde6..029b747 100644
--- a/app-shells/powerline-gitstatus/Manifest
+++ b/app-shells/powerline-gitstatus/Manifest
@@ -1,2 +1,3 @@
DIST powerline-gitstatus-1.3.2.tar.gz 18907 BLAKE2B 15cacbab8a5c6f40fd588f37814c5e7dd97a1685abd54ac38ffa69dd76c1016313ab200493b27be7439c696aa5fa32c21984e99bcc037019c65cced9cea567ed SHA512 5e2f916c3c1493c1b350d5578984ed10210d28b486b46cc481dd480663524dead852a6b298f3e7291f2378264bd0ce57904457a1a97ec14a65b1664f692edaf1
+EBUILD powerline-gitstatus-1.3.2-r1.ebuild 591 BLAKE2B 722fc3bac749d24bda20d4ae847a846e6693da73a4e0954fa6aa58ee0ac7c84b9e45693b53e753325bcc11ca48c0c37914741b63e632403abd8c7d25075cdcc7 SHA512 8212f4896e1d1661f7e7884cfd4d4a73f9dc808d4205557972ccd47788df48d6376b4c78f5c197d32d15da6f29b5948e2a27d4bc59c8d47116d1af86bbea152b
EBUILD powerline-gitstatus-1.3.2.ebuild 559 BLAKE2B 0e2a2cf501a22aecfaefb217a9c7fdddf86d7f73225374b1e5e1ab62c85c9e44be0364b6982ec14ba013a235006b8aa27f5789df000f916627a982e16fe3dffd SHA512 19eff89f3fc03d20a65c9bafaaeaa37e139bdff570247032301bd30fdd80071da009ffb8ab9f9cd99ad85534d0232514a76d44b0d42e859f66a183cfcfc5cc78
diff --git a/app-shells/powerline-gitstatus/powerline-gitstatus-1.3.2-r1.ebuild b/app-shells/powerline-gitstatus/powerline-gitstatus-1.3.2-r1.ebuild
new file mode 100644
index 0000000..087fa39
--- /dev/null
+++ b/app-shells/powerline-gitstatus/powerline-gitstatus-1.3.2-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN="powerline-gitstatus"
+inherit distutils-r1
+
+DESCRIPTION="A Powerline segment for showing the status of a Git working copy."
+HOMEPAGE="https://github.com/jaspernbrouwer/powerline-gitstatus"
+SRC_URI="https://github.com/jaspernbrouwer/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="app-shells/powerline"
+RDEPEND="${DEPEND}"
+BDEPEND=""