summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorrandomdan <randomdan@localhost>2008-03-12 10:03:43 +0000
committerrandomdan <randomdan@localhost>2008-03-12 10:03:43 +0000
commiteb0d1bf685566fe3fb66c6fdcd5dc9b3bb1bd55c (patch)
tree92e918dff7bc79d47f34df9aee8309160a4a8475
parentOptional vnc instead of tightvnc (diff)
downloadportage-eb0d1bf685566fe3fb66c6fdcd5dc9b3bb1bd55c.tar.bz2
portage-eb0d1bf685566fe3fb66c6fdcd5dc9b3bb1bd55c.tar.xz
portage-eb0d1bf685566fe3fb66c6fdcd5dc9b3bb1bd55c.zip
Dan's prerelease version of pgadmin3
-rw-r--r--dev-db/pgadmin3/Manifest8
-rw-r--r--dev-db/pgadmin3/files/digest-pgadmin3-1.8.03
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.8.0.ebuild65
3 files changed, 76 insertions, 0 deletions
diff --git a/dev-db/pgadmin3/Manifest b/dev-db/pgadmin3/Manifest
new file mode 100644
index 0000000..a6d8bd8
--- /dev/null
+++ b/dev-db/pgadmin3/Manifest
@@ -0,0 +1,8 @@
+DIST pgadmin3-1.8.0.tar.gz 7913989 RMD160 aef947be994789e600da1cf2f7ca9ac3eea6bd5b SHA1 5513c5b2ab42ff8771f0e00e0298db609409cda8 SHA256 1e707f942de4fd01bcac7c0fd0407a10d6cba25b82762552e96cea5864fae617
+EBUILD pgadmin3-1.8.0.ebuild 1550 RMD160 36cfc1a625a60a94127528f798dbef9a62b6cf61 SHA1 ecd47d13db73130f5e275a999ed364d6c2e0784f SHA256 01f315252a41b927daad76cf1ffc51991ee6a2af2b9ca427a9dd20c0af8ebc10
+MD5 6a0e55c621d9c5ef6ab878b19d10aabf pgadmin3-1.8.0.ebuild 1550
+RMD160 36cfc1a625a60a94127528f798dbef9a62b6cf61 pgadmin3-1.8.0.ebuild 1550
+SHA256 01f315252a41b927daad76cf1ffc51991ee6a2af2b9ca427a9dd20c0af8ebc10 pgadmin3-1.8.0.ebuild 1550
+MD5 eacb15c8358229a7ba7618811e28cb4a files/digest-pgadmin3-1.8.0 247
+RMD160 589d5aead0c1f4dfceb2b70a7be61e0392186482 files/digest-pgadmin3-1.8.0 247
+SHA256 4b6ac9761da9275d00bb6e84f700c4c93c9c7cd4a778ae49e5f26403ba2c330f files/digest-pgadmin3-1.8.0 247
diff --git a/dev-db/pgadmin3/files/digest-pgadmin3-1.8.0 b/dev-db/pgadmin3/files/digest-pgadmin3-1.8.0
new file mode 100644
index 0000000..4ba9164
--- /dev/null
+++ b/dev-db/pgadmin3/files/digest-pgadmin3-1.8.0
@@ -0,0 +1,3 @@
+MD5 fdcf7b211971790db4f5f5c5081a63f8 pgadmin3-1.8.0.tar.gz 7913989
+RMD160 aef947be994789e600da1cf2f7ca9ac3eea6bd5b pgadmin3-1.8.0.tar.gz 7913989
+SHA256 1e707f942de4fd01bcac7c0fd0407a10d6cba25b82762552e96cea5864fae617 pgadmin3-1.8.0.tar.gz 7913989
diff --git a/dev-db/pgadmin3/pgadmin3-1.8.0.ebuild b/dev-db/pgadmin3/pgadmin3-1.8.0.ebuild
new file mode 100644
index 0000000..db4db9e
--- /dev/null
+++ b/dev-db/pgadmin3/pgadmin3-1.8.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvs/lportage/dev-db/pgadmin3/pgadmin3-1.8.0.ebuild,v 1.1 2008-03-12 10:03:43 randomdan Exp $
+
+inherit wxwidgets eutils autotools
+
+KEYWORDS="alpha amd64 ppc sparc x86"
+
+DESCRIPTION="wxWidgets GUI for PostgreSQL."
+HOMEPAGE="http://www.pgadmin.org/"
+SRC_URI="mirror://postgresql/pgadmin3/release/v${PV}/src/${P}.tar.gz"
+LICENSE="Artistic"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="=x11-libs/wxGTK-2.8*
+ >=dev-db/libpq-7.4
+ >=dev-libs/libxml2-2.5
+ >=dev-libs/libxslt-1.1"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ export WX_GTK_VER=2.8
+ export WX_HOME=/usr
+ need-wxwidgets unicode
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # --debug=yes/no for wx_config is only needed if wxGTK debug and
+ # release versions are installed aside. Which is not possible
+ # on Gentoo at the moment.
+ sed -i \
+ -e 's/--debug=[yesno]* //g' \
+ acinclude.m4 || die "sed failed"
+ eautoreconf
+}
+
+src_compile() {
+ cd "${S}"
+
+ # pgadmin3 inserts WX_HOME before the WX_CONFIG path below, so we have to strip "/usr" from it
+ econf \
+ --with-wx-config=${WX_CONFIG/\/usr} \
+ $(use_enable debug) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ cd "${S}"
+
+ einstall || die "einstall failed"
+
+ insinto /usr/share/pixmaps
+ newins "${S}/src/include/images/elephant48.xpm" pgadmin3.xpm
+
+ insinto /usr/share/pgadmin3
+ newins "${S}/src/include/images/elephant48.xpm" pgadmin3.xpm
+
+ insinto /usr/share/applications
+ doins "${S}/pkg/pgadmin3.desktop"
+}