summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Goodliffe <dan@randomdan.homeip.net>2020-06-13 17:13:16 +0100
committerDan Goodliffe <dan@randomdan.homeip.net>2020-08-22 12:46:15 +0100
commitd0baafbd8ece9811b79acf2853cc61035866933c (patch)
treee4bb732d86ac36bd55b37124fd34f36d6d0eb740
parentaccess_compat for bugzilla (diff)
downloadportage-d0baafbd8ece9811b79acf2853cc61035866933c.tar.bz2
portage-d0baafbd8ece9811b79acf2853cc61035866933c.tar.xz
portage-d0baafbd8ece9811b79acf2853cc61035866933c.zip
Initial commit of pg_chameleon
-rw-r--r--dev-db/pg_chameleon/Manifest2
-rw-r--r--dev-db/pg_chameleon/pg_chameleon-2.0.12.ebuild28
-rw-r--r--dev-python/daemonize/Manifest2
-rw-r--r--dev-python/daemonize/daemonize-2.5.0.ebuild18
-rw-r--r--dev-python/mysql-replication/Manifest2
-rw-r--r--dev-python/mysql-replication/mysql-replication-0.21.ebuild17
-rw-r--r--dev-python/rollbar/Manifest2
-rw-r--r--dev-python/rollbar/rollbar-0.15.0.ebuild17
8 files changed, 88 insertions, 0 deletions
diff --git a/dev-db/pg_chameleon/Manifest b/dev-db/pg_chameleon/Manifest
new file mode 100644
index 0000000..bb22d93
--- /dev/null
+++ b/dev-db/pg_chameleon/Manifest
@@ -0,0 +1,2 @@
+DIST pg_chameleon-2.0.12.tar.gz 65306 BLAKE2B a20dc113d01e0c659678664161a11781f2eb488fcb7a5dae27760d39668d2bd1d7c4be8786cf402fcab74f5ca7159e71b485aafa84ea6261f7c6d5b64832821b SHA512 8714f0da07ad348f9380d8c53ce25eedb3293fdcc81a4c1fb1709dcf9b5462a17c9f6a8bb1fd1a03312c5d3d5ecc49c85209d7a9b3367ef2c3b162b196e3b377
+EBUILD pg_chameleon-2.0.12.ebuild 736 BLAKE2B cd0d2f3c96ce0e7146641a3f7f8a06a5e4a32d5b0dd71a663f51f928a051f21006b5e082ba7d5a9c92a437598ea77b6c383420a84ecf7fd64d82730f91cdb765 SHA512 aafb95915f23b22dbbbd8ceda2824130cf237c09fde7d441b9af8af19b78d5dad05b1b4853e9201622ee555e284ae03ce3649e66cc1e26d3aa7e0986d05f0193
diff --git a/dev-db/pg_chameleon/pg_chameleon-2.0.12.ebuild b/dev-db/pg_chameleon/pg_chameleon-2.0.12.ebuild
new file mode 100644
index 0000000..70c3b85
--- /dev/null
+++ b/dev-db/pg_chameleon/pg_chameleon-2.0.12.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="MySQL to PostgreSQL replica system"
+HOMEPAGE="https://pgchameleon.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ >=dev-python/daemonize-2.4.7[${PYTHON_USEDEP}]
+ >=dev-python/mysql-replication-0.15[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.8.3[${PYTHON_USEDEP}]
+ >=dev-python/pymysql-0.7.11[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1.2[${PYTHON_USEDEP}]
+ >=dev-python/rollbar-0.13.17[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.1[${PYTHON_USEDEP}]"
+BDEPEND=""
diff --git a/dev-python/daemonize/Manifest b/dev-python/daemonize/Manifest
new file mode 100644
index 0000000..28f928b
--- /dev/null
+++ b/dev-python/daemonize/Manifest
@@ -0,0 +1,2 @@
+DIST daemonize-2.5.0.tar.gz 10126 BLAKE2B 10e13f93825309d48ef67d0725ed53dcca2220b3940b3b81e1e7f29cf7b6d89af40f94488a2398bec74c0f6235ef8b1626871bda4fb33c233a872a9ccea47558 SHA512 c17a14c073e22fc98b3663da207238d183c12e95750f14cddcf90419c51c95ebc36251bb95d0bb4db84a2fb243499329473e7d14172d855d3ee204757a2a1a65
+EBUILD daemonize-2.5.0.ebuild 434 BLAKE2B 0ce82e05db0123402a7f13fa0ccb745d400219fcd25ea14686f6e3e084059ae2b4b2e0257bcee20e01fc2ec3f1e92d9b9bde77db98f398b3d4550af5ff76e25a SHA512 474e031d767ac44eb51e018b785a99d3f42080f8f7c0582c2038ecac419d45fd1413e5bc81c8ef018243137cf9acd541a4c4e78ddd9e81d4668735c7c1e45668
diff --git a/dev-python/daemonize/daemonize-2.5.0.ebuild b/dev-python/daemonize/daemonize-2.5.0.ebuild
new file mode 100644
index 0000000..04bd72b
--- /dev/null
+++ b/dev-python/daemonize/daemonize-2.5.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for writing system daemons in Python"
+HOMEPAGE="https://github.com/thesharp/daemonize"
+SRC_URI="https://github.com/thesharp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests nose
diff --git a/dev-python/mysql-replication/Manifest b/dev-python/mysql-replication/Manifest
new file mode 100644
index 0000000..c73e72b
--- /dev/null
+++ b/dev-python/mysql-replication/Manifest
@@ -0,0 +1,2 @@
+DIST mysql-replication-0.21.tar.gz 38080 BLAKE2B 9f396d7a886af3aff114a672de5e548f770bfb45d6a87196f8eae4234a17a602ffd024cd795c57dbcb5a693adecf4f57db1c5e37589d891435602fcc23efb98e SHA512 6ecbebb0d964fc2bd173851c47310414b43cd98227e357d4657b71f93391e8dcacef6ae6b2b7b4ff933922c310d85347ba551af051470d4175e74e8f19a20c61
+EBUILD mysql-replication-0.21.ebuild 440 BLAKE2B f0fed534adb0bafdf60f77562208088df05b860b432386d43f4ffa38b4726c1e92b3e310fb232990709cbd2478845de57d3b24cc7c68af43d9c7bedb347e89d9 SHA512 17d5cf706f70e099fa3440537e84fc80ac797ca65096b12cbd9deb7fab4fa858e9b106a056428d43b39e1f88d2f5e111b71749c3eb9a379cc55f8ec024cb10c6
diff --git a/dev-python/mysql-replication/mysql-replication-0.21.ebuild b/dev-python/mysql-replication/mysql-replication-0.21.ebuild
new file mode 100644
index 0000000..e279a4b
--- /dev/null
+++ b/dev-python/mysql-replication/mysql-replication-0.21.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure Python Implementation of MySQL replication protocol build on top of PyMYSQL"
+HOMEPAGE="https://github.com/noplay/python-mysql-replication"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
diff --git a/dev-python/rollbar/Manifest b/dev-python/rollbar/Manifest
new file mode 100644
index 0000000..96e9efa
--- /dev/null
+++ b/dev-python/rollbar/Manifest
@@ -0,0 +1,2 @@
+DIST rollbar-0.15.0.tar.gz 50665 BLAKE2B 3f0c5300a2ee2d3563df80b83792e4ca6d0410d820f560e4f90d7d0e4d50caba6baecc633bd3d48c54144c8cd2706e9ad21f7d3a132d724d8a0748251a2f6bac SHA512 5c38ca56a0081553564a06625d5595b92d85cbf8763bb5b5dc9d51712bda2ff24c1443004e60e69dc0a6de96dc6c81dc8c07009132281eb4821e7e9ea1ef71c6
+EBUILD rollbar-0.15.0.ebuild 388 BLAKE2B 42f199b005c2620ba00d9c6fceff0ea880028318813fd06a3e938dd91e9605d65ece1c5dda2c940f76667315ad6821a2eb7bfbea2ae83b98121abd81027e7f57 SHA512 45f1da42dcf2f43b6bee42f694e79cf688c6a266ddd92d1a847591a8b9baafb87f4d9f1610899beb8c26e6f1cc718a97911875d8d5e3b39963ea88461fcf3eca
diff --git a/dev-python/rollbar/rollbar-0.15.0.ebuild b/dev-python/rollbar/rollbar-0.15.0.ebuild
new file mode 100644
index 0000000..14ab4ad
--- /dev/null
+++ b/dev-python/rollbar/rollbar-0.15.0.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Error tracking and logging from Python to Rollbar"
+HOMEPAGE="https://github.com/rollbar/pyrollbar"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""