summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Goodliffe <dan@randomdan.homeip.net>2016-12-19 17:09:22 +0000
committerDan Goodliffe <dan@randomdan.homeip.net>2016-12-19 17:09:22 +0000
commitaf10def582e352541e1d3c9700ef89c4319bb77e (patch)
tree97e9331076c8361fa2eaf52a3bee92d6d897a3e8
parentpgadmin3-1.22.2 (diff)
downloadportage-af10def582e352541e1d3c9700ef89c4319bb77e.tar.bz2
portage-af10def582e352541e1d3c9700ef89c4319bb77e.tar.xz
portage-af10def582e352541e1d3c9700ef89c4319bb77e.zip
Add pglogical
-rw-r--r--dev-db/pglogical/Manifest3
-rw-r--r--dev-db/pglogical/files/32bit.patch72
-rw-r--r--dev-db/pglogical/pglogical-1.2.1.ebuild30
3 files changed, 105 insertions, 0 deletions
diff --git a/dev-db/pglogical/Manifest b/dev-db/pglogical/Manifest
new file mode 100644
index 0000000..c9bd46a
--- /dev/null
+++ b/dev-db/pglogical/Manifest
@@ -0,0 +1,3 @@
+AUX 32bit.patch 3217 SHA256 50c10ee0f004060c13fd828aeb027ba8cd82507532a911debf8da4e99af2db36 SHA512 87a77b97a827adac2f54961b3a7cbf2c89aa5987dbc2d2eee676eb7fe37ca7eba811df43f6738ba24f4128b1a4b90c8094846e7b6d670a6f8436a83d9ef51ebf WHIRLPOOL 1aee05a7a2f75e0fe8e372462f3fa8d35d3a4720b193de16edee27c698aee2e86ea9dbf9c54c78423d205eef06e4061d2c452c09f3759d6c780ea9f8713234e2
+DIST pglogical-1.2.1.tar.gz 206658 SHA256 079b4b45ca18325321ad949c650f21ef142edf22a078047083896652fb829fff SHA512 9fded00d1fce0df86b8cb2d57b03555fa4fa0752b335f50e4a7fab664ab99a803080695a797d60e5efedf705a5302dfc81fec2f3a6618930e680d37892405bd2 WHIRLPOOL c70743784f01e4a1d6ffd7c0f862485cb48d2f38723eade2a461931486a7e07814c273ea12bd25dc957043e614e627b281b0b850e7b1e5cbfdd230baa5e88b4b
+EBUILD pglogical-1.2.1.ebuild 621 SHA256 f35037ba9fc736d7d8e4255e33c7695eb5f6335581c08d6ea57a3517232f4e09 SHA512 1b49f4ab0a6aa1a56d09fe6274f22c022ef04f7f2e107c15fb3b73ed93fc5bb25bfcd20a2ec0707858dd0694bd35d7c5079da6ec8a69fd6181b8ea1449466160 WHIRLPOOL cb6351b4ad6081683f39d2847592a965d463b8eb1c1e2c202d5a496cf7cf08707dcdebc7b5a417510a57681d44c7e142c7f6bd42580a372904cc545be80b48a5
diff --git a/dev-db/pglogical/files/32bit.patch b/dev-db/pglogical/files/32bit.patch
new file mode 100644
index 0000000..22bf335
--- /dev/null
+++ b/dev-db/pglogical/files/32bit.patch
@@ -0,0 +1,72 @@
+From f0df3fb519835c7b5893fdf3a6583e0aa859f38d Mon Sep 17 00:00:00 2001
+From: Dan Goodliffe <dan@randomdan.homeip.net>
+Date: Mon, 19 Dec 2016 16:14:27 +0000
+Subject: [PATCH] Fix elog format string for 32bit architectures
+
+---
+ pglogical_manager.c | 2 +-
+ pglogical_worker.c | 10 +++++-----
+ 2 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/pglogical_manager.c b/pglogical_manager.c
+index 6de68ad..74e8356 100644
+--- a/pglogical_manager.c
++++ b/pglogical_manager.c
+@@ -156,7 +156,7 @@ manage_apply_workers(void)
+ /* Cleanup old info about crashed apply workers. */
+ if (worker && worker->crashed_at != 0)
+ {
+- elog(DEBUG2, "cleaning pglogical worker slot %ld",
++ elog(DEBUG2, "cleaning pglogical worker slot %zu",
+ (worker - &PGLogicalCtx->workers[0]));
+ worker->worker_type = PGLOGICAL_WORKER_NONE;
+ worker->crashed_at = 0;
+diff --git a/pglogical_worker.c b/pglogical_worker.c
+index 040b515..d9cc7da 100644
+--- a/pglogical_worker.c
++++ b/pglogical_worker.c
+@@ -203,7 +203,7 @@ wait_for_worker_startup(PGLogicalWorker *worker,
+
+ if (status == BGWH_STARTED && pglogical_worker_running(worker))
+ {
+- elog(DEBUG2, "%s worker at slot %ld started with pid %d and attached to shmem",
++ elog(DEBUG2, "%s worker at slot %zu started with pid %d and attached to shmem",
+ pglogical_worker_type_name(worker->worker_type), (worker - &PGLogicalCtx->workers[0]), pid);
+ break;
+ }
+@@ -241,7 +241,7 @@ wait_for_worker_startup(PGLogicalWorker *worker,
+ * attaching to shmem so it didn't set crashed_at. Mark it
+ * crashed so the slot can be re-used.
+ */
+- elog(DEBUG2, "%s worker at slot %ld exited prematurely",
++ elog(DEBUG2, "%s worker at slot %zu exited prematurely",
+ pglogical_worker_type_name(worker->worker_type), (worker - &PGLogicalCtx->workers[0]));
+ worker->crashed_at = GetCurrentTimestamp();
+ }
+@@ -252,7 +252,7 @@ wait_for_worker_startup(PGLogicalWorker *worker,
+ * replaced. Either way, we don't care, we're only looking for crashes before
+ * shmem attach.
+ */
+- elog(DEBUG2, "%s worker at slot %ld exited before we noticed it started",
++ elog(DEBUG2, "%s worker at slot %zu exited before we noticed it started",
+ pglogical_worker_type_name(worker->worker_type), (worker - &PGLogicalCtx->workers[0]));
+ }
+ break;
+@@ -336,7 +336,7 @@ pglogical_worker_detach(bool crash)
+ Assert(MyPGLogicalWorker->generation == MyPGLogicalWorkerGeneration);
+ MyPGLogicalWorker->proc = NULL;
+
+- elog(LOG, "%s worker [%d] at slot %ld generation %hu %s",
++ elog(LOG, "%s worker [%d] at slot %zu generation %hu %s",
+ pglogical_worker_type_name(MyPGLogicalWorker->worker_type),
+ MyProcPid, MyPGLogicalWorker - &PGLogicalCtx->workers[0],
+ MyPGLogicalWorkerGeneration,
+@@ -506,7 +506,7 @@ pglogical_worker_kill(PGLogicalWorker *worker)
+ Assert(LWLockHeldByMe(PGLogicalCtx->lock));
+ if (pglogical_worker_running(worker))
+ {
+- elog(DEBUG2, "killing pglogical %s worker [%d] at slot %ld",
++ elog(DEBUG2, "killing pglogical %s worker [%d] at slot %zu",
+ pglogical_worker_type_name(worker->worker_type),
+ worker->proc->pid, (worker - &PGLogicalCtx->workers[0]));
+ kill(worker->proc->pid, SIGTERM);
diff --git a/dev-db/pglogical/pglogical-1.2.1.ebuild b/dev-db/pglogical/pglogical-1.2.1.ebuild
new file mode 100644
index 0000000..ca7be1b
--- /dev/null
+++ b/dev-db/pglogical/pglogical-1.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Logical Replication extension for PostgreSQL 9.4, 9.5 and 9.6 (Postgres)"
+HOMEPAGE="https://github.com/2ndQuadrant/pglogical"
+SRC_URI="https://github.com/2ndQuadrant/${PN}/archive/REL${PV//./_}.tar.gz -> ${P}.tar.gz"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="=dev-db/postgresql-9.6*[server,static-libs]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-REL${PV//./_}/"
+
+src_prepare() {
+ epatch ${FILESDIR}/32bit.patch
+}
+
+src_compile() {
+ emake USE_PGXS=1
+}
+