summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Goodliffe <dan.goodliffe@octal.co.uk>2022-09-29 11:05:04 +0100
committerDan Goodliffe <dan.goodliffe@octal.co.uk>2022-09-29 11:05:04 +0100
commit670e1b1ce5d42d4861e41de3421412d451abfb54 (patch)
tree194f1c3eff697cd76c4181374dbb6b180378b6e7
parentWildcard not support, focus on crmsh cos parallax (diff)
downloadportage-670e1b1ce5d42d4861e41de3421412d451abfb54.tar.bz2
portage-670e1b1ce5d42d4861e41de3421412d451abfb54.tar.xz
portage-670e1b1ce5d42d4861e41de3421412d451abfb54.zip
Drop need for python9 parallax/crmsh with ebuild from bug #845771
-rw-r--r--dev-python/parallax/Manifest2
-rw-r--r--dev-python/parallax/parallax-1.0.6.ebuild16
-rw-r--r--profiles/base/server/package.use4
3 files changed, 8 insertions, 14 deletions
diff --git a/dev-python/parallax/Manifest b/dev-python/parallax/Manifest
index 11519f3..c1073e0 100644
--- a/dev-python/parallax/Manifest
+++ b/dev-python/parallax/Manifest
@@ -1,2 +1,2 @@
DIST parallax-1.0.6.tar.gz 17371 BLAKE2B 7540b7248ddeecbef79bf6d302043c48e5aa228a9c217aa0df3161d399d326d8e5da7e06906ac1bd715976dd65d5282302c73df84d00d64de525e4e16a37ffdd SHA512 01f45d5fd801b5525adec12655e620219f8c2ccb9390b82ca78f19a7489278121dd45de6be387034da3691d9ccb1e8f912859c31e85a82bccd1a789da830349e
-EBUILD parallax-1.0.6.ebuild 384 BLAKE2B 317c8a3b083a746dceafd50442006cc0bd7b3a641beffd84c2f6a6f04893f9d0a32ba1e20abe22d2800c41a09db8b61bb6f9d564859614a5b40f24ba35600e10 SHA512 c7d5215cfbbb8bc026c040b6baa9cc9a3447fff7da9b756b05fffdda6072b261281ae65287c5735d4857f177ec7240a7735ffd2976fe2e4b034f64be170dabdf
+EBUILD parallax-1.0.6.ebuild 418 BLAKE2B 35cc4497ff55b8fec0eca9ed7601f55c6c72d33a80fdecb3113f92ad1db3fa856f6bc4a93ede0bfedec640c9cedcda7982e3aed9644cb4b08508c0f5831a10f9 SHA512 9ce818805edc2e40777e3678911815f4929430d1e3572fe438e792b496d96735348766f09963405dd68830a7041b24543de5b85f7b9f2bf9859738466b0c8a7a
diff --git a/dev-python/parallax/parallax-1.0.6.ebuild b/dev-python/parallax/parallax-1.0.6.ebuild
index 83495ff..9e7296c 100644
--- a/dev-python/parallax/parallax-1.0.6.ebuild
+++ b/dev-python/parallax/parallax-1.0.6.ebuild
@@ -1,17 +1,15 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6..9} )
-
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
-DESCRIPTION="Error tracking and logging from Python to Rollbar"
-HOMEPAGE="https://github.com/krig/parallax"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+DESCRIPTION="Execute commands and copy files over SSH to multiple machines at once"
+HOMEPAGE="https://github.com/krig/parallax/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
-LICENSE="MIT"
+LICENSE="all-rights-reserved"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
+KEYWORDS="~amd64 ~hppa ~x86"
diff --git a/profiles/base/server/package.use b/profiles/base/server/package.use
index a36c27e..72ddf38 100644
--- a/profiles/base/server/package.use
+++ b/profiles/base/server/package.use
@@ -16,7 +16,3 @@ net-proxy/haproxy -slz
sys-cluster/netfs server client
sys-devel/clang static-analyzer
sys-kernel/linux-firmware savedconfig
-
-# Cos dev-python/parallax
-sys-cluster/crmsh PYTHON_TARGETS: -* python3_9
-sys-cluster/crmsh PYTHON_SINGLE_TARGET: -* python3_9