summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorrandomdan <randomdan@localhost>2011-08-28 13:03:31 +0000
committerrandomdan <randomdan@localhost>2011-08-28 13:03:31 +0000
commit2e5009e1f87a1a02fd7fcd6b22ae1917348c07ae (patch)
treea164e376e480a19b11fb6421fc942c3d5119b41c
parentAdd deps for drivers (diff)
downloadportage-2e5009e1f87a1a02fd7fcd6b22ae1917348c07ae.tar.bz2
portage-2e5009e1f87a1a02fd7fcd6b22ae1917348c07ae.tar.xz
portage-2e5009e1f87a1a02fd7fcd6b22ae1917348c07ae.zip
Now in official tree
-rw-r--r--sys-boot/grub/Manifest4
-rw-r--r--sys-boot/grub/files/defaults30
-rw-r--r--sys-boot/grub/files/grub.conf.gentoo16
-rw-r--r--sys-boot/grub/grub-1.99.ebuild90
4 files changed, 0 insertions, 140 deletions
diff --git a/sys-boot/grub/Manifest b/sys-boot/grub/Manifest
deleted file mode 100644
index 235069a..0000000
--- a/sys-boot/grub/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX defaults 1020 RMD160 48ce6914d693bef9db7f41afecb92c18715ffb7f SHA1 af556abd7deb0d0939f4766df265aa6882707cbe SHA256 302a0cfa6e1f6acf52f5d558cd03f3631313a4b95de038f10f740439ea0a921f
-AUX grub.conf.gentoo 627 RMD160 d90fb4373bad476f98ec9c5065d6cdfd9e3b706f SHA1 004f2fc04605ec9190de0a87e7df8bbc33daff89 SHA256 914b15af252210a32776196437cd8013e10e57d5780e66877ef3fe9a2b4b9776
-DIST grub-1.99.tar.gz 4652619 RMD160 63293381ac2ed2479ac65896d4744b866e6d216c SHA1 6d0536da38224e7caf94cf2531a5f921ac057b9b SHA256 b91f420f2c51f6155e088e34ff99bea09cc1fb89585cf7c0179644e57abd28ff
-EBUILD grub-1.99.ebuild 2589 RMD160 95269dabd78641a27711832628f860e351d4183c SHA1 3643f9e4cef700529ac1a90039c6d2edb0295ab8 SHA256 21d366b4d7ed590c0bcb719c425e83c52ded0d1d8815d01c50f370c0791f9b34
diff --git a/sys-boot/grub/files/defaults b/sys-boot/grub/files/defaults
deleted file mode 100644
index 25e5909..0000000
--- a/sys-boot/grub/files/defaults
+++ /dev/null
@@ -1,30 +0,0 @@
-# /etc/defaults/grub
-# If you change this file, run 'grub-mkconfig -o /boot/grub/grub.cfg'
-# afterwords to update /boot/grub/grub.cfg. Make sure your /boot is
-# mounted rw before executing this command.
-#
-# See the grub info page for documentation on possible variables and
-# their associated values. This wiki also has random bits of info:
-# http://en.gentoo-wiki.com/wiki/Grub2#Using_variables
-
-GRUB_DEFAULT=0
-GRUB_HIDDEN_TIMEOUT=0
-GRUB_HIDDEN_TIMEOUT_QUIET=true
-GRUB_TIMEOUT=10
-
-GRUB_CMDLINE_LINUX_DEFAULT=""
-GRUB_CMDLINE_LINUX=""
-
-# Uncomment to disable graphical terminal (grub-pc only)
-#GRUB_TERMINAL=console
-
-# The resolution used on graphical terminal
-# note that you can use only modes which your graphic card supports via VBE
-# you can see them in real GRUB with the command `vbeinfo'
-#GRUB_GFXMODE=640x480
-
-# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
-#GRUB_DISABLE_LINUX_UUID=true
-
-# Uncomment to disable generation of recovery mode menu entrys
-#GRUB_DISABLE_RECOVERY=true
diff --git a/sys-boot/grub/files/grub.conf.gentoo b/sys-boot/grub/files/grub.conf.gentoo
deleted file mode 100644
index 0027099..0000000
--- a/sys-boot/grub/files/grub.conf.gentoo
+++ /dev/null
@@ -1,16 +0,0 @@
-# This is a sample grub.conf for use with Genkernel, per the Gentoo handbook
-# http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1&chap=10#doc_chap2
-# If you are not using Genkernel and you need help creating this file, you
-# should consult the handbook. Alternatively, consult the grub.conf.sample that
-# is included with the Grub documentation.
-
-default 0
-timeout 30
-#splashimage=(hd0,0)/boot/grub/splash.xpm.gz
-
-#title Gentoo Linux 2.6.24-r5
-#root (hd0,0)
-#kernel /boot/kernel-genkernel-x86-2.6.24-gentoo-r5 root=/dev/ram0 real_root=/dev/sda3
-#initrd /boot/initramfs-genkernel-x86-2.6.24-gentoo-r5
-
-# vim:ft=conf:
diff --git a/sys-boot/grub/grub-1.99.ebuild b/sys-boot/grub/grub-1.99.ebuild
deleted file mode 100644
index d3c3d94..0000000
--- a/sys-boot/grub/grub-1.99.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-1.99_rc1.ebuild,v 1.3 2011/04/10 14:34:42 ulm Exp $
-
-# XXX: need to implement a grub.conf migration in pkg_postinst before we ~arch
-
-inherit mount-boot eutils flag-o-matic toolchain-funcs
-
-MY_P=${P/_/\~}
-SRC_URI="ftp://ftp.gnu.org/gnu/${PN}/${MY_P}.tar.gz mirror://gentoo/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="GNU GRUB 2 boot loader"
-HOMEPAGE="http://www.gnu.org/software/grub/"
-
-LICENSE="GPL-3"
-use multislot && SLOT="2" || SLOT="0"
-KEYWORDS="~x86"
-IUSE="custom-cflags debug truetype multislot static"
-
-RDEPEND=">=sys-libs/ncurses-5.2-r5
- dev-libs/lzo
- truetype? ( media-libs/freetype >=media-fonts/unifont-5 )"
-DEPEND="${RDEPEND}
- >=sys-devel/autogen-5.10
- >=dev-lang/python-2.5.2"
-
-export STRIP_MASK="*/grub/*/*.mod"
-QA_EXECSTACK="sbin/grub-probe sbin/grub-setup sbin/grub-mkdevicemap bin/grub-script-check bin/grub-fstest"
-
-src_compile() {
- use custom-cflags || unset CFLAGS CPPFLAGS LDFLAGS
- use static && append-ldflags -static
-
- econf \
- --disable-werror \
- --sbindir=/sbin \
- --bindir=/bin \
- --libdir=/$(get_libdir) \
- --disable-efiemu \
- $(use_enable truetype grub-mkfont) \
- $(use_enable debug mm-debug) \
- $(use_enable debug grub-emu) \
- $(use_enable debug grub-emu-usb) \
- $(use_enable debug grub-fstest)
- emake -j1 || die "making regular stuff"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README THANKS TODO
- cat <<-EOF >> "${D}"/lib*/grub/grub-mkconfig_lib
- GRUB_DISTRIBUTOR="Gentoo"
- EOF
- if use multislot ; then
- sed -i "s:grub-install:grub2-install:" "${D}"/sbin/grub-install || die
- mv "${D}"/sbin/grub{,2}-install || die
- mv "${D}"/sbin/grub{,2}-set-default || die
- mv "${D}"/usr/share/man/man8/grub{,2}-install.8 || die
- mv "${D}"/usr/share/info/grub{,2}.info || die
- fi
-}
-
-setup_boot_dir() {
- local boot_dir=$1
- local dir=${boot_dir}/grub
-
- if [[ ! -e ${dir}/grub.cfg ]] ; then
- einfo "Running: grub-mkconfig -o '${dir}/grub.cfg'"
- grub-mkconfig -o "${dir}/grub.cfg"
- fi
-
- #local install=grub-install
- #use multislot && install="grub2-install --grub-setup=/bin/true"
- #einfo "Running: ${install} "
- #${install}
-}
-
-pkg_postinst() {
- mount-boot_mount_boot_partition
-
- if use multislot ; then
- elog "You have installed grub2 with USE=multislot, so to coexist"
- elog "with grub1, the grub2 install binary is named grub2-install."
- fi
- setup_boot_dir "${ROOT}"boot
-
- # needs to be after we call setup_boot_dir
- mount-boot_pkg_postinst
-}