summaryrefslogtreecommitdiff
path: root/dev-util/qtkeychain/qtkeychain-0.10.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/qtkeychain/qtkeychain-0.10.0.ebuild')
-rw-r--r--dev-util/qtkeychain/qtkeychain-0.10.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/qtkeychain/qtkeychain-0.10.0.ebuild b/dev-util/qtkeychain/qtkeychain-0.10.0.ebuild
new file mode 100644
index 0000000..82a4590
--- /dev/null
+++ b/dev-util/qtkeychain/qtkeychain-0.10.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+RESTRICT="mirror"
+
+DESCRIPTION="qtkeychain - Platform-independent Qt API for storing passwords securely"
+HOMEPAGE="https://github.com/frankosterfeld/qtkeychain"
+SRC_URI="https://github.com/frankosterfeld/qtkeychain/archive/v${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+qt5"
+REQUIRE_USE="qt5 ( xcb )"
+
+RDEPEND="
+ dev-qt/qtcore:5"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/qtkeychain-${PV}"
+
+src_configure() {
+ local mycmakeargs=()
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+}