summaryrefslogtreecommitdiff
path: root/dev-util/hotspot/hotspot-1.5.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/hotspot/hotspot-1.5.1-r1.ebuild')
-rw-r--r--dev-util/hotspot/hotspot-1.5.1-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-util/hotspot/hotspot-1.5.1-r1.ebuild b/dev-util/hotspot/hotspot-1.5.1-r1.ebuild
new file mode 100644
index 0000000..fd745a1
--- /dev/null
+++ b/dev-util/hotspot/hotspot-1.5.1-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake
+
+RESTRICT="mirror"
+
+DESCRIPTION="Hotspot - the Linux perf GUI for performance analysis"
+HOMEPAGE="https://github.com/KDAB/hotspot"
+vperfparser="851ebf0a033e73854c934d150a120f013bae2a66"
+vprefixticklabels="6e86393f546429113e4ee78f7702eb820b21a0d2"
+SRC_URI="https://github.com/KDAB/${PN}/archive/refs/tags/v${PV}.tar.gz
+ https://github.com/KDAB/perfparser/archive/${vperfparser}.tar.gz
+ https://github.com/koenpoppe/PrefixTickLabels/archive/${vprefixticklabels}.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE=""
+REQUIRE_USE=""
+
+RDEPEND="
+ >=dev-qt/qtcore-5.15.0
+ >=dev-qt/qtwidgets-5.15.0
+ >=dev-qt/qtnetwork-5.15.0
+ >=dev-qt/qttest-5.15.0
+ virtual/libelf
+ sys-devel/gettext
+ kde-frameworks/extra-cmake-modules
+ kde-frameworks/threadweaver:5
+ kde-frameworks/ki18n:5
+ kde-frameworks/kconfigwidgets:5
+ kde-frameworks/kcoreaddons:5
+ kde-frameworks/kitemviews:5
+ kde-frameworks/kitemmodels:5
+ kde-frameworks/kio:5
+ kde-frameworks/solid:5
+ kde-frameworks/kwindowsystem:5
+ kde-frameworks/KDDockWidgets
+ dev-util/perf
+ dev-libs/qcustomplot
+ media-gfx/kgraphviewer
+ "
+
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ default
+ rmdir ${S}/3rdparty/perfparser ${S}/3rdparty/PrefixTickLabels
+ ln -sf ${WORKDIR}/perfparser-${vperfparser} ${S}/3rdparty/perfparser
+ ln -sf ${WORKDIR}/PrefixTickLabels-${vprefixticklabels} ${S}/3rdparty/PrefixTickLabels
+}