From 92c901c1b6fd83039337323bb90bba7f142bcc9b Mon Sep 17 00:00:00 2001
From: Dan Goodliffe <dan@randomdan.homeip.net>
Date: Sat, 27 Jan 2018 13:59:04 +0000
Subject: Add a fork of ocfs2-tools with some fixes in place

---
 sys-fs/ocfs2-tools/Manifest                   |   4 +
 sys-fs/ocfs2-tools/files/ocfs2.confd          |  37 ++++++++
 sys-fs/ocfs2-tools/files/ocfs2.initd          | 124 ++++++++++++++++++++++++++
 sys-fs/ocfs2-tools/ocfs2-tools-1.8.4.1.ebuild |  68 ++++++++++++++
 4 files changed, 233 insertions(+)
 create mode 100644 sys-fs/ocfs2-tools/Manifest
 create mode 100644 sys-fs/ocfs2-tools/files/ocfs2.confd
 create mode 100644 sys-fs/ocfs2-tools/files/ocfs2.initd
 create mode 100644 sys-fs/ocfs2-tools/ocfs2-tools-1.8.4.1.ebuild

diff --git a/sys-fs/ocfs2-tools/Manifest b/sys-fs/ocfs2-tools/Manifest
new file mode 100644
index 0000000..96f2543
--- /dev/null
+++ b/sys-fs/ocfs2-tools/Manifest
@@ -0,0 +1,4 @@
+AUX ocfs2.confd 1494 BLAKE2B 6390651f1d07fb82c98e7058a7ffa1267672fafc64b84fc320d58076de723e6472b4587ec7fd7ad6345a310f225b1a66f50296e39e772ff4a2c22d7fafa6943b SHA512 7cb63e889fad081d41283534032f41413bbb37202391d7a0f08f590170dc7a11c45bd90946910ba7680e401e4cb80eeb70fe85eb55ecbe9c16507e4d3d0b08c9
+AUX ocfs2.initd 4004 BLAKE2B 8d9f839d9ad7607b45e768b95ebc589c0e6fb729d2fff3afac04cd28f5b72f2a2d958c8e9153ae8db7a5cc01dd4a8e397f6514f3fd4f615317ed6acbb2953208 SHA512 ab35d6916871eed469c3e05470dec6913b96bf806fd67d090f5a6af9eb28e4cd648707d768c0a47f6d2926f969421837adf9ef714b336c929b73df785dbfae1b
+DIST ocfs2-tools-1.8.4.1.tar.gz 1481310 BLAKE2B 58ed030055003f60707be342ee23bd1ac0630d9300c351b58789009627dc276740293b9584c4502264f13b77f51fa59dfc6b18b5a4aa618f38f4bf4fffc95721 SHA512 2f7131cd8595e8f495f9321d0ed3370c1355b0795766dc868602b02bc7cf675d131b0fcab27c5cc249f7e92a683b914a566f5f410b4f6b01ec06e7b761a9a2f3
+EBUILD ocfs2-tools-1.8.4.1.ebuild 1492 BLAKE2B 3803d3f54b6b4c802f1f28a6d1957215c7ddff966bd158479825e5e438b1b0da2a4050dea0ab473eabf5b304c5a42df11840f85af9da2b55c7a6f0b79eb9bf8d SHA512 438f9ad709406c3e6af56f4cc2e96cb2594c619961fcf98b9a07f6f058bb88adb36e78a9c001a3c31283e7be25a1f34e73094d17e91b8a03b3d1de3c9c0069ca
diff --git a/sys-fs/ocfs2-tools/files/ocfs2.confd b/sys-fs/ocfs2-tools/files/ocfs2.confd
new file mode 100644
index 0000000..89f7a98
--- /dev/null
+++ b/sys-fs/ocfs2-tools/files/ocfs2.confd
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# Put your cluster names here, separated by space, ie.
+# OCFS2_CLUSTER="cluster1 admincluster cluster2" 
+OCFS2_CLUSTER="home"
+
+# Some heartbeat tweaks to prevent self-fencing quite so much during heavy load.
+# http://oss.oracle.com/projects/ocfs2/dist/documentation/ocfs2_faq.html
+
+# How long to wait before a node is considered dead from lack of network activity.
+OCFS2_IDLE_TIMEOUT_MS="30000"
+# How often we should attempt to send heartbeats.
+OCFS2_KEEPALIVE_DELAY_MS="2000"
+OCFS2_RECONNECT_DELAY_MS="2000"
+# How often we should attempt to send heartbeats.
+# How many interations before a node is considered dead from lack of IO activity.
+# (dead_threshold - 1) * 2s
+OCFS2_DEAD_THRESHOLD="61"
+
+# Default: "-fy" (force check on double-unmounted boot). I beleave this is best.
+# Native way is "-y", but once I have twice reboot/powerOFF with bad result...
+# Affected only fstab.
+OCFS2_FSCK="-fy"
+
+# http://oss.oracle.com/projects/ocfs2-tools/news/article_8.html
+# starting from 1.4.3, fsck.ocfs2 "aggressively cache the metadata blocks"
+# this is useful on lots of free memory, but I have heavy slowdown on x86_64
+# with 1G of RAM.
+# "yes" will "swapoff -a" & "swapon -a" around fsck to avoid caching over swap
+OCFS2_FSCK_SWAPOFF="yes"
+
+# Signal to kill processes on stop/umount on busy device (empty to not kill)
+#OCFS2_UMOUNT_KILL="KILL"
+
+# "yes" to force stop
+#OCFS2_FORCE_STOP="no"
diff --git a/sys-fs/ocfs2-tools/files/ocfs2.initd b/sys-fs/ocfs2-tools/files/ocfs2.initd
new file mode 100644
index 0000000..32ff2e0
--- /dev/null
+++ b/sys-fs/ocfs2-tools/files/ocfs2.initd
@@ -0,0 +1,124 @@
+#!/sbin/openrc-run
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+	need net localmount
+	before netmount 
+}
+
+check_modules_config() {
+	local MODULES=$1
+	local CONFIGS=$2
+	local MODULE
+	local retval=0
+	
+	for MODULE in ${MODULES}; do
+		if ! ls -1 /sys/module | egrep -q "^${MODULE}$"; then
+			retval=1
+		fi
+	done
+	if [ ${retval} -eq 1 ] && [ -e /proc/config.gz ]; then
+		retval=0
+		for MODULE in ${CONFIGS}; do
+			if ! gzip -dc /proc/config.gz | egrep -q "^CONFIG_${MODULE}=y$"; then
+				retval=1
+			fi
+		done
+	fi
+	return ${retval}
+}
+
+check_modules() {
+	check_modules_config "ocfs2_dlmfs ocfs2 ocfs2_dlm ocfs2_nodemanager" "OCFS2_FS OCFS2_FS_O2CB" && check_modules_config configfs CONFIGFS_FS && return 0
+	if ! egrep -q '\s*ocfs2\s*$' /proc/filesystems || ! egrep -q '\s*ocfs2_dlmfs\s*$' /proc/filesystems; then 
+		ewarn "One or more required modules are not loaded."
+                ewarn "Make sure you have "
+                ewarn " - placed ocfs, dlmfs and configfs into /etc/modules.autoload.d/kernel-2.6 or built directly into the kernel."
+                ewarn "For a (in)complete documentation, read /usr/share/doc/ocfs-<version>/INSTALL.GENTOO.bz2"
+	fi
+	return 1
+}
+
+check_pseudofs() { 
+	local retval=0
+	local HASMOUNT="mount -l -t"
+	if [ -z "`${HASMOUNT} configfs`" ] ; then
+		retval=1
+	fi
+	if [ -z "`${HASMOUNT} ocfs2_dlmfs`" ] ; then
+		retval=1
+	fi
+
+	if [ ${retval} -eq 1 ]; then
+		ewarn "One or more pseudo-filesystes are not mounted."
+		ewarn "Make sure you have following lines in your /etc/fstab:"
+		ewarn "none         /sys/kernel/config         configfs        defaults                0 0"
+		ewarn "none         /sys/kernel/dlm            ocfs2_dlmfs     defaults                0 0"
+	fi
+	return ${retval}
+}
+
+
+
+start() {
+	check_modules || return $? 
+	check_pseudofs || return $?
+	
+	einfo "Starting OCFS2 cluster"
+	for cluster in ${OCFS2_CLUSTER}; do
+		ebegin " - ${cluster}"
+		/sbin/o2cb_ctl -H -n ${cluster} -t cluster -a online=yes >/dev/null 2>&1
+		eend $?
+
+		# Some heartbeat tweaks to prevent self-fencing quite so much during heavy load.
+		# http://oss.oracle.com/projects/ocfs2/dist/documentation/ocfs2_faq.html
+
+		# How long to wait before a node is considered dead from lack of network activity.
+		echo $OCFS2_IDLE_TIMEOUT_MS > /sys/kernel/config/cluster/${cluster}/idle_timeout_ms
+		# How often we should attempt to send heartbeats.
+		echo $OCFS2_KEEPALIVE_DELAY_MS > /sys/kernel/config/cluster/${cluster}/keepalive_delay_ms
+		echo $OCFS2_RECONNECT_DELAY_MS > /sys/kernel/config/cluster/${cluster}/reconnect_delay_ms
+		# How many interations before a node is considered dead from lack of IO activity.
+		# (dead_threshold - 1) * 2s
+		echo $OCFS2_DEAD_THRESHOLD > /sys/kernel/config/cluster/${cluster}/heartbeat/dead_threshold
+	done
+	sleep 2
+}
+
+stop() {
+	# Shamelesly stolen from netmount
+        local ret
+        ebegin "Unmounting OCFS2 filesystems"
+        [ -z "$(umount -art ocfs2 2>&1)" ]
+        ret=$?
+        eend ${ret} "Failed to simply unmount filesystems"
+        [ ${ret} -eq 0 ] && return 0
+
+        declare -a siglist=( "TERM" "KILL" "KILL" )
+        local retry=0
+        local remaining="go"
+
+        while [ -n "${remaining}" -a ${retry} -lt 3 ]
+        do
+                remaining="$(awk '$3 ~ /'ocfs2'/ { if ($2 != "/") print $2 }' /proc/mounts | sort -r)"
+                IFS=$'\n'
+                set -- ${remaining//\\040/ }
+                unset IFS
+                [ -z "${remaining}" ] && break
+
+                ebegin $'\t'"Unmounting ocfs2 filesystems (retry #$((retry+1)))"
+                /bin/fuser -k -${siglist[$((retry++))]} -m "$@" &>/dev/null
+                sleep 5
+                umount "$@" &>/dev/null
+                eend $? $'\t'"Failed to unmount filesystems"
+        done
+
+	
+	einfo "Stopping OCFS2 cluster" 
+	for cluster in ${OCFS_CLUSTERS}; do
+		ebegin " - ${cluster}"
+		/sbin/o2cb_ctl -H -n ${cluster} -t cluster -a online=no >/dev/null 2>&1
+		eend $?
+	done
+}
diff --git a/sys-fs/ocfs2-tools/ocfs2-tools-1.8.4.1.ebuild b/sys-fs/ocfs2-tools/ocfs2-tools-1.8.4.1.ebuild
new file mode 100644
index 0000000..452bfe8
--- /dev/null
+++ b/sys-fs/ocfs2-tools/ocfs2-tools-1.8.4.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+inherit autotools eutils python-single-r1
+
+DESCRIPTION="Support programs for the Oracle Cluster Filesystem 2"
+HOMEPAGE="http://oss.oracle.com/projects/ocfs2-tools/ https://github.com/rascalDan/ocfs2-tools"
+SRC_URI="https://github.com/rascalDan/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug external gtk"
+
+RDEPEND="
+	dev-libs/libaio
+	sys-apps/util-linux
+	sys-cluster/libcman
+	external? (
+		sys-cluster/libdlm
+		sys-cluster/pacemaker[-heartbeat]
+		)
+	sys-fs/e2fsprogs
+	sys-libs/ncurses
+	sys-libs/readline
+	sys-process/psmisc
+	gtk? (
+		dev-python/pygtk
+	)
+"
+# 99% of deps this thing has is automagic
+# specialy cluster things corosync/pacemaker
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}-${P}"
+
+DOCS=(
+	"${S}/documentation/samples/cluster.conf"
+	"${S}/documentation/users_guide.txt"
+)
+
+MAKEOPTS+=" -j1"
+
+src_prepare() {
+	# gentoo uses /sys/kernel/dlm as dlmfs mountpoint
+	sed -e 's:"/dlm/":"/sys/kernel/dlm":g' \
+		-i libo2dlm/o2dlm_test.c \
+		-i libocfs2/dlm.c || die "sed failed"
+	AT_M4DIR=. eautoreconf
+	default
+}
+
+src_configure() {
+	econf \
+		$(use_enable debug debug) \
+		$(use_enable debug debugexe) \
+		$(use_enable gtk ocfs2console) \
+		--enable-dynamic-fsck \
+		--enable-dynamic-ctl
+}
+
+src_install() {
+	default
+	newinitd "${FILESDIR}/ocfs2.initd" ocfs2
+	newconfd "${FILESDIR}/ocfs2.confd" ocfs2
+}
-- 
cgit v1.2.3